Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Porter

Port Information

  • Submitted: May 13 2017 09:00 AM
  • Last Updated: Jun 13 2017 08:23 AM
  • Views: 1416
  • Downloads: 78

Wrapper Type & Video Card Compatibility

  • Wrapper Type: Wineskin
  • Wine Version: 2.6.2 Wine Staging 2.7
  • ATI / AMD: GREEN (fully playable)
  • NVIDIA: GREEN (fully playable)
  • Intel GMA: GREY (not tested)
  • Intel HD: GREEN (fully playable)

Wrapper Type Info

Note:
Wrappers have different Mac OS X compatibility!

Wineskin:   10.610.710.810.9
Cider:          10.610.710.810.9
CXZ/CXEx:  10.610.710.810.9

What is WINE & what is a Wrapper?

Video Card Info

 GREY          = not tested
 GREEN        = fully playable
 YELLOW     = playable with minor glitches
 ORANGE     = playable with some effort
 RED             = severe glitches / unplayable

Download Wrapper Darksiders I & II (for Sierra) v1

- - - - - Please vote for the Quality of this Port / Wrapper, not for the Game or Application!




Screenshots
This is another port of Darksiders I & II that works with the last MacOS (the link of the old one seems broken).

Darksiders is a single-player action adventure in which the player takes control of War, one of the Four Horsemen of the Apocalypse. In third-person perspective, the player engages in combat, puzzles and exploration. The world is divided into separate locations with many areas at first initially inaccessible until War regains many of his lost weapons and abilities. The center of the world, The Scalding Gallow, acts as a hub where War is given new objectives and paths to further unlock new areas. Each contains a series of linear and non-linear paths, many of which require large sections of platforming, climbing and swimming along environment-based puzzles that impair progress that require the use of newly-gained abilities. He fights mainly against angels and demons, and has a unique way to kill each particular type of enemy, usually tearing them apart painfully.

Personal Notes:
I test Darksiders I with Skidrow and GOG version. All works : movies and menu (that is the challenge in this port !).
I added Darksiders II because the other port seems not working also. It's works with 1.4 version of the game.

My System Specs:
- OS: Mac OS x 10.12.4
- CPU: Core i7 3.5GHz
- RAM: 8 GB.
- Video:    NVIDIA GeForce GTX 780M 4096 Mo
- Disk Space:   10 Go


Known Issues:
Like on many games : the joypad don't work and there's nothing we can do...

Installation:
You may install the game itself with Wineskin. The wrapper is configured to works with the executable in Program Files/Darksiders. Perhaps you may to change the path in Wineskin advanced configuration (look the same thing for Darksiders II).

What's New in Version v1 (See full changelog)

  • 13/05/2017 initial release
  • 12/06/2017 adding Darksiders II


Screenshots

Screenshots


Works Great on Intel HD 4000. No lag or anything, Thank You.
OK. Thanks. I update the video card compatibility.
Finally a Darksiders port that works like a charm. Thanks mate!
Any chance Darksiders 2 is on it's way?
Well, there is a port of Darksiders II on this site, it doesn't work ? I seem to remember that is the base of the one i use.

noxx09, on 06 June 2017 - 08:53 AM, said:

Well, there is a port of Darksiders II on this site, it doesn't work ? I seem to remember that is the base of the one i use.

hmtinc's port? Never worked for me. I'll give it another shot, I had a different Mac back then.

noxx09, on 06 June 2017 - 08:53 AM, said:

Well, there is a port of Darksiders II on this site, it doesn't work ? I seem to remember that is the base of the one i use.

I tried using both this port and hmtinc's port just in case any of them worked with Darksiders 2, but none of them did.
Ok. After verification, it's not the same in fact. So I propose my Darksiders II wrapper. I hope no hurt somebody to do that in the same page ;-)

noxx09, on 12 June 2017 - 04:00 PM, said:

Ok. After verification, it's not the same in fact. So I propose my Darksiders II wrapper. I hope no hurt somebody to do that in the same page ;-)


Thanks mate, but when I install it, it says "Runtime Error" just before completing the installation. I pressed OK, it completed the installation and when I tried opening it, it didn't even appear in the docks.
Could it be because I'm trying the Deathinitive Edition instead of the Standard one?
Perhaps. I've installed the 1.4 version. You can try to install dotnet40 via winetricks : perhaps the setup need this...

noxx09, on 13 June 2017 - 07:25 AM, said:

Perhaps. I've installed the 1.4 version. You can try to install dotnet40 via winetricks : perhaps the setup need this...

Tried with dotnet40. Didn't work. I'll try later with the standard version of the game. I'll let you know how it turns out.



18 user(s) are online (in the past 15 minutes)

1 members, 16 guests, 0 anonymous users


Google, dsdsq