Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

OS X 10.11 El Capitan--flickering screen still present?


  • Please log in to reply
41 replies to this topic

#1 1v9HOJ1ez56B

1v9HOJ1ez56B

    Experienced Member

  • Members
  • PipPip
  • 30 posts
  • Graphics Card:ATI
  • Operating System:Mac OS X 10.7 (Lion)

Posted 05 July 2015 - 08:03 PM

Does the screen still flicker with some older some games in El Capitan?

#2 TheGunSmith13

TheGunSmith13

    Lurker

  • Members
  • 2 posts
  • Graphics Card:Intel Iris
  • Operating System:Other OS/Not specified

Posted 02 October 2015 - 11:44 PM

I had this issue with Dawn of War, but I changed the screen options to NOT use the mac-driver instead of x-11 and it fixed it for this case. Hope this works for you.

#3 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 03 October 2015 - 03:25 AM

The flickering screen issue he mentions is with 2d elements and 2d menus,  particularly in older games.  Yes, it is still in 10.11 as apple doesn't view the rare circumstance that causes it only in wine as a bug. Chances are, it's not going to be fixed. You have three options.

1. use wineskin to change ddr=opengl to ddr=gdi Many times this is ok, but it's quite a performance hit, and anygame that uses 3d hardware accelleration for other parts (Xwing vs tie figher for example) will not work.

2. Build a version of wine with this hack that fixes the issue in wine.  https://bugs.winehq.org/show_bug.cgi?id=34166

3. Use a crossover engine, which has the hack already in place.

#4 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 2,935 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro Core i7 16GB
    AMD Radeon HD 6750M 512MB

    MacBook Core2Duo 4GB
    nVidia 9400M 256MB
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:la rockitar
Author

Posted 04 October 2015 - 08:07 PM

So I've gone ahead and patched the patched Staging github source code and succesfully built the engine. I can confirm that it does indeed work to rectify the flicker. At least on 10.10.5. When I launched DeadPool with Crossover 14.1.8 the developer logo screen appeared and then it would start flickering. I worked around this by using command + enter to go into windowed mode and then back to fullscreen again and it would show the menu screen correctly.

With the new engine the transition from logo screen to main menu is flawless.

Bad news though. I'm currently sitting with power in my apartment and 40% juice left. I get hooked up tomorrow so when I am able to maintain a constant power supply I will make this engine available for everyone. Probably tomorrow afternoon or tomorrow night.
Posted Image

#5 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 04 October 2015 - 08:54 PM

View PostDankoB, on 04 October 2015 - 08:07 PM, said:

When I launched DeadPool with Crossover 14.1.8 the developer logo screen appeared and then it would start flickering. I worked around this by using command + enter to go into windowed mode and then back to fullscreen again and it would show the menu screen correctly.

Strange your crossover engine worked fine for me in Zues, Xwing Series, Stronghold series, and Heroes 3,  all of which have the flicker issue.

#6 NRG

NRG

    Champion Member

  • Members
  • 594 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 04 October 2015 - 08:57 PM

View Postdarklord42, on 04 October 2015 - 08:54 PM, said:

Strange your crossover engine worked fine for me in Zues, Xwing Series, Stronghold series, and Heroes 3,  all of which have the flicker issue.

do you have nvidia or AMD? perhaps depending by mac drivers used...

#7 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 04 October 2015 - 09:25 PM

Nvidia,  but the problem is not driver related, but a little higher up with Apple's OpenGL.

From the bug thread:

Quote

Here's the thing, for some games, WineD3D does something a bit unusual: in circumstances where it's only really interested in using one buffer, it nevertheless creates a double-buffered context.  It then only draws to the front buffer and ignores the back buffer.

This interacts poorly with the assumptions made in Apple's OpenGL optimizations.  Those optimizations assume that, for a double-buffered context, the app will be drawing to the back buffer and swapping it to display it.

The result is that, for each frame, Apple's OpenGL is replacing the good drawing done by WineD3D with the garbage in the uninitialized back buffer.  This is the cause of the horrible flickering.

What WineD3D is doing is unusual but legal.  Apple's OpenGL optimization is therefore buggy.

The Mac driver, prior to commit d30705bd, was unintentionally doing something that was defeating optimizations in Apple's OpenGL.  The one good effect of that was that it prevented the bad optimization from kicking in and causing the flickering.  The obvious bad effect is that it negatively impacted performance of OpenGL graphics.

Commit d30705bd fixed this problem in the Mac driver, allowing Apple's OpenGL optimizations to take effect.  In most cases, this is good.  For those particular games which use this one-buffer-of-a-double-buffered-context technique, it also re-enables the optimization that causes the flickering.  That's unfortunate, but not really the fault of the Mac driver.

Perhaps we are talking about two different flickering issues?  I have never played deadpool but I'm pretty sure it's newer then most of these effected programs.  And is certainly not fixed by going back and forth between windowed and fullscreen. (windowed is fine, but as soon as you went back to full screen you would be suffering again)  I would play with the set screen options and try some of the Override settings.

#8 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 2,935 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro Core i7 16GB
    AMD Radeon HD 6750M 512MB

    MacBook Core2Duo 4GB
    nVidia 9400M 256MB
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:la rockitar
Author

Posted 05 October 2015 - 02:26 PM

I don't think it has the same the flickering issue but the developer logo would be flickering and then it would think the program had gone to menu screen but the logo would remain on screen...weird issue I only came across with the last three CX releases but this patched staging 1.7.52 seems to have fixed the issue...

As soon as the power comes on this afternoon I'll start uploading the engine for others to use...
Posted Image

#9 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 2,935 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro Core i7 16GB
    AMD Radeon HD 6750M 512MB

    MacBook Core2Duo 4GB
    nVidia 9400M 256MB
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:la rockitar
Author

Posted 06 October 2015 - 07:09 AM

I'm not sure if doh123's new Wineskin 2.6.1 update fixes the El Capitan issue with flickering but here's the engine suggested in the post #3

WS9WineStaging1.7.52noflicker: http://www.mediafire...oflicker.tar.7z

Posted Image

#10 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 07 October 2015 - 11:25 PM

So I've been asked to start posting this here rather than in the wine-staging thread.  Makes sense.

So, the deal is that ever since wine-staging 1.7.51 was released, I've been experiencing flickering issues in my Oblivion wrapper.  This is what I'm seeing.  That's with CSMT and D3DBoost turned on, and with the wine-staging-1.7.52 (no flicker) engine installed.  So it would seem that the patch to eliminate flicker did not alleviate my problem.

And, to repost from the other thread, I tried another, completely unrelated game, Anno 1404.  With Staging 1.7.52, the main menu was a mess of flickering textures.  With Staging 1.7.52 (no flicker), the main menu was fine, but there was still a good bit of in-game flickering.  With Staging 1.7.50, no flickering but the game crashed.

There's also some flickering in STALKER Shadow of Chernobyl, even with the no-flicker engine.

Yes, I am running El Capitan, and I have upgraded to the latest Wineskin version, but this issue was affecting me before the upgrade, so I don't believe it's related.

#11 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 25 October 2015 - 06:08 PM

So many games are broken.  Screw it.  I'm going back to Yosemite.

#12 NRG

NRG

    Champion Member

  • Members
  • 594 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 25 October 2015 - 08:04 PM

View Postclocknova, on 25 October 2015 - 06:08 PM, said:

So many games are broken.  Screw it.  I'm going back to Yosemite.

What I know is's that also on yosemite some olds games had the flicker issue

So are you sure that it depends by El Capitan and not by the engine used in the wrapper?

Not necessarily  the latest engine is better out of older... each game may prefer an engine over another ...

#13 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 26 October 2015 - 01:18 AM

It's not just Wineskin games, though.  Quite a few Unity games, like Pillars of Eternity, no longer work properly either.

#14 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 26 October 2015 - 03:26 AM

Really? Ultimate Civil war general, Kerbal Space Program, and WIngCommander flat Universe all work fine for me.  I have no idea what the heck you are experiencing.

#15 NRG

NRG

    Champion Member

  • Members
  • 594 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 26 October 2015 - 07:55 AM

View Postclocknova, on 25 October 2015 - 06:08 PM, said:

So many games are broken.  Screw it.  I'm going back to Yosemite.

View PostNRG, on 25 October 2015 - 08:04 PM, said:

What I know is's that also on yosemite some olds games had the flicker issue

So are you sure that it depends by El Capitan and not by the engine used in the wrapper?

Not necessarily  the latest engine is better out of older... each game may prefer an engine over another ...

View Postclocknova, on 26 October 2015 - 01:18 AM, said:

It's not just Wineskin games, though.  Quite a few Unity games, like Pillars of Eternity, no longer work properly either.


What driver do you use? Native OS X 10.11 drivers or Nvidia Web Drivers for 10.11?

#16 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 26 October 2015 - 07:38 PM

I tried both, but both lead to the same thing.  Actually, I had to switch right back to El Capitan; to many other things relating to productivity and important data became broken or screwed up by switching back.  Guess I'll just have to wait for Apple to fix the issue.  Obsidian claims the problem with Pillars of Eternity cannot be fixed in house; Apple has to do it.  Sigh.

#17 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 26 October 2015 - 08:12 PM

View Postdarklord42, on 26 October 2015 - 03:26 AM, said:

Really? Ultimate Civil war general, Kerbal Space Program, and WIngCommander flat Universe all work fine for me.  I have no idea what the heck you are experiencing.

I think the problem actually depends on what graphic card you have.  What happens is that, when affected games are running in fullscreen mode, the graphics do not get drawn to screen.  The screen remains black unless a finder window (such as the force quit window) is dragged across the screen; then the graphics will draw and update behind it.

#18 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 26 October 2015 - 10:59 PM

What card do you have?

#19 NRG

NRG

    Champion Member

  • Members
  • 594 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 27 October 2015 - 08:27 AM

View Postdarklord42, on 26 October 2015 - 10:59 PM, said:

What card do you have?

Posted Image

#20 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 27 October 2015 - 01:56 PM

Haha I was looking at the post content and missed that.  I have an old GForce 330M.   I don't think there is an issue with Nvidia cards, unless model is an issue?

#21 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 27 October 2015 - 05:29 PM

I would have updated my operating system to 10.11 in my profile, but 10.9 is still the latest one offered.

#22 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 27 October 2015 - 07:24 PM

View Postclocknova, on 27 October 2015 - 05:29 PM, said:

I would have updated my operating system to 10.11 in my profile, but 10.9 is still the latest one offered.

Yeah, we only asked about that multiple times over the last year and a half ;).

#23 Thundar73

Thundar73

    Lurker

  • Members
  • 2 posts
  • Graphics Card:ATI Radeon HD
  • Operating System:Other OS/Not specified

Posted 13 November 2015 - 03:35 AM

Most of the games I've tried to wrap flicker...like Star Wars Pod Racer & Damage Incorporated. (Have Mac Os 10.11.1)


Update, I tried that no flicker engine that was discussed above, & I enabled Win 95 & also checked ddr=gdi & Damage Incorporated works flawlessly now.  Thanks guys. :)

#24 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 14 November 2015 - 07:00 PM

Unfortunately, switching the renderer to GDI is a horrible tradeoff in most games.  Not a good solution.

#25 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 09 January 2016 - 02:50 PM

Sigh.  Even with the newest engines I'm still getting the UI flicker in my Oblivion wrapper.  Is this ever going to be fixed?

#26 NRG

NRG

    Champion Member

  • Members
  • 594 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 09 January 2016 - 03:25 PM

View Postclocknova, on 09 January 2016 - 02:50 PM, said:

Sigh.  Even with the newest engines I'm still getting the UI flicker in my Oblivion wrapper.  Is this ever going to be fixed?

Did you try also with the new crossover engine v.15.0.0 ?

http://www.mediafire...CX15.0.0.tar.7z

#27 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 09 January 2016 - 08:47 PM

View PostNRG, on 09 January 2016 - 03:25 PM, said:

Did you try also with the new crossover engine v.15.0.0 ?

http://www.mediafire...CX15.0.0.tar.7z

Not yet.  Does it include the staging fixes as well?

EDIT:
Tried it.  Still flickers, but the greyed-out text bug has been fixed.

#28 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 10 January 2016 - 01:42 AM

Maybe try out the new XQuartz? It has some fix for an OpenGL problem..

#29 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 2,935 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro Core i7 16GB
    AMD Radeon HD 6750M 512MB

    MacBook Core2Duo 4GB
    nVidia 9400M 256MB
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:la rockitar
Author

Posted 10 January 2016 - 07:45 AM

View Postclocknova, on 09 January 2016 - 08:47 PM, said:

Not yet.  Does it include the staging fixes as well?

EDIT:
Tried it.  Still flickers, but the greyed-out text bug has been fixed.

I'm sure it includes some of the staging fixes in one way or another. The Indexed Vertex Shading fix is implemented but requires a direct3d registry key
"fixed_vs_constants_limit"="1024"
...also have you tried setting
"StrictDrawOrdering"="enabled"
in the user.reg file under Direct3D? This can be done through Winetricks > Settings. I'm on Yosemite with an ATI gpu so I don't know how valid of a fix it might be but lately when I encounter an issue like this I adjust the registry and 95% of the time it works.

Good luck!
Posted Image

#30 clocknova

clocknova

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 237 posts
  • LocationUSA
  • Graphics Card:NVIDIA GeForce GTX 780M 4096 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:RPG
    TBS

Posted 11 January 2016 - 02:03 PM

View PostdankoB, on 10 January 2016 - 07:45 AM, said:

I'm sure it includes some of the staging fixes in one way or another. The Indexed Vertex Shading fix is implemented but requires a direct3d registry key
"fixed_vs_constants_limit"="1024"
...also have you tried setting
"StrictDrawOrdering"="enabled"
in the user.reg file under Direct3D? This can be done through Winetricks > Settings. I'm on Yosemite with an ATI gpu so I don't know how valid of a fix it might be but lately when I encounter an issue like this I adjust the registry and 95% of the time it works.

Good luck!

StrictDrawOrdering fixed the problem.  Thanks!  And the 1.9.1 engine finally fixed the greyed-out text.  Unfortunately, performance seems to have taken a hit; not sure why.  What exactly is StrictDrawOrdering, anyway?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users