Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Wine64 engines...


  • Please log in to reply
45 replies to this topic

#1 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 06 August 2016 - 07:31 PM

This thread is for vanilla wine's engines that can  run  x64 software/games... (The  wine64's engines work also with x86 software)

for others 64 engines (as staging engines) you can watch to the Staging Engines thread


(engines compiled by ScoPezz)


P.S.: Most of actuals x64 games (pratically all) need also directx11, while  actuals wine's versions aren't yet ready for that...

#2 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 07 August 2016 - 05:48 PM

Thank you very much for this.

#3 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 08 August 2016 - 10:00 PM

I can't seem to make a wrapper using this engine. Wineskin stops working every time after I enter a name for the wrapper.

#4 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 09 August 2016 - 08:12 AM

View PostScoPezz, on 08 August 2016 - 10:00 PM, said:

I can't seem to make a wrapper using this engine. Wineskin stops working every time after I enter a name for the wrapper.

Peraphs your engine was corrupted during download...

I  tried to download it again from my link and the creation of a new wrapper it worked perfectly

#5 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 09 August 2016 - 05:19 PM

View PostNRG, on 09 August 2016 - 08:12 AM, said:

Peraphs your engine was corrupted during download...

I  tried to download it again from my link and the creation of a new wrapper it worked perfectly

I tried again, making a wrapper worked. But now when I try to install an app, nothing shows up and it just says that no new executables could be found.

#6 ovvldc

ovvldc

    Master Member

  • Members
  • 1233 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 09 August 2016 - 07:04 PM

Did you then manually select the executable?

#7 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 09 August 2016 - 09:38 PM

View Postovvldc, on 09 August 2016 - 07:04 PM, said:

Did you then manually select the executable?

There was no executable to be selected, installer didn't show up, nothing was installed.

#8 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 08:49 AM

View PostScoPezz, on 09 August 2016 - 09:38 PM, said:

There was no executable to be selected, installer didn't show up, nothing was installed.

Hi @ScoPezz, you are right! Sorry, there was something wrong  in my previous package... Now I repackaged the engine, download it again from new link in the first post of this thread....It should work now...

#9 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 August 2016 - 03:38 PM

View PostNRG, on 10 August 2016 - 08:49 AM, said:

Hi @ScoPezz, you are right! Sorry, there was something wrong  in my previous package... Now I repackaged the engine, download it again from new link in the first post of this thread....It should work now...
Thank you for all your effort so far! But the same problem is still there :/ Tried redownloading the engine, reinstalling winery, but that didn't work.

#10 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 03:51 PM

View PostScoPezz, on 10 August 2016 - 03:38 PM, said:

Thank you for all your effort so far! But the same problem is still there :/ Tried redownloading the engine, reinstalling winery, but that didn't work.

You made me come the doubt I linked a wrong file... but not, I just redownloaded it from the link in first page, and I created with this a wrapper for 7-zip

All works fine; the wrapper I created,  can install without problem the x64 version of the tool as the x86 version...

So there is something wrong in your procedure or into your os x

PS: use firefox and change the DNS into your osx with OpenDNS, if downloads from MEGA are corrupted...

#11 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 August 2016 - 04:47 PM

View PostNRG, on 10 August 2016 - 03:51 PM, said:

You made me come the doubt I linked a wrong file... but not, I just redownloaded it from the link in first page, and I created with this a wrapper for 7-zip

All works fine; the wrapper I created,  can install without problem the x64 version of the tool as the x86 version...

So there is something wrong in your procedure or into your os x

PS: use firefox and change the DNS into your osx with OpenDNS, if downloads from MEGA are corrupted...

I just tried all that, I'm using OSX 10.7 and the newest firefox. I tried to create a wrapper for 7zip x64 but the installer just doesn't show up.

EDIT: Asked a friend to try it as well, didn't work for him either.

#12 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 06:35 PM

View PostScoPezz, on 10 August 2016 - 04:47 PM, said:

I just tried all that, I'm using OSX 10.7 and the newest firefox. I tried to create a wrapper for 7zip x64 but the installer just doesn't show up.

EDIT: Asked a friend to try it as well, didn't work for him either.

Sorry but in my yosemite 10.10.5 it works without any problems...

Does Your friend use, as you, osx 10.7? (He download the engine directly from my link or it has a copy from your?)

You can  also  try with the x64 version of staging engine:

http://portingteam.c...300#entry105890


PS: did you changed DNS before download the engine? Some users have problem with their I.S. providers to download from MEGA without corruptions in their files ..

I don't know, but recently wine engines are compiled with SDK 10.8 so I'm not sure if the problem could depend by your OS X...

#13 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 August 2016 - 07:39 PM

View PostNRG, on 10 August 2016 - 06:35 PM, said:

Sorry but in my yosemite 10.10.5 it works without any problems...

Does Your friend use, as you, osx 10.7? (He download the engine directly from my link or it has a copy from your?)

You can  also  try with the x64 version of staging engine:

http://portingteam.c...300#entry105890


PS: did you changed DNS before download the engine? Some users have problem with their I.S. providers to download from MEGA without corruptions in their files ..

I don't know, but recently wine engines are compiled with SDK 10.8 so I'm not sure if the problem could depend by your OS X...

My friend uses Yosemite. I did change the DNS and my friend used your mega link. I'll try it again on a different mac.

#14 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 08:26 PM

another thing, does your wineskin winery updated to latest 2.6.2 version?

#15 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 August 2016 - 08:35 PM

View PostNRG, on 10 August 2016 - 08:26 PM, said:

another thing, does your wineskin winery updated to latest 2.6.2 version?
Yes, I'm using Winery 1.7 with Wineskin version 2.6.2. Your wine64 1.9.11 engine works perfectly.

#16 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 08:39 PM

View PostScoPezz, on 10 August 2016 - 08:35 PM, said:

Yes, I'm using Winery 1.7 with Wineskin version 2.6.2. Your wine64 1.9.11 engine works perfectly.

also my wine64 1.9.16 works perfectly (on my OS X  :P  )

did you try the STG64 1.9.16

engine?

It's very strange... the logical answer should your file was corrupted during the download, but if you think not it's very dfficult for me to help you...
Did you use Wi-fi? If yes try to download it through an ethernet connection with cable

another thing should be that your wineskin winery works in background and don't permits to use correctly the engine... try to stop all wineskin process through the specific button of the tool

#17 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 August 2016 - 08:58 PM

View PostNRG, on 10 August 2016 - 08:39 PM, said:

also my wine64 1.9.16 works perfectly (on my OS X  :P  )

did you try the STG64 1.9.16

engine?

It's very strange... the logical answer should your file was corrupted during the download, but if you think not it's very dfficult for me to help you...
Did you use Wi-fi? If yes try to download it through an ethernet connection with cable

another thing should be that your wineskin winery works in background and don't permits to use correctly the engine... try to stop all wineskin process through the specific button of the tool
STG64 1.9.16 doesn't work either. The weird thing is, there is no drive_c folder with anything in it inside the wrapper. I guess it's just my mac or Wi-Fi connection, I'll try all of it on another mac with ethernet connection. Thanks for all your help!

#18 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 10 August 2016 - 10:41 PM

View PostScoPezz, on 10 August 2016 - 08:58 PM, said:

STG64 1.9.16 doesn't work either. The weird thing is, there is no drive_c folder with anything in it inside the wrapper. I guess it's just my mac or Wi-Fi connection, I'll try all of it on another mac with ethernet connection. Thanks for all your help!

As I written, it could be some wineskin process that works from  your previous bugged version of the engine, in background...

Restart your os x... and try again

Another test you can try it's to make a fresh wineskin winery installation and update it to 2.6.2 after the new installation

#19 --------

--------

    Professional Member

  • Members
  • PipPipPipPip
  • 162 posts
  • LocationIstanbul
  • Graphics Card:MSI Z97 MPOWER - GTX 980 - View Sonic VP2780-4K - 16GB Ram - macOS High Sierra
  • Operating System:Other OS/Not specified
  • I like to play:Most of games :-)
Author

Posted 11 August 2016 - 03:49 PM

I just added this topic's link to staging engines topic's update section. So people can easily find out :ph34r: I have macOS Sierra on my hackintosh right now, probably I will able to spare sometime in order to catch up all recent updates related to wine :lol:

#20 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 15 August 2016 - 03:16 PM

I just tested the engine on my Yosemite iMac and it worked! Thank you @NRG!

#21 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 15 August 2016 - 05:40 PM

you're welcome

#22 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 22 August 2016 - 07:51 AM


Wine 1.9.17 Released
August 19, 2016
The Wine development release 1.9.17 is now available.
What's new in this release:
  • Better exception handling on 64-bit.
  • Various improvements in joystick support.
  • Some more stream support in the C++ runtime.
  • Font embedding improvements.
  • More metafile support in GDI+.
  • Various bug fixes.


#23 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 03 September 2016 - 06:28 PM

Hey @NRG, it might be a good idea to add that your 64bit and Staging engines are only usable on OS X 10.8 and later. (I know this is true, because I have tested it and since your repacking from official builds, which are 10.8+)

#24 Ballo

Ballo

    Novice Member

  • Members
  • 7 posts
  • Graphics Card:AMD Radeon HD 6750M
  • Operating System:OS X 10.9 (Mavericks)

Posted 20 October 2016 - 11:24 PM

Anybody know what this means? Google came up empty at least last I looked

Posted Image

#25 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 21 October 2016 - 09:15 AM

View PostBallo, on 20 October 2016 - 11:24 PM, said:

Anybody know what this means? Google came up empty at least last I looked

Posted Image

it's something related to OpenGL... so it's better try some directx9 game, but there aren't any modern game with the 64 bit support that uses also directx9. Most of 64 bit games are directx11 or OpenGL; and directx 11 are not fully implemented with wine and also OpenGl create many issues with wine

#26 Ballo

Ballo

    Novice Member

  • Members
  • 7 posts
  • Graphics Card:AMD Radeon HD 6750M
  • Operating System:OS X 10.9 (Mavericks)

Posted 21 October 2016 - 06:20 PM

So, basically I'm boned unless I install windows (which I cannot do in my current setup without buying a thunderbolt drive)

#27 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3009 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 22 October 2016 - 12:27 AM

Apple will lead you to believe that but it might not necessarily be true. I was not suppose to be able to install Windows 10 on my 2011 MBP but I still did. What type of system do you have? By the looks of your GPU I'm guessing it's the same as mine.

#28 Ballo

Ballo

    Novice Member

  • Members
  • 7 posts
  • Graphics Card:AMD Radeon HD 6750M
  • Operating System:OS X 10.9 (Mavericks)

Posted 22 October 2016 - 12:29 AM

Not possible to use bootcamp on a raid

#29 NRG

NRG

    Champion Member

  • Members
  • 678 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 01 November 2016 - 01:13 PM



#30 ovvldc

ovvldc

    Master Member

  • Members
  • 1233 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 01 November 2016 - 01:51 PM

Are you using X11 or Mac driver?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users