Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Wineskin HaloMD Server (El Capitan)


  • Please log in to reply
4 replies to this topic

#1 a_stick

a_stick

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Other OS/Not specified

Posted 19 September 2016 - 03:05 PM

I am trying to get this dedicated server app to work for the mini demo of Halo on my Mac. Being an El Capitan user, I got this error message.

Posted Image

So I updated the wineskin and it would finally open a blank console window. Shortly after it would say "Cannot allocate required memory. Some application has loaded where Halo wants to be located." I started to look around this forum for similar issues regarding Halo and I found a forum that helped. http://portingteam.c...olved-problems/
This person said:

View Postthedoc, on 05 March 2012 - 03:31 PM, said:

I'm not sure if the 1.1.23 binary works with 1.4 RC5 - I've only used it with Wine 1.2 and it worked there.

the file you wanna replace is located in WineskinWrapper.app/Contents/Frameworks/wswine.bundle/bin/wine

I changed the wineskin engine to 1.1.10 and BAMM!! The server app loaded with a beautifully colored console with the server loading. Then I got another
error message.

Posted ImagePosted Image

I don't know what to do now. Can anyone help? Thank you.
Link to the server app: https://macgamingmod...p?f=101&t=18567

#2 MaestroTesseract

MaestroTesseract

    Experienced Member

  • Members
  • PipPip
  • 22 posts
  • LocationBehind you.
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:macOS 10.12 (Sierra)

Posted 02 November 2016 - 06:58 AM

I've downloaded the wrapper as well and by the looks of it the Wineskin version's too old for El Capitan (I'm using Sierra, but they're require more or less the same thing). The Wineskin version (with the one I have) is 2.5.10 and El Capitan requires 2.6.1 or 2.6.2. To update it go into Wineskin > Advanced > Tools > Update Wrapper, which should update it to 2.6.2 or whatever you have installed with Wineskin Winery.

Not sure about the Wine engine as I've had absolutely no luck with getting it to launch past the splash screen and to add to me confusion my friend runs it on Linux with the standard Wine binaries perfectly.

#3 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 02 November 2016 - 07:02 AM

Wine 1.1.23 is positively ancient. You may want to try with a more modern engine (1.8 or CX15.3.1), just in case.

#4 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 03 November 2016 - 08:13 PM

Unfortunately, Halo for the PC does not work with a more modern engine and suffers from the: "Cannot allocate required memory. Some other application has loaded where Halo needs to be located."  It has always suffered from this error. This has me completely scratching my head as to why wine hq has it rated as platinum....  The error never went away.  They must be high. As such the best engine that works with it is the WS8WineCXG7.2.0

#5 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 03 November 2016 - 08:21 PM

Note: Engines that old do not have the mac driver and require the X11 one.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users