Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

MacOS Sierra


  • Please log in to reply
64 replies to this topic

#31 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 09 September 2017 - 06:26 AM

ok so i tried to install the pc copy i had. it wouldn't play because of permission or something so i applied the crack and it worked but still 4 screens. the installer was normal though if that helps

#32 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 09 September 2017 - 07:02 AM

ok i think it might have something to do with the color depth?? i really don't know. it seems to be the only thing that slightly changes the 4 screen problem but not all the way and the port crashes immediately. maybe its just the limitations of my gpu but its a fairly new computer (15 or 16 i think). anyway thanks nrg for your attention to this matter.

#33 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 09 September 2017 - 09:11 AM

View Postkerbs, on 09 September 2017 - 04:22 AM, said:

intel iris?

1280x 800?

as I imagined...

Iris GPUs and theirs VideoRAM  have often issues to be well recognized by wineskin's wrappers  or by wine engines... It's a know issue of wine with intel/iris gpus...
In these case your videomemory is seen by wine as very low and it isn't used at his full potential

So try this:

use my wineskin's wrapper as I explained before in my previous post.

but open it (right click show package contents) and  open the wineskin.app inside it

go to advanced then click on "Set Screen Option" and unflag the "Autodetect GPU info for Direct3D" option

Click on "Done"

Then select the "Tools" tab

click on "Winetricks" then click on "update winetricks" at the bootom of the window and wait the finishing of the process

Now into the winetricks window select "settings" and scroll down until you find "videomemorysize=1024" and flag it then click on the "Run" button and wait the finish of the process... then click on close and esc from wineskin.app

Try if the game work correctly now

#34 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 03:57 AM

View PostNRG, on 09 September 2017 - 09:11 AM, said:

as I imagined...

Iris GPUs and theirs VideoRAM  have often issues to be well recognized by wineskin's wrappers  or by wine engines... It's a know issue of wine with intel/iris gpus...
In these case your videomemory is seen by wine as very low and it isn't used at his full potential

So try this:

use my wineskin's wrapper as I explained before in my previous post.

but open it (right click show package contents) and  open the wineskin.app inside it

go to advanced then click on "Set Screen Option" and unflag the "Autodetect GPU info for Direct3D" option

Click on "Done"

Then select the "Tools" tab

click on "Winetricks" then click on "update winetricks" at the bootom of the window and wait the finishing of the process

Now into the winetricks window select "settings" and scroll down until you find "videomemorysize=1024" and flag it then click on the "Run" button and wait the finish of the process... then click on close and esc from wineskin.app

Try if the game work correctly now

still getting 4 screens? should i re install after i set the winetrick?

#35 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 04:09 AM

View Postkerbs, on 10 September 2017 - 03:57 AM, said:

still getting 4 screens? should i re install after i set the winetrick?

no

try to set "videomemorysize=2048"

#36 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 04:11 AM

@nrg

tried that and the 512.. still 4 screens

#37 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 04:19 AM

View PostNRG, on 10 September 2017 - 04:09 AM, said:

no

try to set "videomemorysize=2048"

tried each videomemorysize wine trick and still 4 screens. maybe there is no solution at this time? should i try a different version of windows in the wrapper? just taking shots in the dark

#38 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 04:20 AM

are you sure to have disabled the Autodetect GPU info for Direct3D ?

If yes, and if the issue still persists try this:

Again inside the "Set Screen Options" window unflag also the "Use Mac Driver instead of X11"

#39 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 05:03 AM

View PostNRG, on 10 September 2017 - 04:20 AM, said:

are you sure to have disabled the Autodetect GPU info for Direct3D ?

If yes, and if the issue still persists try this:

Again inside the "Set Screen Options" window unflag also the "Use Mac Driver instead of X11"

yea no boxes are flagged in the screen options and it still persists. i like unflagging "use mac driver instead of x11" because it lets me quit out of the app with command q but if its checked then the command tab works and i have to quit it from the finder. but still 4 screens..

#40 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 06:09 AM

View Postkerbs, on 10 September 2017 - 05:03 AM, said:

yea no boxes are flagged in the screen options and it still persists. i like unflagging "use mac driver instead of x11" because it lets me quit out of the app with command q but if its checked then the command tab works and i have to quit it from the finder. but still 4 screens..

and if you flag the "use direct3d Boost if available"?

if nothing changes, it remains only to try another different engine for example with the latest crossover 16.2.5:

download...

update your wrapper with that engine e try again the various solutions with it


ps: use CMD+ALT+Q   to quit with "use mac driver instead x11" flagged

#41 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 06:42 AM

View PostNRG, on 10 September 2017 - 06:09 AM, said:

and if you flag the "use direct3d Boost if available"?

if nothing changes, it remains only to try another different engine for example with the latest crossover 16.2.5:

download...

update your wrapper with that engine e try again the various solutions with it


ps: use CMD+ALT+Q   to quit with "use mac driver instead x11" flagged

can't figure out how to get the engine i downloaded from you to show up in wineskin app

#42 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 08:43 AM

View Postkerbs, on 10 September 2017 - 06:42 AM, said:

can't figure out how to get the engine i downloaded from you to show up in wineskin app

do you have installed wineskin winery into your macOS?

If yes put the engine's file (as is, without  extracting it)
within this path:

~/Library/Application Support/Wineskin/Engines

Then open the wineskin.app contained into my Metal Slug Complete.app and go to Advanced
Click on the Tools tab and select change engine used
The new engine will appear between your wineskin's engines, so, select it and waiting the finishing of his installation

#43 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 07:03 PM

View PostNRG, on 10 September 2017 - 08:43 AM, said:

do you have installed wineskin winery into your macOS?

If yes put the engine's file (as is, without  extracting it)
within this path:

~/Library/Application Support/Wineskin/Engines

Then open the wineskin.app contained into my Metal Slug Complete.app and go to Advanced
Click on the Tools tab and select change engine used
The new engine will appear between your wineskin's engines, so, select it and waiting the finishing of his installation

i do have wineskin winery but there is no wineskin folder in my application support folder?

#44 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 10 September 2017 - 07:14 PM

View Postkerbs, on 10 September 2017 - 07:03 PM, said:

i do have wineskin winery but there is no wineskin folder in my application support folder?

Did you start Wineskin Winery and download an engine? That should set it all up.

#45 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 08:10 PM

View Postovvldc, on 10 September 2017 - 07:14 PM, said:

Did you start Wineskin Winery and download an engine? That should set it all up.

yes i have no problem downloading an engine in the app but @nrg sent me an engine that is not available in app and there appears to be no application support folder for wineskin? searched high and low in finder.

#46 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 10 September 2017 - 08:40 PM

View Postkerbs, on 10 September 2017 - 07:03 PM, said:

i do have wineskin winery but there is no wineskin folder in my application support folder?

this path:

~/Library/Application Support/Wineskin/Engines

is into your HOME folder and Library is an Hidden folder


The easiest way to find your hidden ~/Library/ folder is to do the following:

by the Finder's bar choose Go then Hold down the Alt (Option) and You will see the ~/Library folder listed below the Home folder


NOTE: before changing the engine, be sure your wineskin winery is updated to the latest 2.6.2 version:

Posted Image

#47 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 05:37 AM

View PostNRG, on 10 September 2017 - 08:40 PM, said:

this path:

~/Library/Application Support/Wineskin/Engines

is into your HOME folder and Library is an Hidden folder


The easiest way to find your hidden ~/Library/ folder is to do the following:

by the Finder's bar choose Go then Hold down the Alt (Option) and You will see the ~/Library folder listed below the Home folder


NOTE: before changing the engine, be sure your wineskin winery is updated to the latest 2.6.2 version:

Posted Image

was able to install the engine and i do have wineskin v 2.6.2 but now it won't even start tried a clean install into the clean wrapper it worked with 4 screens then when i installed the engine it would no longer work. tried running the winetrick and this is what it said

wine cmd.exe /c echo '%ProgramFiles%' returned empty string, error message "wine: Call from 0x7b42ce09 to unimplemented function user32.dll.BroadcastSystemMessageW, aborting

wine: Unimplemented function user32.dll.BroadcastSystemMessageW called at address 0x7b42ce09 (thread 001e), starting debugger...

wine: Call from 0x7b42ce09 to unimplemented function shell32.dll.SHGetFolderPathW, aborting

wine: Unimplemented function shell32.dll.SHGetFolderPathW called at address 0x7b42ce09 (thread 000b), starting debugger...

Wine cannot find the FreeType font library.  To enable Wine to

use TrueType fonts please install a version of FreeType greater than

or equal to 2.0.5.

http://www.freetype.org

err:module:attach_process_dlls "gdi32.dll" failed to initialize, aborting

err:module:LdrInitializeThunk Main exe initialization for L"C:\windows\system32\explorer.exe" failed, status c000001d

err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.

err:winediag:nodrv_CreateWindow The explorer process failed to start."


not sure if that has anything to do with it.


#48 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 05:50 AM

when i test run here are the logs

wine: Call from 0x7b42ce09 to unimplemented function user32.dll.BroadcastSystemMessageW, aborting
wine: Unimplemented function user32.dll.BroadcastSystemMessageW called at address 0x7b42ce09 (thread 001e), starting debugger...
wine: Call from 0x7b42ce09 to unimplemented function shell32.dll.SHGetFolderPathW, aborting
wine: Unimplemented function shell32.dll.SHGetFolderPathW called at address 0x7b42ce09 (thread 000b), starting debugger...
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:module:attach_process_dlls "gdi32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\explorer.exe" failed, status c000001d
err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
err:winediag:nodrv_CreateWindow The explorer process failed to start.



and then



WineskinX11: main(): argc=12
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=12
Attempting to use pixel depth of 24
[1870313.080] WineskinX11 starting:
[1870313.081] X.Org X Server 1.13.0
[1870313.081] Build Date: 20120921
[1870313.083] Initializing built-in extension Generic Event Extension
[1870313.083] Initializing built-in extension SHAPE
[1870313.083] Initializing built-in extension MIT-SHM
[1870313.083] Initializing built-in extension XInputExtension
[1870313.083] Initializing built-in extension XTEST
[1870313.083] Initializing built-in extension BIG-REQUESTS
[1870313.083] Initializing built-in extension SYNC
[1870313.083] Initializing built-in extension XKEYBOARD
[1870313.083] Initializing built-in extension XC-MISC
[1870313.083] Initializing built-in extension XINERAMA
[1870313.083] Initializing built-in extension PseudoramiX
[1870313.083] Initializing built-in extension XFIXES
[1870313.083] Initializing built-in extension RENDER
[1870313.083] Initializing built-in extension RANDR
[1870313.083] Initializing built-in extension DAMAGE
[1870313.083] Initializing built-in extension MIT-SCREEN-SAVER
[1870313.083] Initializing built-in extension DOUBLE-BUFFER
[1870313.083] Initializing built-in extension RECORD
[1870313.083] Initializing built-in extension X-Resource
[1870313.083] Initializing built-in extension XVideo
[1870313.083] Initializing built-in extension XVideo-MotionCompensation
[1870313.083] Initializing built-in extension GLX
[1870313.084] x: 0, y: 0, w: 1280, h: 777
[1870313.098] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[1870313.231] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
Engine Used: WS9WineCX16.2.5
Hardware:

    Hardware Overview:

      Model Name: MacBook Pro
      Model Identifier: MacBookPro11,1
      Processor Name: Intel Core i7
      Processor Speed: 3 GHz
      Number of Processors: 1
      Total Number of Cores: 2
      L2 Cache (per Core): 256 KB
      L3 Cache: 4 MB
      Memory: 16 GB
      Boot ROM Version: MBP111.0138.B40
      SMC Version (system): 2.16f68

Graphics/Displays:

    Intel Iris:

      Chipset Model: Intel Iris
      Type: GPU
      Bus: Built-In
      VRAM (Dynamic, Max): 1536 MB
      Vendor: Intel (0x8086)
      Device ID: 0x0a2e
      Revision ID: 0x0009
      Metal: Supported
      Displays:
        Color LCD:
          Display Type: Built-In Retina LCD
          Resolution: 2560 x 1600 Retina
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Rotation: Supported
          Automatically Adjust Brightness: Yes
          Connection Type: DisplayPort

#49 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 07:19 AM

maybe cx 16.2.5 isn't compatible with that game...

come back to the previos engine e try to make this test:

open wineskin.app inside the wrapper, go on "advanced" tab and inside the "Configuration" tab
set "EXE flag" writing within it

-W1

as in this image:

Posted Image

then click "Test Run"

The game should open itself in a little window (that you can also manually resizing)

Posted Image

Do you see the 4 splitted screens again?

and if you restore it without the "-W1" after that test?

#50 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 09:48 AM

View PostNRG, on 11 September 2017 - 07:19 AM, said:

maybe cx 16.2.5 isn't compatible with that game...

come back to the previos engine e try to make this test:

open wineskin.app inside the wrapper, go on "advanced" tab and inside the "Configuration" tab
set "EXE flag" writing within it

-W1

as in this image:

Posted Image

then click "Test Run"

The game should open itself in a little window (that you can also manually resizing)

Posted Image

Do you see the 4 splitted screens again?

and if you restore it without the "-W1" after that test?

did that, got a cool resizable window but still 4 screens within

#51 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 09:54 AM

View Postkerbs, on 11 September 2017 - 09:48 AM, said:

did that, got a cool resizable window but still 4 screens within
tried "-R800" and set the virtual desktop to 800x600 and still 4 screens. on another note i tried to play it a bit and it was running insanely fast so theres another problem. maybe an easy fix? maybe it just won't run on my machine but i had another wineskin port that stopped working (not 4 screens but still) and when i updated the wrapper it works fine now.

#52 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 10:31 AM

View Postkerbs, on 11 September 2017 - 09:54 AM, said:

...and when i updated the wrapper it works fine now.

God be praised! :rolleyes:

#53 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 109 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 11 September 2017 - 02:19 PM

@NRG
Can you compile this thread to some kind of tutorial for newcomers when You already put so much efforts :)

#54 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 11 September 2017 - 06:38 PM

View PostNRG, on 11 September 2017 - 10:31 AM, said:

God be praised! :rolleyes:
not sure you understood. i was saying that a different game that didn't work after update to sierra works fine now but the metal slug still has 4 screens and runs too fast. are we all out of options for a solution?

#55 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 12 September 2017 - 05:09 AM

ok i have a new issue with a different port. i found a nice wineskin of a daphne port of all three dragon's lair arcade games i thought it said for sierra but when i run it it starts then on a screen from the game it says it couldn't open a certain fileframe and that the laserdisc player count be initialized

heres what the the log says

--DAPHNE version 1.0.0
--Command line is: C:\Program Files\daphne-1.0v-win32\daphne.exe lair2 vldp -framefile C:\Program Files\daphne-1.0v-win32\mpeg\lair2\dl2-framefile.txt -blank_searches -blank_skips -latency 500 -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir . -nocrc -noissues -noserversend -sound_buffer 2048 -volume_vldp 64 -volume_nonvldp 16 -opengl -fullscreen -x 640 -y 480
--CPU : GenuineIntel 3000 MHz || Mem : 2048 megs
--OS : Windows XP/.NET || Video : X11 Windowing System
--OpenGL: Compiled In
--RGB2YUV Function: MMX
--Line Blending Function: MMX
--Audio Mixing Function: MMX
Setting alternate home dir:
.
Setting Search Latency to 500 milliseconds
Disabling ROM CRC check...
Setting sound buffer size to 2048
Setting screen width to 640
Setting screen height to 480
Set 640x480 at 32 bpp with flags: 80000002
Initializing sound system ...
No joysticks detected
Remapping input ...
Loading compressed ROM image dl2_319.bin...65536 bytes read.
Could not open framefile : C:\Program Files\daphne-1.0v-win32\mpeg\lair2\dl2-framefile.txt
Could not initialize laserdisc player!
Shutting down sound system...
Shutting down video display...

any ideas

#56 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 12 September 2017 - 06:32 AM

ok never mind about the dragons lair, im an idiot. i just downloaded a wrapper, i need to find my own mpeg files and frame files. but still need help with metal slug complete. thanks!

#57 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 12 September 2017 - 08:31 AM

View Postkerbs, on 12 September 2017 - 06:32 AM, said:

ok never mind about the dragons lair, im an idiot. i just downloaded a wrapper, i need to find my own mpeg files and frame files. but still need help with metal slug complete. thanks!

try to change most of engines you can... maybe someone can help with this game and your hardware... otherwise maybe Intel/Iris GPU and this particular game aren't adapted to be played through wine...

maybe an old engine could be better than a newer one...


note:  if you need to play metal slug through macOS you can try also  to emulate it through SDL MAME for macOS...

#58 kerbs

kerbs

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • Graphics Card:intel iris =(
  • Operating System:Other OS/Not specified

Posted 12 September 2017 - 08:48 AM

View PostNRG, on 12 September 2017 - 08:31 AM, said:

try to change most of engines you can... maybe someone can help with this game and your hardware... otherwise maybe Intel/Iris GPU and this particular game aren't adapted to be played through wine...

maybe an old engine could be better than a newer one...


note:  if you need to play metal slug through macOS you can try also  to emulate it through SDL MAME for macOS...


sdl seems a little over my head. ill probably just get steam but i don't know if they're even available for mac

#59 NRG

NRG

    Champion Member

  • Members
  • 595 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:Other OS/Not specified

Posted 12 September 2017 - 09:06 AM

View Postkerbs said:

sdl seems a little over my head. ill probably just get steam but i don't know if they're even available for mac

sorry... but I don't follow you anymore... maybe it's fault by my bad english... Good luck

#60 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 12 September 2017 - 01:39 PM

You could try with different engines and different Screen Options. Especially setting Mac driver or (default) X11 tends to make a difference. This could especially be the case here as Wine said no window could be created and that usually means I should set the Mac driver (no idea what the problem with X11 is on recent engines, but I don't usually get it to work anymore).

This part:
err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
err:winediag:nodrv_CreateWindow The explorer process failed to start."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users