Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Skyrim Stuttering (Mac OSX 10.9.5 Mavericks) *SORT OF FIXED IN REPLYS*


  • Please log in to reply
3 replies to this topic

#1 Viridien

Viridien

    Lurker

  • Members
  • 3 posts
  • Graphics Card:NVIDIA GeForce GT 750M 1024 MB
  • Operating System:OS X 10.9 (Mavericks)

Posted 14 October 2016 - 06:18 AM

I have recently download Wineskin Winery and have engine version 1.15.9 (which is latest update at this time), and wrapper version Wineskin-2.6.2 (default name)

I only downloaded this for the purpose of running Skyrim on my computer with the operating system Mac OSX 10.9.5 Mavericks, with these specs

21.5-inch, Late 2013
Processor  2.9 GHz Intel Core i5
Memory  16 GB 1600 MHz DDR3
Graphics  NVIDIA GeForce GT 750M 1024 MB
Software  OS X 10.9.5 (13F34)  ( Yes I did repeat the software I'm not too daft)

I have great reason to believe that my specs are more than optimal for Elder Scrolls 5. I know this because I torrented the game earlier, and it was running quite fine, but the frame rate was low so I decided that I would purchase the game on Steam because Torrents have lower frame rate and I didn't feel morally pleased about playing the game that way. I bought the bundle purchase of Skyrim with the 3 DLC and downloaded the windows version of steam through wineskin and through that Skyrim. The wrapper I am using to run Skyrim is located at http://portingteam.c...n-updated-2014/. I ran it and immediately noticed that my mouse decided to move as if it had a ghost inside it, and left a trail. I thought that this was just the title screen and played through it a bit more, but to no prevail did anything stop leaving a ghostlike mirage behind them. I have spent the past 4 hours searching for a fix for this wonderful thing, and again, to no prevail. I have tried multiple different fixes that have worked for other people, and none have them have fixed anything. For example here are some things I have tried to do

List of uselessness:

- Alter SkyrimPrefs.ini
   - Change shadow length
   - Change Gamepad rumble to 0 and Gamepad Enable to 0
   - Change PresentInterval to 0
- Download 64hz stuttering Fix and place them in correct place
- http://www.nexusmods...m/mods/2581/?   -  Might work for you hell if I know
- Change resolution, texture detail etc. all to minimum
- Fail to access my graphic's card V-sync (This might be what I need to do just have no idea how to get in to the settings)


And research many other threads and forums for fixes on this. None of them improving my situation, I decided to write this fugly monstrosity.

If anyone had this problem or is still having this problem, I hope that some of what I did may help you. Any type of recommendation would be nice, thanks for your time. Also, if there is something I missed just ask and I will respond as soon as I can.


OR

If you didn't want to read, basically my frame rate is choppy as hell and everything is lagging when it shouldn't. I really want a fix, computer specs are above.

#2 ovvldc

ovvldc

    Master Member

  • Members
  • 1,072 posts
  • Graphics Card:Intel HD5000
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:stories

Posted 14 October 2016 - 07:36 AM

You could try with a recent Staging or Crossover engine and turn on the multithreaded rendering. What could also be a problem is that Skyrim is CPU (not just GPU) intensive, and Wine even more so than normal Windows. I suppose you i5 should be fast enough, but it could become a limiting factor with the multithreaded rendering.

If the problem is the amount of work on a single core, you could try to enable multithreading in the engine. You can look at http://steamcommunit...s/?id=173284583 under the heading 'Multi-core CPU Settings'.

Finally, turn off antialiasing, it doesn't seem to work too well. Anisotropic filtering is fine.

#3 Viridien

Viridien

    Lurker

  • Members
  • 3 posts
  • Graphics Card:NVIDIA GeForce GT 750M 1024 MB
  • Operating System:OS X 10.9 (Mavericks)

Posted 14 October 2016 - 07:50 AM

I found the problem and fixed it, thanks for the response though. All that I had to do was go to my wrapper, Show package contents, open the wineskin app, advanced options, set screen options, then uncheck X11 drivers instead of Mac drivers. Apparently that was the only problem, as soon as I unchecked that things are running beautifully.

After playing a little bit, I notice a slight jerking at the edges of my screen. Much better compared to what I had before though

#4 Viridien

Viridien

    Lurker

  • Members
  • 3 posts
  • Graphics Card:NVIDIA GeForce GT 750M 1024 MB
  • Operating System:OS X 10.9 (Mavericks)

Posted 14 October 2016 - 08:30 PM

UPDATE: The jerking at the edges of my screen got really bad and annoying, and after looking into it I found that it is because of high framerate. This proved to be true when I turned to ultra high settings and the jerking reduced to a tiny amount. My computer had sorts of problems running ultra high so I downloaded a mod - http://www.nexusmods...es/?id=34&pUp=1 - Which I set my limit to 40 fps and 1000 render ahead. This allows it to run quite smoothly with medium graphics and default setting for everything else, other than resolution to match my computer. It might need a bit more tweaking to get the optimal gameplay I desire, but not too much




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users