Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Wolfenstein (2009) fix the pink ?


  • Please log in to reply
11 replies to this topic

#1 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 16 March 2019 - 01:16 PM

I was wondering if there was a way to get rid of those pink parts, apparently showing instead of semi-transparent overlays (the crosshair is also pink and blue). I'm using WS9Wine 4.2 and Wineskin 2.8.9Beta6. It seems to be the only problem with this game.

Posted Image
Posted Image

#2 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 16 March 2019 - 01:44 PM

How did you get this working. Any additional winetricks do you use and what's your hardware Mac spec?

I allow get OpenGL version not supported.

#3 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 16 March 2019 - 02:52 PM

It works out of the box, just copied the folder with wineskin. I'm using a Hackintosh not a real mac (core i7 3,6 Ghz).

I saw that subject in Winehq https://bugs.winehq....ug.cgi?id=34692 So I tried to install d3dx9_36 via winetricks but it didn't work.

View PostIncredible Hulk, on 16 March 2019 - 01:44 PM, said:

I allow get OpenGL version not supported.

Is it an option in Wineskin ?

#4 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 302 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 March 2019 - 03:40 PM

View PostIncredible Hulk, on 16 March 2019 - 01:44 PM, said:

How did you get this working. Any additional winetricks do you use and what's your hardware Mac spec?

I allow get OpenGL version not supported.

Sounds like you GPU is old that’s lightly the reason for the error.

View Postvanhouten, on 16 March 2019 - 02:52 PM, said:

It works out of the box, just copied the folder with wineskin. I'm using a Hackintosh not a real mac (core i7 3,6 Ghz).

I saw that subject in Winehq https://bugs.winehq....ug.cgi?id=34692 So I tried to install d3dx9_36 via winetricks but it didn't work.

The bug says the patch was added into Staging so instead use Staging but it says dxtn was the needed patch so if Staging does not work you could try WineCX18.1.0 or the latest WineXSherry from Slice.

#5 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 16 March 2019 - 04:43 PM

Indeed changing the engine to Staging 4.3 made the bug disappear ! Thank you. Didn't change anything else.

#6 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 16 March 2019 - 08:55 PM

I still have a little bug, though. The mouse cursor showing in the gameplay. Close to this bug : https://bugs.winehq....ug.cgi?id=19841 Not really sure but it seems to appear at the beginning of a new mission. I have to relaunch the wrapper to make it disappear.

#7 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 302 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 17 March 2019 - 02:20 AM

I’m not sure what that could be, but from reading the bug it could be a regression within wine.

#8 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 17 March 2019 - 04:02 PM

I tried to make a screenshot but the system screenshot always hide the cursor… (I'll try with the Capture app next time)

Seems the bug can happen after a cutscene too. I've noticed during a play that the cursor disappears properly again after finishing a level.

I wonder if the bug was only partially fixed… As it only appears after completing level 1.

#9 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3007 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 17 March 2019 - 11:49 PM

I've come across this in a few different games. I normally just command + tab out of the game and then back into it again and the mouse normally resets

#10 ovvldc

ovvldc

    Master Member

  • Members
  • 1203 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 18 March 2019 - 07:23 AM

View PostdankoB, on 17 March 2019 - 11:49 PM, said:

I've come across this in a few different games. I normally just command + tab out of the game and then back into it again and the mouse normally resets

There's a few games that just freeze when you do that (Fallout New Vegas is one for me), so not always good. YMMV

#11 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 18 March 2019 - 07:28 PM

View Postovvldc, on 18 March 2019 - 07:23 AM, said:

There's a few games that just freeze when you do that (Fallout New Vegas is one for me), so not always good. YMMV
Or you get some funky colors sometimes…

Didn't do the trick, alas. It's not the mac cursor, by the way, but the in-game cursor. I've noticed that if I don't skip the first cutscene (didn't have the patience to not skip the second one, though…) I get the cursor bug right at the start. The cursor  doesn't stay in center like the crosshair.

Posted Image

I made another test : skipping all the cutscenes prevent the cursor to appear. Made it to level 2 without the cursed cursor, hehe.

#12 vanhouten

vanhouten

    Regular Member

  • Members
  • Pip
  • 10 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:macOS 10.12 (Sierra)

Posted 27 March 2019 - 12:38 AM

Just for info, I finally changed the engine to WineCX 18.1.0. The cursor never appeared during combat with this one. But sometimes you just completely lose the cursor, and you can't use the mouse navigation in menus anymore. (a bug also present in Staging) I finished the game without any problem otherwise.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users