Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Skyrim Green Screen Problem


  • Please log in to reply
28 replies to this topic

#1 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 02:47 AM

I have the latest version of skyrim but there is a problem with the water. Does any one know how to fix the underwater problem in Skyrim? Everytime I go underwater all I see in green andI don't know how to fix it. I tired using this mod but it does not help me. http://skyrim.nexusm...?id=14007&tab=3

#2 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 02:54 AM

That green water patch is not compatible with the latest patch which made my green water even worse. Your water shouldn't be green by default, by any chance are you trying or using an ENB mod as enb d3d9.dll from enb version 1.03 and down give a green water bug with the 1.5 patches. If you want to get rid of the green water while using enb go to the enb dev website and download the 1.08 enb mod and only move over the 1.08 d3d9.dll to fix the green water. If not using enb give me a list of mods your using and I might be able to find the culprit.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#3 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:11 AM

The list of mods I am using are as follows: Also this is what my plugin txt file looks like for my mods:

voidLetsGetNaked.esp
ApachiiHair.esm
TheEyesOfBeauty.esp
AelaTheHuntress.esp
AelaTheHuntress.bsa
DovahRace.esp
Craftable Greybeard Robes.esp
ArchRobe.esp
WerewolfSecondHowlToggle.esp
ShoutCD.esp
Lanterns Of Skyrim - Around Cities.esp
Lanterns Of Skyrim - Around Cities.bsa
Lanterns Of Skyrim - Bridges x2 - OnOff.bsa
Lanterns Of Skyrim - Bridges x2 - OnOff.esp
Lanterns on the Roads (50% less lanterns).esp
Usable lantern.esp
lt_camping.bsa
lt_camping.esp
HandyMan.esp
Infinite Werewolf.esp

Please let me know if this helps

#4 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 04:14 AM

None of those mod should mess up your water...is it green everywhere and can I see a screenshot if possible.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#5 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:37 AM

here is what it looks like underwater: http://s1080.photobu...01at93403PM.png

#6 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:38 AM

I can't find a way to fix it.

#7 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 04:43 AM

your sure your not using enb or any other d3d9.dll's in the skyrim folder as thats the only time I have seen the water like that.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#8 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:45 AM

How do I find out if I am using enb or d3d9.dll's folder?

#9 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 04:46 AM

Well look in your skyrim game data folder inside the wrapper and see if there is a d3d9.dll in there

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#10 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:48 AM

If there is how do I fix it?

#11 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 04:52 AM

this is everything in my data file: http://s1080.photobu...01at95025PM.png

#12 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 04:57 AM

Idk it looks normal and has no d3d9.dll in it...maybe try a water retexture like W.A.T.E.R or RWT - Real Water Textures that might fix the water. If that doesn't work it must be your graphics card.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#13 julus

julus

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 250 posts
  • LocationSlovakia
  • Graphics Card:AMD Radeon 6750M
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:MMORPG, Adventure, RPG, Strategy
Author

Posted 02 May 2012 - 05:00 AM

You didnt post what is your graphics card. ATI cards have regression since 1.3.37 in some games, with failing to render some screen effects. if you have ATI card, try to use 1.3.36 engine and see if the water still fails to render.

#14 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 05:03 AM

How do I use the 1.3.36 engine?

#15 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 05:05 AM

1.3.36 is a wine engine but your using cider so either you figure out for to port it using wineskin or just ignore the water and keep playing the game.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#16 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 05:08 AM

The graphics card I use is Intel HD 3000 512 MB

#17 julus

julus

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 250 posts
  • LocationSlovakia
  • Graphics Card:AMD Radeon 6750M
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:MMORPG, Adventure, RPG, Strategy
Author

Posted 02 May 2012 - 05:09 AM

Then you are not affected by ati bug

#18 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 05:12 AM

Then I don't know how to fix the problem I tried to RWT and W.A.T.E.R. and those mods did not help

#19 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 05:12 AM

Thats most likely the cause of the bugs as even on pc that card has problems with this game. Probably no way to fix that bug.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#20 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 05:36 AM

so its a bug with the version of 1.5 of skyrim?

#21 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 02 May 2012 - 12:57 PM

Yes its a bug with version 1.5 or how I see it as bethesda added a bunch of useless effects to the 1.5 patches like shadows for grass, overhauled water animations, etc...If you could go back to the last 1.4 patch you could maybe get around this bug but no guarantees.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#22 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 08:48 PM

this is something else someone told me what to do. How do I do the following intrusions below on a mac?
You could try to disable to depth of field to see if fix it or not. It might be the problem, it was for me and the following trick helped me :

In your Documents -> My Games -> Skyrim, find the skyrim.ini and open with notepad.

Then find the line

bDoDepthOfField=1

and change this value to 0

bDoDepthOfField=0

Save and exit.
This disable the depth of field effect, it doesn't have a big impact on the game and sometimes even improve performance when off.

Launch skyrim again and check if you could see underwater or not.
If it doesn't help you can easily just turn it on again by editing the ini and changing the value to 1 again.

Hope this work for you

#23 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 08:50 PM

does anyone have to 1.4 version loaded online so I can download and wrap into cider?

#24 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 02 May 2012 - 09:42 PM

is it possible to run dxdig on mac?

#25 hellsdrinkers

hellsdrinkers

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Gerfoce XFX GTS 250 512mb
  • Operating System:Windows
  • I like to play:Action, RPG, Adventure, SCI-FI, Strategy

Posted 03 June 2012 - 08:13 PM

Hello, I had the same problem, went into the water and it turned green, I could not see anything! I tried everything that was on the internet until I found this:

About "bDoDepthOfField" in "SkyrimPrefs.ini" in your "My Games" folder
=======================================================================
"bDoDepthOfField=0" setting also makes underwater visible.
But you will lose your ENB settings of DoF.
And also it makes your underwater no color, and no blur.
So, I recommend you "bDoDepthOfField=1" when using my mod.
If you choose "bDoDepthOfField=0" setting, please deactivate my mod.
It doesn't need any more.


I did not think twice and have disabled the Depth, also did not use the MOD GreenWaterFix.

Note: I play on PC, not MAC, I registered to discuss the matter, I hope that solves your problem and perhaps more players.

#26 Un0va

Un0va

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts
  • Graphics Card:Intel HD Graphics 3000 (grr)
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Mainly FPS and TPS games, but sandbox and RPG come in a close second.

Posted 03 June 2012 - 08:30 PM

View Postsmellybo, on 02 May 2012 - 08:48 PM, said:

this is something else someone told me what to do. How do I do the following intrusions below on a mac?
You could try to disable to depth of field to see if fix it or not. It might be the problem, it was for me and the following trick helped me :

In your Documents -> My Games -> Skyrim, find the skyrim.ini and open with notepad.

Then find the line

bDoDepthOfField=1

and change this value to 0

bDoDepthOfField=0

Save and exit.
This disable the depth of field effect, it doesn't have a big impact on the game and sometimes even improve performance when off.

Launch skyrim again and check if you could see underwater or not.
If it doesn't help you can easily just turn it on again by editing the ini and changing the value to 1 again.

Hope this work for you
Just click on it and it'll open, probably in TextEdit. That's all there is to it.

#27 burdisthewurd

burdisthewurd

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 3000 384MB
  • Operating System:Mac OS X 10.7 (Lion)

Posted 19 June 2012 - 09:20 AM

I'm currently on 1.6.89.0.6 and am also having this problem. Is there no way at all to fix this? Could it be the update file I am using? [link removed - Please do not post warez links]

I have also crashed twice while under water with this "green screen" and those were the only times I've crashed. Could this have any correlation to the PS3 water bug as well?

Any help would be much appreciated. :)

#28 smellybo

smellybo

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • Graphics Card:Graphics Intel HD Graphics 3000 512 MB / AMD Radeon HD 6750M 1024 MB
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG

Posted 20 June 2012 - 07:18 AM

Changing the depth of filed did not help me but I found this mod that helped solve the problem. This mod is found here: http://skyrim.nexusmods.com/mods/14007 I hope this helps you

#29 bernusdellus

bernusdellus

    Lurker

  • Members
  • 1 posts
  • Graphics Card:NVIDIA GT120
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 09 December 2012 - 02:25 AM

Instant, easy fix.

go to /documents/my games/skyrim/skyrimPrefs

open the SkyrimPrefs file in a text editor.

find the line: bDoDepthOfField=1

and change it to:bDoDepthOfField=0

save and exit the file.

re-launch skyrim and ye shall see underwater!

Enjoy.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users