Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Halo, install cannot load "pidgen.dll"


  • Please log in to reply
5 replies to this topic

#1 ElBanditoVerde

ElBanditoVerde

    Regular Member

  • Members
  • Pip
  • 18 posts
  • Graphics Card:NVIDIA GeForce GT 330M
  • Operating System:OS X 10.9 (Mavericks)

Posted 09 August 2013 - 06:27 PM

Hi,

I'm trying to port my old copy of Halo CE over using wineskin. In accordance with the winehq appdb I tried to load mfc42 using the winetricks before installing Halo. While the command triggers a german EULA agreement which I agree to the window command line window reads "vcredist.exe not found" and when I try to install halo into the wineskin wrapper I get the error "cannot load pidgen.dll". Now it appears that the reason mfc42 has to be loaded is to deal with this exact occurance. However, I'm not sure if the failing is with winetricks or winskin itself. Any help would be greatly apprcetiated.

Using:
Wine Ver. 1.6-rc5
WS9Wine1.7.0X
Mac OS X Lion Ver. 10.7.5

with: MacBook Pro; 2.66Ghz i7; NVIDIA GeForce GT 330M 512mb


Thanks

#2 ElBanditoVerde

ElBanditoVerde

    Regular Member

  • Members
  • Pip
  • 18 posts
  • Graphics Card:NVIDIA GeForce GT 330M
  • Operating System:OS X 10.9 (Mavericks)

Posted 13 August 2013 - 04:09 PM

Alright, I got around the original problem by pulling a copy of the mfc42.dll from a virtual machine of mine and placing it in the system32 file. Now however I am getting the error "Cannot allocate required memory. Some other application has loaded where Halo needs to be located". For normal PCs this occurs due to a conflict with an IE update, however this is wine and there is no IE, only geko...

#3 thedoc

thedoc

    Administration Team

  • Administrators
  • 1,311 posts
  • Graphics Card:nVidia GeForce 9600M GT - 512 MB RAM
  • Operating System:Mac OS X 10.5 (Leopard)
  • I like to play:FPS, RPG, Racing

Posted 13 August 2013 - 04:12 PM

try this wrapper it should work out of the box - don't change the engine though or the game will fail to launch! http://www.mediafire...z/haloce.tar.7z
Posted Image

Check out my Porting Blog @ Doc's Office


#4 ElBanditoVerde

ElBanditoVerde

    Regular Member

  • Members
  • Pip
  • 18 posts
  • Graphics Card:NVIDIA GeForce GT 330M
  • Operating System:OS X 10.9 (Mavericks)

Posted 14 August 2013 - 04:24 PM

Thanks, the wrapper works flawlessly; if possible, could you explain why other engines get that memory error?

#5 thedoc

thedoc

    Administration Team

  • Administrators
  • 1,311 posts
  • Graphics Card:nVidia GeForce 9600M GT - 512 MB RAM
  • Operating System:Mac OS X 10.5 (Leopard)
  • I like to play:FPS, RPG, Racing

Posted 15 August 2013 - 10:32 AM

You need to use the wine binary file from a pre 1.1.20 Wine build - all later builds show the error you mentioned above.
Posted Image

Check out my Porting Blog @ Doc's Office


#6 sonsandsonsadnsons

sonsandsonsadnsons

    Regular Member

  • Members
  • Pip
  • 17 posts
  • Graphics Card:NVIDIA GeForce GT 750M 2048 MB graphics
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:Retro & Modern

Posted 10 February 2019 - 07:08 PM

All i'm getting is "Error this engine is corrupt or opened incorrectly" when I'm just trying to create a blank wrapper

when i try using any wrapper pre 1.1.20 it wont even open the exe or install menus don't work.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users