Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Tutorial info

  • Added on: Mar 31 2012 06:37 PM
  • Date Updated: May 02 2012 11:02 AM
  • Views: 5152


* * * * *
1 Ratings

How to build custom engine with Wineskin and Xcode 4.3.1+

guide how to patch WineskingEngineBuild and how to get gcc-4.2 back to system.

Posted by julus on Mar 31 2012 06:37 PM
This tutorial has became obsolete with the W2.5.5v1EngineBase

How to build custom engine with Wineskin and Xcode 4.3.1+

This is basically manual to patch the wineskin build engine, so you can use the wineskin winery to build wine as usual

The apple has changed quite a few things in new xcode, so here is manual how build custom engine with xcode.
Even though the wine can be compiled using clang, I cannot recommend it as this is completly untested territory (but it works). So if you want to be safe, perform the optional steps.


Features
  • Use gcc-4.2 (if available), otherwise use clang
  • Detects new SDK path
  • Use clang over gcc-4.2 if the /Developer/SDKs/MacOSX10.6.sdk is missing
  • Speedup of compile process (make -j3)
  • Automatically patches the wine source code to be able to compile with clang and reverts if using gcc-4.2
  • Force the clang to use --disable-win16 as the assembly will fail otherwise
Prerequisites
this patch (at least until doh123 will make a new version of builder)
install commandlinetools via XCode>Preferences>Downloads>Components>Command line tools

Now, the steps:
copy and patch the WineskinEngineBuild
cp WineskinEngineBuild.diff ~/Library/Application\ Support/Wineskin/EngineBase/W2.5.4v3EngineBase/builder.patch
cd ~/Library/Application\ Support/Wineskin/EngineBase/W2.5.4v3EngineBase/
patch -p1 < builder.patch
and that is pretty much anything... now build wine via wineskin winery as usual


Optional:

Install gcc-4.2

download the osx gcc installerfor your system version (not target) and install it.

Extract MacOSX10.6.sdk from Xcode 4.1 installer - this is needed to compile wine using gcc-4.2 with snow leopard support:
You dont have to do these steps, if you still have the /Developer/SDKs/MacOSX10.6.sdk directory
  • install The Unarchiver from app store (free)
  • mount xcode4.1 dmg
  • copy the InstallXcodeLion.pkg somewhere on disk
  • right click and select open in application > the unarchiver
  • go to new InstallXcodeLion directory > right click on InstallXcodeLion.pkg and click show contents
  • move Payload file somewhere else and rename it to Payload.cpio and double click it, the unarchiver will unpack it
  • go to new payload directory >  Applications > right click on install Xcode and show contents
  • locate the MacOSX10.6.pkg in Contents>Resources>Packages directory and move it somewhere else
  • now right click the MacOSX10.6.pkg and select open in application > the unarchiver
  • in the new MacOSX10.6 directory, rename payload file to payload.tar.gz and double click it to unpack it
  • Now finally move the new created SDKs folder to /Developer folder (create if it does not exists)
If you encounter any problems, or have suggestion of improving, please post here.
7 Comments
where do i download XCOde I need Dem Codes Man
  • Report

blinxfrost, on 01 April 2012 - 10:51 PM, said:

where do i download XCOde I need Dem Codes Man
Its called "the app store" LOL :D
  • Report
Or you can google for the developers site, register as a developer, and download the version you want.
I'm on SL, and since they only have XCode for Lion on the TAS, I had to do that.
  • Report
Erm julus, just have one quick question...
I can't seem to find commandlinetools in XCode 4.2 for Snow Leopard.
Posted Image
  • Report
PS. If I'm using the latest engine base, being W2.5.5v1EngineBase...
There's no builder.patch.
So is the patching for the WineskinEngineBuild required?
  • Report
No patching required for W2.5.5v1EngineBase
also this patch was for Xcode 4.3.1+ and newer. 4.2 is screwed up
  • Report
with W2.5.5v1EngineBase and later, gcc-4.2 is included, and if its missing on your machine, it'll ask you about installing it, and install it for you... it will also use the SDK from any xcode 3.x or 4.x
  • Report
Powered by Tutorials 1.3.1 © 2017, by Michael McCune