Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Porter

Port Information

  • Submitted: Sep 07 2014 09:09 PM
  • Last Updated: Sep 08 2014 05:26 PM
  • Views: 34692
  • Downloads: 3042

Wrapper Type & Video Card Compatibility

  • Wrapper Type: Wineskin
  • Wine Version: Wineskin 2.6
  • ATI / AMD: GREEN (fully playable)
  • NVIDIA: GREEN (fully playable)
  • Intel GMA: GREY (not tested)
  • Intel HD: GREY (not tested)

Wrapper Type Info

Note:
Wrappers have different Mac OS X compatibility!

Wineskin:   10.610.710.810.9
Cider:          10.610.710.810.9
CXZ/CXEx:  10.610.710.810.9

What is WINE & what is a Wrapper?

Video Card Info

 GREY          = not tested
 GREEN        = fully playable
 YELLOW     = playable with minor glitches
 ORANGE     = playable with some effort
 RED             = severe glitches / unplayable

Download Freeware Port STAR WARS The Old Republic 1.0

* * * - - 7 Votes Please vote for the Quality of this Port / Wrapper, not for the Game or Application!




Screenshots
Star Wars: The Old Republic, often abbreviated as SWTOR, is a massively multiplayer online role-playing game (MMORPG) based in the Star Wars universe. Developed by BioWare Austin and a supplemental team at BioWare Edmonton.

Personal Notes:
- SWTOR_FIX was used for run SWTOR without problems it will minimized after Launch and must run in background for Playing.
- I Played now with this wrapper the last week over 20 Hours without problems.
- The Game runs fine with 45 - 65 fps on my System.
- No know Bugs for Now game is Fully Playable.

PS - Sorry for my Bad Englisch my German is much better. I ve you have any trubble with the Wrapper feel free to write me a personal Message. Have fun and enjoy SWTOR on a Mac and never go Back :-)

My System Specs:
- Mac:    Apple MacPro 3.1 (2008)
- OS: Mac OS-X 10.94
- CPU: 2x Intel XEON 3,00 GHZ QuadCore
- RAM:   32GB DDR-3 FB-DIMM
- Video: Sapphire AMD 7950 for Mac
- Disk Space: 25gb of HDD Space for the Game ( maybe it will increase the size with further patches from BioWare )

Known Issues:
- It Takes 3 to 6 Minutes Loading for each Level or Location.
- Settings can only changed in main Menu / Character Selection Screen not in Game. (anyway it will Crash)
- Switch from Fullscreen to Window can crash the game somtimes.

Installation:
1. Unpack the Wrapper with 7zx for Mac. get it at http://www.macupdate...p/mac/20526/7zx
2. Drop the App into your Applications Folder on your Mac.
3. Start the Wrapper and Log-In with your User-Account and patch the game and have Fun.
4. You can set the Launcher Language in the Options.
5. Have Fun.

What's New in Version 1.0 (See full changelog)

  • - Initial Release


Screenshots

Screenshots Screenshots


Worked fine on Macbook Pro 13" with retina and Iris graphics until the Sept. 9th patch. Now it goes to a blank screen past the initial loading screen before game menu. Am I doing something wrong?

*it ran perfectly fine on decent setting prior to the new patch and on the windows side it runs almost flawless on my machine at fairly decent settings. Heck even my wifes 13" samsung ultrabook with an i3 and intel 4000 graphics runs it at decent speeds.
@youngbr93: Sorry to hear that but you must be doing somthing wrong, the Wrapper is working without any trouble after the 9th September Update for me. So i going back to play SWTOR
2012 rMBP here, works! Make sure you have enough hard drive space for installing(it requires like 20gbs), cause it won't tell you if you don't. The install will just stop and you can't restart it again.

The game doesn't run that great. I'm running at 1400x900 on High settings and it averages around 25 fps. I got a crash after about 10 minutes, but I'm also running the OS X 10.10 beta so that could be affecting performance. Cheers and thanks for making this!!
I am having the exact same problem as @youngbr93.  Worked fine on Macbook Pro 13" retina late 2013 until latest patch.  Now all I get is blank screen past the initial loading screen before game menu.  

Game still works (mostly) fine on iMac 27" mid 2011 with AMD Radeon HD 6770M 512 MB

game still works okay in bootcamp on the Macbook
hängt sporadisch nach einigen Minuten des Spielens. macbook pro 15 Retina. geforce 750
solved hanging by installing http://gfx.io and forced macbook to use geforce
i was wrong. gfx.io dint solve the issue
Hi, I was trying to play the game but everything was very laggy and the screen kept flashing. Eventually I started the Jedi Knight quest but since it took so long to load, I decided to do a hard restart. When I restarted my computer, the loading screen is still flashing over my regular desktop, but at a very low opacity so I can still easily see the desktop screen. I tried restarting again but it is still there.
I am on an iMac with Mavericks.
Is there anything I can do to fix this?
I had flashing too, till I changed the resolution
I'm having problems with loading time and latency, making it nearly unplayable, it was working, is there something I could change to fix these latency problems, I'm already on low settings?
Hi leonard, I'm not playing this on my mac, so I can't say if this is going to help. But try finding the client_settings.ini inside the wrapper (I don't know where, just search for it) and add/change some of these values, to look more like this:

Quote

UseMinSpecShaders = true
doShadows = false
doBlobShadows = false
GraphicsQuality = 6
FarClipScale = 0.0071195  
PlantDensity = 0
TextureQuality = 5
AmbientNPCCount = 15
Of course lower your resolution to 1024x768 or below.
Then right click on the .ini and make it read only for all users and lock the file, so the game can't change these on its own.

The Intel HD3000 probably can't render this game at a bearable speed. The settings above could ease things out. The game will look terrible though. But I would avoid playing this with your integrated card anyway. Thats why I didn't test this out on my mac.
thanks Zephon, I'll try that.
I'm still having trouble with latency, I am using the above settings and still it is unbearable. I am screwed because I'm using an Intel HD3000 graphics card?

Quote

I am screwed because I'm using an Intel HD3000 graphics card?

Most likely, thats the case. But what latency issues are you having exactly? Is it lagging/rubberbanding, or stuttering?

I googled a bit, and read somewhere, that you could try to disable scaling of the nametags in the game options. Of course you have to unlock your client_settings.ini again for doing so. Try playing in windowed mode as well, by adding Fullscreen = false into the .ini.

The Game didn't change the settings back by any chance, last time you tried it? Always check, after playing the game.
nope, it didn't change back, the fps is extremely low, some times it gets bearable and even awesome. also, certain interactions cause the HUD to disappear and the game to freeze, I'll try your new suggestions. Is there a way to have the graphics processed more by my CPU than my GPU?



42 user(s) are online (in the past 15 minutes)

0 members, 42 guests, 0 anonymous users