Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Porter

Port Information

  • Submitted: Sep 07 2014 09:09 PM
  • Last Updated: Sep 08 2014 05:26 PM
  • Views: 34539
  • Downloads: 3042

Wrapper Type & Video Card Compatibility

  • Wrapper Type: Wineskin
  • Wine Version: Wineskin 2.6
  • ATI / AMD: GREEN (fully playable)
  • NVIDIA: GREEN (fully playable)
  • Intel GMA: GREY (not tested)
  • Intel HD: GREY (not tested)

Wrapper Type Info

Note:
Wrappers have different Mac OS X compatibility!

Wineskin:   10.610.710.810.9
Cider:          10.610.710.810.9
CXZ/CXEx:  10.610.710.810.9

What is WINE & what is a Wrapper?

Video Card Info

 GREY          = not tested
 GREEN        = fully playable
 YELLOW     = playable with minor glitches
 ORANGE     = playable with some effort
 RED             = severe glitches / unplayable

Download Freeware Port STAR WARS The Old Republic 1.0

* * * - - 7 Votes Please vote for the Quality of this Port / Wrapper, not for the Game or Application!




Screenshots
Star Wars: The Old Republic, often abbreviated as SWTOR, is a massively multiplayer online role-playing game (MMORPG) based in the Star Wars universe. Developed by BioWare Austin and a supplemental team at BioWare Edmonton.

Personal Notes:
- SWTOR_FIX was used for run SWTOR without problems it will minimized after Launch and must run in background for Playing.
- I Played now with this wrapper the last week over 20 Hours without problems.
- The Game runs fine with 45 - 65 fps on my System.
- No know Bugs for Now game is Fully Playable.

PS - Sorry for my Bad Englisch my German is much better. I ve you have any trubble with the Wrapper feel free to write me a personal Message. Have fun and enjoy SWTOR on a Mac and never go Back :-)

My System Specs:
- Mac:    Apple MacPro 3.1 (2008)
- OS: Mac OS-X 10.94
- CPU: 2x Intel XEON 3,00 GHZ QuadCore
- RAM:   32GB DDR-3 FB-DIMM
- Video: Sapphire AMD 7950 for Mac
- Disk Space: 25gb of HDD Space for the Game ( maybe it will increase the size with further patches from BioWare )

Known Issues:
- It Takes 3 to 6 Minutes Loading for each Level or Location.
- Settings can only changed in main Menu / Character Selection Screen not in Game. (anyway it will Crash)
- Switch from Fullscreen to Window can crash the game somtimes.

Installation:
1. Unpack the Wrapper with 7zx for Mac. get it at http://www.macupdate...p/mac/20526/7zx
2. Drop the App into your Applications Folder on your Mac.
3. Start the Wrapper and Log-In with your User-Account and patch the game and have Fun.
4. You can set the Launcher Language in the Options.
5. Have Fun.

What's New in Version 1.0 (See full changelog)

  • - Initial Release


Screenshots

Screenshots Screenshots


Quote

The only interesting point are the loading times... with this wrapper are really really fast. Why?

Because the Wrapper isn't loading the graphics portion of the game. I used crashoverridese's wrapper and relogged on Nar Shaddaa. Loading Times: 3-5 minutes. I relogged on my personal ship and the loading times decreased dramatically (20s - 1 min). It is a matter of how much the game has to load upon entering an area. And if nothing is there, the speed of the game increases.

To get your ME3 Wrapper to work, try finding similarities to crashoverridese's wrapper. For example, by starting regedit (through Wineskin.app inside the wrapper) and find Wineskins (under HKEY_CURRENT_USER) Direct3D directory. There you can see with what preferences both wrappers are set up. Try adding settings from one wrapper to another. A lot of trial and error, but maybe necessary if you want to get it fixed. Here are additional options:

http://wiki.winehq.o...fulRegistryKeys

youngbr93, on 09 September 2014 - 08:02 PM, said:

Worked fine on Macbook Pro 13" with retina and Iris graphics until the Sept. 9th patch. Now it goes to a blank screen past the initial loading screen before game menu. Am I doing something wrong?

*it ran perfectly fine on decent setting prior to the new patch and on the windows side it runs almost flawless on my machine at fairly decent settings. Heck even my wifes 13" samsung ultrabook with an i3 and intel 4000 graphics runs it at decent speeds.

I am having this same problem. After the initial load screen I get a blank black screen. I do have a cursor but nothing else and no sound.
The game works fine for me. Except it freezes pretty much all the time, and it takes about 15 minutes to load in the beginning.

I used Zephon's suggestion on altering the client_settings.ini inside the wrapper, but didn't make a huge difference.

Mind you, I have a 13 inch, Mid 2012 MacBookPro with
i OS X 10.9.5
2.5 GHz Intel Core i5
4 GB 1600 MHz DDR3
Intel HD Graphics 4000 1024 MB

Something else to add here:

I played this game perfectly on Crossovers till the Sept. 9th patch. There were no freezes, and it loaded very quickly. Somehow this port manages to go past the patch, however it doesn't play as well as Crossovers managed it to.

Looking into Crossovers could help people who are more experienced in porting games than I to get this game into playable condition.
SWTOR is playable until you reach Taris. as soon as you enter Waypoint Station Aurek in the Sinking City region the game freezes and freezes everytime you reload. That makes the whole region unplayable!
i dont know how to use a wrapper but am interested could someone help me

Quote

I used Zephon's suggestion on altering the client_settings.ini inside the wrapper, but didn't make a huge difference

You changed the file to read only and locked it as well? You should notice at least some changes. I reconfigured my file to the (horribly) lowest possible settings and uploaded it here:

http://cl.ly/code/1S29051i2q1p

Try this (locked and read only) and see if it changes anything. The game should look like utter horsecrap if you applied it right. If so, you have to scale the settings higher until you are satisfied and always lock it again after altering. Your HD4000 should run the game better than my setup...

The freezes are perhaps caused by the map and quest-bug. I mentioned it in one of my earlier comments. Try avoiding certain Interface-Areas with your mouse.

Have you also tried changing the Wine Engine to A Crossover Engine? Namely the WS9WineCX ones
I'm trying Crossover right now. Until now I cannot go after the zone loading screen. It crashes (immediately after char selection screen). Dunno why (because a lot of Crossover users reported as fully functional)...

osmanleon, on 02 October 2014 - 05:10 PM, said:

The game works fine for me. Except it freezes pretty much all the time, and it takes about 15 minutes to load in the beginning.

I used Zephon's suggestion on altering the client_settings.ini inside the wrapper, but didn't make a huge difference.

Mind you, I have a 13 inch, Mid 2012 MacBookPro with
i OS X 10.9.5
2.5 GHz Intel Core i5
4 GB 1600 MHz DDR3
Intel HD Graphics 4000 1024 MB

Something else to add here:

I played this game perfectly on Crossovers till the Sept. 9th patch. There were no freezes, and it loaded very quickly. Somehow this port manages to go past the patch, however it doesn't play as well as Crossovers managed it to.

Looking into Crossovers could help people who are more experienced in porting games than I to get this game into playable condition.
Have you tried to play it with the latest SWTOR patch? What kind of issues you got after 9th Sept patch?
Guys, after the patch of 15/10/14, I am no longer to use the wrapper, the game just doesn't start. it worked fine before. I'm on a 15-inch, Mid 2012 MacBook Pro, on OS X 10.9.3, Intel HD Graphics 4000 Graphic Card, 8 GB 1600 MHz DDR3, 2.6 GHz Intel Core i7. Any solutions? Its a new launcher apparently, so that may help.
The Wrapper is working for me after the Ptach from 15/10/14 very well.
Me too, with two exceptions:
1. Some Datacrons are unreachable because jumping is not very exact.
2. Taris is so slow that it is unplayable.
So far, so bad.

After various attempts, I got through character creation and the opening cut screen (with a lot of audio stutters). It popped up a message about optimum graphic settings that I clicked, gave me a dialog to keep or revert the settings, and then nothing..wasn't a freeze, as the sound kept going, but it just wouldn't go away regardless of clicks. I force quit, reopened the game, and then after going to character selection screen to enter the game, it just sat on the loading screen (with music playing) and never progressed.
MBP mid 2010 here
Game completely unplayable. In the character selection screen the fps goes down to about 0.20 [sic!]@ 800x600, so it's complete garbage. But I realise it's the hardware's fault, because the game installs and runs fine. I even changed some game settings without causing the game to crash!

Edit:
specs, if sb would like to know:
2.4GHz Core 2 Duo, 6GB RAM, GeForce 320M, OCZ SSD as main storage
using a macbook pro, I was able to download and to login in, but it stops at the loading screen before character selection. What do I do to fix it?

Zephon, on 12 October 2014 - 08:22 AM, said:

Have you also tried changing the Wine Engine to A Crossover Engine? Namely the WS9WineCX ones

I couldn't figure out a way to work it with a Crossover Engine.

Thelothian, on 13 October 2014 - 06:56 PM, said:

Have you tried to play it with the latest SWTOR patch? What kind of issues you got after 9th Sept patch?

It didn't even let me load the game until the 3.0.2 patch. I've managed to download the 3.0.2 last Saturday (01/17/15), and now it works perfectly. Even the graphics are pretty good. Still with the same settings that Zephon suggested. Only downside is it takes about 10 minutes for the menu to load with the whole screen flickering, then when I change the resolution, it goes back to normal. Then it takes another 10 minutes to load the game, but once that's done, it's in perfect condition.

New locations do freeze countless of times, but never at the same place. So if you are patient, there is hope.

Since crashoverridese's port is working for me now, I didn't go back to Crossovers to try it.



11 user(s) are online (in the past 15 minutes)

1 members, 9 guests, 0 anonymous users


Google, tybruh