Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Porter

Port Information

  • Submitted: Sep 07 2014 09:09 PM
  • Last Updated: Sep 08 2014 05:26 PM
  • Views: 34681
  • Downloads: 3042

Wrapper Type & Video Card Compatibility

  • Wrapper Type: Wineskin
  • Wine Version: Wineskin 2.6
  • ATI / AMD: GREEN (fully playable)
  • NVIDIA: GREEN (fully playable)
  • Intel GMA: GREY (not tested)
  • Intel HD: GREY (not tested)

Wrapper Type Info

Note:
Wrappers have different Mac OS X compatibility!

Wineskin:   10.610.710.810.9
Cider:          10.610.710.810.9
CXZ/CXEx:  10.610.710.810.9

What is WINE & what is a Wrapper?

Video Card Info

 GREY          = not tested
 GREEN        = fully playable
 YELLOW     = playable with minor glitches
 ORANGE     = playable with some effort
 RED             = severe glitches / unplayable

Download Freeware Port STAR WARS The Old Republic 1.0

* * * - - 7 Votes Please vote for the Quality of this Port / Wrapper, not for the Game or Application!




Screenshots
Star Wars: The Old Republic, often abbreviated as SWTOR, is a massively multiplayer online role-playing game (MMORPG) based in the Star Wars universe. Developed by BioWare Austin and a supplemental team at BioWare Edmonton.

Personal Notes:
- SWTOR_FIX was used for run SWTOR without problems it will minimized after Launch and must run in background for Playing.
- I Played now with this wrapper the last week over 20 Hours without problems.
- The Game runs fine with 45 - 65 fps on my System.
- No know Bugs for Now game is Fully Playable.

PS - Sorry for my Bad Englisch my German is much better. I ve you have any trubble with the Wrapper feel free to write me a personal Message. Have fun and enjoy SWTOR on a Mac and never go Back :-)

My System Specs:
- Mac:    Apple MacPro 3.1 (2008)
- OS: Mac OS-X 10.94
- CPU: 2x Intel XEON 3,00 GHZ QuadCore
- RAM:   32GB DDR-3 FB-DIMM
- Video: Sapphire AMD 7950 for Mac
- Disk Space: 25gb of HDD Space for the Game ( maybe it will increase the size with further patches from BioWare )

Known Issues:
- It Takes 3 to 6 Minutes Loading for each Level or Location.
- Settings can only changed in main Menu / Character Selection Screen not in Game. (anyway it will Crash)
- Switch from Fullscreen to Window can crash the game somtimes.

Installation:
1. Unpack the Wrapper with 7zx for Mac. get it at http://www.macupdate...p/mac/20526/7zx
2. Drop the App into your Applications Folder on your Mac.
3. Start the Wrapper and Log-In with your User-Account and patch the game and have Fun.
4. You can set the Launcher Language in the Options.
5. Have Fun.

What's New in Version 1.0 (See full changelog)

  • - Initial Release


Screenshots

Screenshots Screenshots


Marceldp1234, on 18 January 2016 - 12:05 AM, said:

When i open it it gets stuck on loading, been like that for 40 minutes.
same tbh. I even left it for almost 2+ hours but its just wont start
i thought it was the heavy graphics that caused problems, but i doubt it. I run sims 4 and skyrim at high resolution in my mac and everything's fine.

probably the wrapper tho. ugh
a1181 plays but its in german  how do i translate?

iminzc, on 20 June 2016 - 07:35 PM, said:

a1181 plays but its in german  how do i translate?

Click on the "Settings" gear button on the launcher when you're logging in. You should be able to change the language there.
Well I did all the steps (including updating the WineSkin engine to WS9Wine1.752) and the launcher opened for me, updated, downloaded everything, but when I get to the loading screen after hitting "play" it just freezes... Any thoughts? Thanks.

Meier, on 26 June 2016 - 06:52 AM, said:

after hitting "play" it just freezes... Any thoughts? Thanks.

Do you get flicker on the screen?
My game just freezes when loading into game.
I hit play and go to loading screen. After 2 minutes some sound appears then cuts out and blue circle stops rotating. Any advice?

Shimmery1009, on 07 January 2017 - 07:27 PM, said:

I hit play and go to loading screen. After 2 minutes some sound appears then cuts out and blue circle stops rotating. Any advice?

Try using my wrapper instead. The owner of this wrapper has not updated it in years. http://portingteam.c...e-old-republic/



48 user(s) are online (in the past 15 minutes)

0 members, 47 guests, 0 anonymous users


Google