Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Every wrapper with Steam install is crashing


  • Please log in to reply
4 replies to this topic

#1 FukuKurihara

FukuKurihara

    Novice Member

  • Members
  • 8 posts
  • LocationTokyo
  • Graphics Card:NVIDIA GeForce GT 330M 512 MB
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:Check out my games here : http://steamcommunity.com/id/n_v14404/
Author

Posted 27 June 2014 - 05:22 AM

Dear PortingTeam discussion community,

Recently it has been the biggest Steam Summer Sale yet, and everybody's buying new, cool games. The thing is, almost over 3/4 of steam games are for PC. So I looked through this forum and found the wrappers for the games I wanted and see if they were steam compatible. So I got the games on steam and I followed every process, and the result was very unexpected. I almost see no users with this problem.

This is a very detailed explanation:
The games I bought were the following: "Payday: The Heist", "Payday 2", and "FarCry 3"

The ports were all by DanIsTheMan, and I need serious help.
Basically all of these ports had a way to play these games through Steam. In order to do this, you had to download the wrapper, show package contents, install Steam through the custom made installer app, change the Windows EXE line to /Program Files/Steam/Steam.exe, and run the wrapper, install the game, and play it through the library.

Now here's where I got stuck:
After successfully installing Steam and changing the Windows EXE line to Steam.exe, I opened the wrapper like anyone else would, and a updating steam window came up. I just let it do its thing, and the next thing you know, the window is gone, and the app had closed all by itself. Now I looked through the forums and found out the Razer Synapse app for mac had to do something with the wrapper not functioning, so I uninstalled the app and rebooted the mac. I opened the wrapper, same thing repeated. I tried doing things over again with a new downloaded wrapper, same thing happened again.

Here are my specs:
MacBook Pro 15-inch, Mid 2010
Processer : 2.66 GHz Intel Core i7
Memory : 4GB 1067 MHz DDR3
Graphics : NVIDIA GeForce GT 330M 512MB
Software : OS X Mountain Lion 10.8.5

Many users that replied to these types of unexpected errors in other discussions asked for the wine logs, so here they are:
The following includes the test results for the Payday 2 wrapper by DanIsTheMan.
fixme:ver:GetCurrentPackageId (0x32e4e0 0x0): stub
fixme:advapi:EventRegister {47a9201e-73b0-42ce-9821-7e134361bc6f}, 0x3f0070b0, 0x3f041ce8, 0x3f041ce0
fixme:advapi:EventRegister {58a9201e-73b0-42ce-9821-7e134361bc70}, 0x3f0070b0, 0x3f041d20, 0x3f041d18
fixme:advapi:EventRegister {3fa9201e-73b0-43fe-9821-7e145359bc6f}, 0x3f0070b0, 0x3f041cb0, 0x3f041ca8
fixme:advapi:EventRegister {1432afee-73b0-42ce-9821-7e134361b433}, 0x3f0070b0, 0x3f041d58, 0x3f041d50
fixme:advapi:EventRegister {4372afee-73b0-42ce-9821-7e134361b519}, 0x3f0070b0, 0x3f041d90, 0x3f041d88
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winsock:WSAIoctl ignoring keepalive interval and timeout
fixme:winsock:WSAIoctl ignoring keepalive interval and timeout
fixme:advapi:EventRegister {47a9201e-73b0-42ce-9821-7e134361bc6f}, 0x3f0070b0, 0x3f041ce8, 0x3f041ce0
fixme:advapi:EventRegister {58a9201e-73b0-42ce-9821-7e134361bc70}, 0x3f0070b0, 0x3f041d20, 0x3f041d18
fixme:advapi:EventRegister {3fa9201e-73b0-43fe-9821-7e145359bc6f}, 0x3f0070b0, 0x3f041cb0, 0x3f041ca8
fixme:advapi:EventRegister {1432afee-73b0-42ce-9821-7e134361b433}, 0x3f0070b0, 0x3f041d58, 0x3f041d50
fixme:advapi:EventRegister {4372afee-73b0-42ce-9821-7e134361b519}, 0x3f0070b0, 0x3f041d90, 0x3f041d88
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:imm:ImmGetOpenStatus (0x13d93e8): semi-stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:ver:GetCurrentPackageId (0x32de7c 0x0): stub
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
[0627/141529:ERROR:resource_bundle.cc(417)] Failed to load C:\Program Files\Steam\bin\chrome.pak
Some features may not be available.
fixme:dwmapi:DwmSetWindowAttribute (0x10088, 2, 0x32e488, 4) stub
fixme:dwmapi:DwmSetWindowAttribute (0x10088, 3, 0x32e494, 4) stub
fixme:dwmapi:DwmSetWindowAttribute (0x10088, 4, 0x32e484, 4) stub
[0627/141529:FATAL:browser_database_system.cc(40)] Check failed: temp_dir_.CreateUniqueTempDir().
fixme:ver:GetCurrentPackageId (0x30e320 0x0): stub
fixme:winsock:WSAIoctl ignoring keepalive interval and timeout
fixme:hnetcfg:fw_apps_get__NewEnum 0x1578b98, 0xdc8ed64
fixme:hnetcfg:fw_app_put_ProcessImageFileName 0x14f1b10, L"C:\\Program Files\\Steam\\steam.exe"
fixme:hnetcfg:fw_app_put_Name 0x14f1b10, L"Steam"
fixme:hnetcfg:fw_app_put_Enabled 0x14f1b10, -1
fixme:hnetcfg:fw_apps_Add 0x1598d90, 0x14f1b10
err:ole:CoGetClassObject class {e2b3c97f-6ae1-41ac-817a-f6f92166d7dd} not registered
err:ole:CoGetClassObject no class object {e2b3c97f-6ae1-41ac-817a-f6f92166d7dd} could be created for context 0x1
fixme:advapi:StopTraceA (0, "Steam Event Tracing", 0xdc8e6c4) stub
fixme:advapi:StartTraceA (0xdc8e750, "Steam Event Tracing", 0xdc8e6c4) stub
fixme:advapi:OpenTraceA 0xdc8e524: stub
fixme:advapi:EnableTrace (1, 0x10, 4, {22fb2cd6-0e7b-422b-a0c7-2fad1fd0e716}, cafe4242): stub
fixme:advapi:CloseTrace cafe4242: stub
fixme:advapi:ProcessTrace 0xe05ba48 1 0x0 0x0: stub
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:ver:GetCurrentPackageId (0xd69ec60 0x0): stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub
fixme:advapi:EventUnregister deadbeef: stub

I would appreciate a fix for this, especially since I don't want to have my 40 bucks down the drain. I understand that FarCry 3 has a different approach and process to installing the game, but my main point of this discussions is a request for a fix, a brief description on how to fix it, and if there is anyway to create a wrapper myself to make these games work.

I hope the log above helped, please reply asap.

Thank you for taking the time to read this post, there are many out there,
but I appreciate you choosing to help me out of all the others first.

Sincerely,
FukuKurihara

#2 smooth_jazz

smooth_jazz

    Lurker

  • Members
  • 2 posts
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)

Posted 27 June 2014 - 12:00 PM

I'm not sure how to fix the wrappers that you are currently using, but as to making a wrapper yourself, there are several tutorials on this site for how to use wineskin winery to make your own wrapper. That's what I had to do for Payday 2, because Dan's wrapper didn't work for me.

#3 FukuKurihara

FukuKurihara

    Novice Member

  • Members
  • 8 posts
  • LocationTokyo
  • Graphics Card:NVIDIA GeForce GT 330M 512 MB
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:Check out my games here : http://steamcommunity.com/id/n_v14404/
Author

Posted 28 June 2014 - 05:58 AM

View Postsmooth_jazz, on 27 June 2014 - 12:00 PM, said:

I'm not sure how to fix the wrappers that you are currently using, but as to making a wrapper yourself, there are several tutorials on this site for how to use wineskin winery to make your own wrapper. That's what I had to do for Payday 2, because Dan's wrapper didn't work for me.

Great, but now when I try to do so, my SteamInstall.msi fails on me. It's been working since last month, but now whenever I open it, it crashes. Do you have a link to a SteamInstall.msi file? Ever since Steam took out the msi and replaced it with Install.exe it's been a pain to get it back.

#4 smooth_jazz

smooth_jazz

    Lurker

  • Members
  • 2 posts
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)

Posted 29 June 2014 - 12:00 AM

View PostFukuKurihara, on 28 June 2014 - 05:58 AM, said:

Great, but now when I try to do so, my SteamInstall.msi fails on me. It's been working since last month, but now whenever I open it, it crashes. Do you have a link to a SteamInstall.msi file? Ever since Steam took out the msi and replaced it with Install.exe it's been a pain to get it back.

You can use the SteamInstall.exe from the Steam website to install it, you don't need a .msi.

#5 Infinite8

Infinite8

    Lurker

  • Members
  • 2 posts
  • Graphics Card:ATI Radeon HD 4850
  • Operating System:OS X 10.9 (Mavericks)

Posted 01 July 2014 - 04:55 AM

View Postsmooth_jazz, on 27 June 2014 - 12:00 PM, said:

I'm not sure how to fix the wrappers that you are currently using, but as to making a wrapper yourself, there are several tutorials on this site for how to use wineskin winery to make your own wrapper. That's what I had to do for Payday 2, because Dan's wrapper didn't work for me.
Can confirm. Having same problem with my Mac. I to am having trouble with Payday 2. You say you made a wrapper. Is it possible for me to use your wrapper?
Edit: Nevermind. I saw that you uploaded it. I'm trying it out now to check it out.
Edit2: Okay so far same problem where steam just closes after updating is happening. I'm gonna continue to look for a solution.
Edit3: Okay I made some progress. I forgot that I had Razer Synapse. I uninstalled it and now I'm at the Steam Setup area. However all the text boxes are blank so it's kind of difficult to install. I'm a see if I can make it through this.
Edit4: Got it to install, however it crashes whenever I hit escape, or start playing.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users