Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Cant get Terraria Wrapper sound working on Mac


  • Please log in to reply
12 replies to this topic

#1 Parallelshadow

Parallelshadow

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Mac OS X 10.7 (Lion)

Posted 23 August 2014 - 05:28 PM

So i got a wineskin wrapper for Terarria and all seem to run pretty well until i get to the actual game.. There is absolutely no sound or music while in game.. also another small problem that isnt as big of a deal is when im running or moving around in the game i can see slight graphical flickering.. sometimes on top screen sometimes bottom agin though this problem can probably be ignored.

Also something to note every time i launch terraria before it opens it pops up with this message..

__CPU does not meet minimum requirements;Streaming SIMD extensions support required.__


LAST WINE LOG:

fixme:heap:HeapSetInformation 0x0 1 0x0 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation 0x0 1 0x0 0
fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
fixme:module:GetModuleHandleExW should pin refcount for 0x79000000
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Game"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Configuration"
fixme:shell:URL_ParseUrl failed to parse L"System.Xml"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Graphics"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Xact"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Input.Touch"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"Accessibility"
fixme:advapi:RegisterTraceGuidsW (0xcd865a, 0x0, {8e9f5090-2d75-4d03-8a81-e5afbf85daf1}, 1, 0x32e15c, (null), (null), 0x110d56c,): stub
fixme:d3d:init_driver_info Unable to find a driver/device info for vendor_id=0x8086 device_id=0xa26 for driver_model=2
fixme:win:EnumDisplayDevicesW ((null),0,0x32cb7c,0x00000000), stub!
fixme:d3d9:D3DPERF_SetOptions (0x2) : stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.GamerServices"
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:gdiplus:GdipCreateHalftonePalette stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.

LAST X11 LOG:

WineskinX11: main(): argc=12
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=12
Attempting to use pixel depth of 24
[ 65282.083] WineskinX11 starting:
[ 65282.083] X.Org X Server 1.13.0
[ 65282.083] Build Date: 20120921
[ 65282.083] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[ 65282.085] Initializing built-in extension Generic Event Extension
[ 65282.085] Initializing built-in extension SHAPE
[ 65282.085] Initializing built-in extension MIT-SHM
[ 65282.085] Initializing built-in extension XInputExtension
[ 65282.085] Initializing built-in extension XTEST
[ 65282.085] Initializing built-in extension BIG-REQUESTS
[ 65282.085] Initializing built-in extension SYNC
[ 65282.085] Initializing built-in extension XKEYBOARD
[ 65282.085] Initializing built-in extension XC-MISC
[ 65282.085] Initializing built-in extension XINERAMA
[ 65282.085] Initializing built-in extension PseudoramiX
[ 65282.085] Initializing built-in extension XFIXES
[ 65282.085] Initializing built-in extension RENDER
[ 65282.085] Initializing built-in extension RANDR
[ 65282.085] Initializing built-in extension DAMAGE
[ 65282.085] Initializing built-in extension MIT-SCREEN-SAVER
[ 65282.085] Initializing built-in extension DOUBLE-BUFFER
[ 65282.085] Initializing built-in extension RECORD
[ 65282.085] Initializing built-in extension X-Resource
[ 65282.085] Initializing built-in extension XVideo
[ 65282.085] Initializing built-in extension XVideo-MotionCompensation
[ 65282.085] Initializing built-in extension GLX
[ 65282.085] x: 0, y: 0, w: 1366, h: 746
[ 65282.103] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/75dpi, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/100dpi, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/cyrillic, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/misc, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/OTF, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/Speedo, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/TTF, removing from list!
[ 65282.104] [dix] Could not init font path element /opt/X11/share/fonts/Type1, removing from list!
[ 65282.105] [dix] Could not init font path element /opt/X11/share/fonts/util, removing from list!
[ 65282.227] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
[ 65283.621] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
[ 65283.624] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
Engine Used: WS8Wine1.5.0
Hardware:

    Hardware Overview:

      Model Name: MacBook Air
      Model Identifier: MacBookAir6,1
      Processor Name: Intel Core i5
      Processor Speed: 1.4 GHz
      Number of Processors: 1
      Total Number of Cores: 2
      L2 Cache (per Core): 256 KB
      L3 Cache: 3 MB
      Memory: 4 GB
      Boot ROM Version: MBA61.0099.B12
      SMC Version (system): 2.12f137

Graphics/Displays:

    Intel HD Graphics 5000:

      Chipset Model: Intel HD Graphics 5000
      Type: GPU
      Bus: Built-In
      VRAM (Dynamic, Max): 1536 MB
      Vendor: Intel (0x8086)
      Device ID: 0x0a26
      Revision ID: 0x0009
      Displays:
        Color LCD:
          Display Type: LCD
          Resolution: 1366 x 768
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Built-In: Yes

#2 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 23 August 2014 - 06:12 PM

From winehq:

Quote

If you ran into the stuttering sound issue, all you need to do is install some missing audio codecs using winetricks. Run the following command:

winetricks dirac directmusic dmsynth dsound ffdshow icodecs l3codecx

Also:

Quote

What did fix the problem for me was, after installing the codecs, running winecfg. Go to the Libraries tab and edit both "dsound" and "dswave" to be "builtin, then native." Sound works smoothly for me after this.

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#3 Parallelshadow

Parallelshadow

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Mac OS X 10.7 (Lion)

Posted 23 August 2014 - 07:21 PM

Whole different issue now at the moment... just tried opening the program and a box comes up saying not the right graphics card or somthing... Please help here are the Logs this time

Winskin LOG:

fixme:heap:HeapSetInformation 0x0 1 0x0 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation 0x0 1 0x0 0
fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
fixme:module:GetModuleHandleExW should pin refcount for 0x79000000
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Game"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Configuration"
fixme:shell:URL_ParseUrl failed to parse L"System.Xml"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Graphics"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Xact"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework.Input.Touch"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"Accessibility"
fixme:advapi:RegisterTraceGuidsW (0xcd865a, 0x0, {8e9f5090-2d75-4d03-8a81-e5afbf85daf1}, 1, 0x32e15c, (null), (null), 0x110d56c,): stub
fixme:d3d:init_driver_info Unable to find a driver/device info for vendor_id=0x8086 device_id=0xa26 for driver_model=2
fixme:win:EnumDisplayDevicesW ((null),0,0x32cb7c,0x00000000), stub!
fixme:d3d9:D3DPERF_SetOptions (0x2) : stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
err:d3d_surface:surface_init_sysmem Failed to allocate memory.
err:d3d_surface:surface_init_sysmem Failed to allocate memory.
err:d3d_surface:surface_modify_location Surface 0x17b340 does not have any up to date location.
err:d3d_surface:surface_modify_location Surface 0x17b340 does not have any up to date location.
fixme:d3d:wined3d_device_decref Something's still holding the stateblock.
err:d3d:resource_init Out of memory!
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:gdiplus:GdipCreateHalftonePalette stub


X11 LOG


WineskinX11: main(): argc=12
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=12
Attempting to use pixel depth of 24
[ 72204.177] WineskinX11 starting:
[ 72204.177] X.Org X Server 1.13.0
[ 72204.177] Build Date: 20120921
[ 72204.177] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[ 72204.180] Initializing built-in extension Generic Event Extension
[ 72204.180] Initializing built-in extension SHAPE
[ 72204.181] Initializing built-in extension MIT-SHM
[ 72204.181] Initializing built-in extension XInputExtension
[ 72204.181] Initializing built-in extension XTEST
[ 72204.181] Initializing built-in extension BIG-REQUESTS
[ 72204.181] Initializing built-in extension SYNC
[ 72204.181] Initializing built-in extension XKEYBOARD
[ 72204.181] Initializing built-in extension XC-MISC
[ 72204.181] Initializing built-in extension XINERAMA
[ 72204.181] Initializing built-in extension PseudoramiX
[ 72204.181] Initializing built-in extension XFIXES
[ 72204.181] Initializing built-in extension RENDER
[ 72204.181] Initializing built-in extension RANDR
[ 72204.181] Initializing built-in extension DAMAGE
[ 72204.181] Initializing built-in extension MIT-SCREEN-SAVER
[ 72204.181] Initializing built-in extension DOUBLE-BUFFER
[ 72204.181] Initializing built-in extension RECORD
[ 72204.181] Initializing built-in extension X-Resource
[ 72204.181] Initializing built-in extension XVideo
[ 72204.181] Initializing built-in extension XVideo-MotionCompensation
[ 72204.181] Initializing built-in extension GLX
[ 72204.181] x: 0, y: 0, w: 1366, h: 746
[ 72204.201] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/75dpi, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/100dpi, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/cyrillic, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/misc, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/OTF, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/Speedo, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/TTF, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/Type1, removing from list!
[ 72204.202] [dix] Could not init font path element /opt/X11/share/fonts/util, removing from list!
[ 72204.352] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
[ 72205.722] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
[ 72205.725] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
Engine Used: WS8Wine1.5.0
Hardware:

    Hardware Overview:

      Model Name: MacBook Air
      Model Identifier: MacBookAir6,1
      Processor Name: Intel Core i5
      Processor Speed: 1.4 GHz
      Number of Processors: 1
      Total Number of Cores: 2
      L2 Cache (per Core): 256 KB
      L3 Cache: 3 MB
      Memory: 4 GB
      Boot ROM Version: MBA61.0099.B12
      SMC Version (system): 2.12f137

Graphics/Displays:

    Intel HD Graphics 5000:

      Chipset Model: Intel HD Graphics 5000
      Type: GPU
      Bus: Built-In
      VRAM (Dynamic, Max): 1536 MB
      Vendor: Intel (0x8086)
      Device ID: 0x0a26
      Revision ID: 0x0009
      Displays:
        Color LCD:
          Display Type: LCD
          Resolution: 1366 x 768
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Built-In: Yes

#4 Parallelshadow

Parallelshadow

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Mac OS X 10.7 (Lion)

Posted 23 August 2014 - 09:06 PM

Bump?

#5 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 24 August 2014 - 12:00 AM

Did you try installing dotnet 4 and xna 4?

#6 Parallelshadow

Parallelshadow

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Mac OS X 10.7 (Lion)

Posted 24 August 2014 - 12:01 AM

Ill try that those are winetricks right?

#7 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 24 August 2014 - 12:03 AM

yes

#8 Parallelshadow

Parallelshadow

    Novice Member

  • Members
  • 5 posts
  • Graphics Card:Intel HD Graphics 5000
  • Operating System:Mac OS X 10.7 (Lion)

Posted 24 August 2014 - 12:06 AM

I dont know if im running the wrong wineskin but i cant find those in winetricks.. am i using too old of an engine?

#9 ovvldc

ovvldc

    Master Member

  • Members
  • 1255 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 24 August 2014 - 03:24 PM

Probably. 1.5.0 is a weird choice anyway. Maybe try 1.4.2 or 1.6.something first.

#10 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 24 August 2014 - 03:31 PM

View PostParallelshadow, on 24 August 2014 - 12:06 AM, said:

I dont know if im running the wrong wineskin but i cant find those in winetricks.. am i using too old of an engine?
has nothing to do with the engine... Are you using Wineskin 2.6.0?  The default Winetricks that comes with it has both of those... you can use the search bar. Or you can update Winetricks to the latest version...

#11 ovvldc

ovvldc

    Master Member

  • Members
  • 1255 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 24 August 2014 - 04:22 PM

I thought some Winetricks versions work better with some engines. Is that (still) true?

#12 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 25 August 2014 - 04:51 AM

typically the latest version is only made for the latest version of Wine... so usually a version of Winetricks that was newest around the same time a Wine version was released... has the best compatibility.

#13 ancestral

ancestral

    Regular Member

  • Members
  • Pip
  • 17 posts
  • Graphics Card:Intel HD Graphics 4000
  • Operating System:OS X 10.9 (Mavericks)

Posted 15 September 2014 - 02:00 AM

Wine 1.7.22+ has sound issues with Terraria and many other games.

Wineskin 2.6.0 with WS9Wine 1.7.21 works fine with Terraria for me, however.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users