Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Skyrim Wineskin Not In Fullscreen


  • Please log in to reply
5 replies to this topic

#1 Tomaltach

Tomaltach

    Lurker

  • Members
  • 2 posts
  • Graphics Card:Intel HD Graphics 4000 1024 MB
  • Operating System:OS X 10.9 (Mavericks)

Posted 08 September 2014 - 05:47 PM

I recently switched my Skyrim Cider wrapper for the Porting Team's wineskin one so I could get into modding. While I have had great success in the modding realm of things, from the start I have had a full screen problem. Basically Skyrim refuses to appear in full screen, only ever a small window in the corner. I have played with both the SkyrimPrefs.ini file setting bFullScreen to 1 and the resolution to my screen size, and the wineskin screen option, neither of which worked. The game is very much playable and being able to run mods has been fun, but I am honestly considering switching back to the cider and just running mods without skse. Any help on this matter would be very appreciated.

#2 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 09 September 2014 - 02:53 PM

it only shows up like that if its running a resolution your screen cannot display.  Whatever settings your using for the game to try and adjust resolution doesn't appear to be working.... the game is running the wrong resolution.  Why? I don't know, but at least thats where you need to be looking.

#3 Tomaltach

Tomaltach

    Lurker

  • Members
  • 2 posts
  • Graphics Card:Intel HD Graphics 4000 1024 MB
  • Operating System:OS X 10.9 (Mavericks)

Posted 25 September 2014 - 11:20 PM

I have set the resolution in Skyrim.ini to match that of my laptop, and I have used the manual wineskin screen preferences to try forcing it to fill the screen. Still nothing has worked. I've honestly gotten used to playing it in a window, but I would still love to get it to be full screen,

#4 Jesrad

Jesrad

    Lurker

  • Members
  • 3 posts

Posted 22 July 2015 - 09:19 PM

I have the same problem and trying everything I could think of did not change a thing :(

#5 Jesrad

Jesrad

    Lurker

  • Members
  • 3 posts

Posted 22 July 2015 - 09:38 PM

OK, figured it out after more trials: the wineskin wrapper uses a totally different path to user folders and data. You have to move your .ini files and save files to the "My Games" data structure that it create in your Documents folder (your main Mac one, not the folder inside of the c_drive). In the absence of those files the wrapper recreates them from scratch, reverting all your fine-tuning, and it defaults at 640x480 resolution which is obsolete on recent Macs.

#6 calval

calval

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Intel HD Graphics 4000 1536 MB
  • Operating System:macOS 10.12 (Sierra)

Posted 01 May 2019 - 06:58 AM

Hi! I just noticed I'm 5 years late to this topic, but I found this because I was having the same problem. I tried the solutions other users offered in the replies but none of them worked for me, however, I finally found something that did. So I wanted to reply in case anyone else comes across this topic with the same problem!

I needed to go to Applications > Games > Skyrim, right-click Skyrim to 'Show Package Contents'

Then go into Contents > Resources > My Games > Skyrim, and from there open the SkyrimPrefs.ini file in TextEdit

In TextEdit, I used the 'Find' tool from the Edit menu up top to look for 'bFull', then change bFull Screen = 0 to bFull Screen =1

Now it works perfectly, and the screen goes straight into full screen at launch! Sorry I'm seeing this so late but wanted to share nonetheless :P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users