Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

CrossOver engine 15.3.1 (WS9WineCX15.3.1)


  • Please log in to reply
11 replies to this topic

#1 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 21 September 2016 - 06:29 AM


edit: 5 Oct 2016 [new little update]:



changelog...



#2 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 21 September 2016 - 01:46 PM

Does anyone have any idea which version of wine this coincidences with?  I wonder if it can be built 64bit now?

#3 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 21 September 2016 - 01:59 PM

View Postdarklord42, on 21 September 2016 - 01:46 PM, said:

Does anyone have any idea which version of wine this coincidences with?


1.8.4

#4 darklord42

darklord42

    Rookie Porter

  • Members
  • PipPipPipPip
  • 151 posts

Posted 22 September 2016 - 02:33 AM

Ah makes sense, thanks!

#5 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 185 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 04 October 2016 - 08:27 PM

View PostNRG, on 21 September 2016 - 06:29 AM, said:


Thanks for this especially as doh123 don't update Codeweavers engines regularly. Change log doesn't tell much but 15.3.0 works fantastic across the board.

#6 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 04 October 2016 - 10:30 PM

View PostIncredible Hulk, on 04 October 2016 - 08:27 PM, said:

but 15.3.0 works fantastic across the board.

I'm to upload the new 15.3.1 version

#7 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 04 October 2016 - 11:15 PM



changelog...

#8 LordCruaver

LordCruaver

    Lurker

  • Members
  • 2 posts
  • Graphics Card:AMD Radeon HD 6750M 512 MB
  • Operating System:Other OS/Not specified

Posted 30 October 2016 - 06:53 AM

I seem to be getting some odd Audio Crackling when using the 15.3.1 engine.
Engine Usage: Wrapper to operate steam, error noticed in Skyrim audio.

Edit:
Result was because of using Windows 10 base instead of Windows XP. Perhaps it could be part of your next work to make a windows 10 usable. Or perhaps not, depends if you got the time and desire.

#9 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 30 October 2016 - 08:05 AM

View PostLordCruaver, on 30 October 2016 - 06:53 AM, said:

I seem to be getting some odd Audio Crackling when using the 15.3.1 engine.
Engine Usage: Wrapper to operate steam, error noticed in Skyrim audio.

Edit:
Result was because of using Windows 10 base instead of Windows XP. Perhaps it could be part of your next work to make a windows 10 usable. Or perhaps not, depends if you got the time and desire.

Sorry but it's not depend by me; It depends by Codeweavers releases...

Regarding me, I only compiled  their wine's engine to make it available for wineskin

However actually there isn't any valid reason to use windows10 as default system in the wineskin's configuration pannel, expecially if a game is old  and if it was released  also for previous versions of Windows, it's always better use the same Windows version for a better compatibility...

#10 Josander

Josander

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts
  • Graphics Card:AMD Radeon HD 7970 3072 MB
  • Operating System:OS X 10.11 (El Capitan)
  • I like to play:Bethesda games

Posted 09 November 2016 - 02:09 PM

not sure if its a hot iron, or bothering question, and i echo the same ingenuous question like darklord42 :  I wonder if it can be built 64bit now?

#11 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 185 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 27 November 2016 - 02:14 PM

View PostJosander, on 09 November 2016 - 02:09 PM, said:

not sure if its a hot iron, or bothering question, and i echo the same ingenuous question like darklord42 :  I wonder if it can be built 64bit now?
Crossover 16 will be 64-bit

#12 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 185 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 27 November 2016 - 02:17 PM


Tip to update Crossover engines with latest wine libraries for best Wineskin expirience


- right click your wine app -> Show Package Contents

go to … Contest/ Frameworks


Find at the bottom “wswine.bundle” (that’s the actual wine engine)

right click it -> Show Package Contents


Inside You have bin, lib and share folder


- Go to lib folder and delete all files except wine folder (lib/wine)

- Go to share folder and delete all folders except wine folder (share/wine)


- Download latest Mac Wine tarball:

https://dl.winehq.or...x/download.html


- uncompress downloaded file and go to usr folder

(btw. - if you put version file inside and rename this folder to wswine.bundle you’ll get actual wineskin engine)


- Move all files except wine folders from usr/lib and usr/share from Your uncompressed Mac Wine tarball to appropriate folders in wineskin engine. (It can’t hurt if You copy lib64 folder also)


Run Your app





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users