Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Wineskin Engine Repository


  • Please log in to reply
104 replies to this topic

#1 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 22 December 2016 - 01:11 PM

I've been compiling engines for a while and decided to share them.

Link: https://mega.nz/#F!I...dEFtmpXpLoYAGpA

All of my engines, except for the 64bit engines, are macOS 10.6 and higher compatible.
My 64bit engines are macOS 10.8 and higher compatible until I figure out how to compile those for 10.6+. (I stopped trying because it is too much of a hassle and machines that are not able to run on 10.8 and higher won't be able to take advantage of 64bit stuff anyway)

What is available?

Vanilla Engines (just plain wine engines).
Vanilla 64bit Engines.
Staging Engines.
Staging 64bit Engines.
Stable Engines.
Various custom engines to fix certain games/problems.

#2 rampancy

rampancy

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • LocationDenial.
  • Graphics Card:Intel GMA 950 (MacBook), Nvidia GeForce 320M (MacBook Air)
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:FPS, RPGs, TBS, RTS, Adventure Games, Classic and Indie/Retro Games

Posted 24 December 2016 - 12:50 PM

View PostScoPezz, on 22 December 2016 - 01:11 PM, said:

I've been compiling engines for a while and decided to share them.

Link: https://mega.nz/#F!I...dEFtmpXpLoYAGpA

All of my engines, except for the 64bit engines, are macOS 10.6 and higher compatible.
My 64bit engines are macOS 10.8 and higher compatible until I figure out how to compile those for 10.6+.

What is available?

Vanilla Engines (just plain wine engines).
Vanilla 64bit Engines.
Staging Engines.
Staging 64bit Engines.
Various custom engines to fix certain games/problems.

Many thanks to you again, for your efforts. I deeply appreciate the fact that you've tried to compile your engines for 10.6.

#3 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 24 December 2016 - 01:57 PM

View Postrampancy, on 24 December 2016 - 12:50 PM, said:

Many thanks to you again, for your efforts. I deeply appreciate the fact that you've tried to compile your engines for 10.6.
You are very welcome, I will continue to do so. I have an old macbook4.1 myself, with 10.7 on it. (core 2 duo)
That's why I do it :D

#4 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 26 December 2016 - 10:39 PM

Added WS9Wine2.0-rc3

EDIT: 64bit rc2 and rc3 are still missing, and so are 32 and 64bit staging rc2 and rc3

#5 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 02 January 2017 - 11:08 PM

I added all the missing engines.

#6 rampancy

rampancy

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • LocationDenial.
  • Graphics Card:Intel GMA 950 (MacBook), Nvidia GeForce 320M (MacBook Air)
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:FPS, RPGs, TBS, RTS, Adventure Games, Classic and Indie/Retro Games

Posted 04 January 2017 - 04:43 PM

Are your staging engines also compatible with 10.6/32-bit? The wine-staging engines on Gurqn's thread all rely on libraries that are 10.7/64-bit only.

Thanks again for all of your hard work!

#7 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 04 January 2017 - 04:49 PM

View Postrampancy, on 04 January 2017 - 04:43 PM, said:

Are your staging engines also compatible with 10.6/32-bit? The wine-staging engines on Gurqn's thread all rely on libraries that are 10.7/64-bit only.

Thanks again for all of your hard work!
The staging engines that are in the folder 'Vanilla Staging' are 10.6 compatible :)
Only the 64bit engines are 10.8 and higher compatible.
Except for those, all my engines are 10.6 and higher compatible :)
You are very welcome btw!

#8 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 14 January 2017 - 11:46 PM

Staging, Staging64, vanilla 64 and vanilla 2.0-rc4 were added. Vanilla 2.0-rc5 also added.

#9 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 17 January 2017 - 09:57 PM

Staging, Staging64 and Vanilla 64 2.0-rc5 added.

#10 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 24 January 2017 - 01:41 AM

All 2.0-rc6 engines were added.

#11 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3011 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 28 January 2017 - 05:55 AM

Any luck getting the stable Wine 2.0 Staging x64 engine compiled? :)

#12 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 28 January 2017 - 10:07 AM

View PostdankoB, on 28 January 2017 - 05:55 AM, said:

Any luck getting the stable Wine 2.0 Staging x64 engine compiled? :)
I added all the stable 2.0 engines now :) Including 64bit! :D
EDIT: sorry for the delay btw :P

#13 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 12 February 2017 - 05:41 PM

All 2.1 engines have been addes, again sorry for the delay.

#14 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 18 February 2017 - 01:55 AM

WS9Wine2.2 has been added. I'll add Staging and 64bit engines when they are released.

#15 gbsaab

gbsaab

    Novice Member

  • Members
  • 8 posts
  • Graphics Card:ATI Radeon HD 4850 512 MB graphics
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 25 February 2017 - 05:42 AM

These engines are a great effort, many thanks.

I need a 64-bit engine to run software which is 64-bit only.  I downloaded a 64-bit engine but, I can't get it working.

I put a copy of the engine into ~/Library/Application Support/WineSkin/Engines/.  WineSkin Winery recognised the engine so, I opened my WineSkin prefix (containing the 64-bit software) and clicked on "Change Engine Used".  That succeeded and the engine version is now WS9Wine64bit2.2.

However, when I try to run the 64-bit software I get the standard error saying that I've tried to run 64-bit software in a 32-bit prefix.

I'm sure I've just not understood something but, I can't figure it out.

Can anyone help ?

#16 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 25 February 2017 - 08:17 AM

View Postgbsaab, on 25 February 2017 - 05:42 AM, said:

These engines are a great effort, many thanks.

I need a 64-bit engine to run software which is 64-bit only.  I downloaded a 64-bit engine but, I can't get it working.

I put a copy of the engine into ~/Library/Application Support/WineSkin/Engines/.  WineSkin Winery recognised the engine so, I opened my WineSkin prefix (containing the 64-bit software) and clicked on "Change Engine Used".  That succeeded and the engine version is now WS9Wine64bit2.2.

However, when I try to run the 64-bit software I get the standard error saying that I've tried to run 64-bit software in a 32-bit prefix.

I'm sure I've just not understood something but, I can't figure it out.

Can anyone help ?

you need to create a new Wineskin wrapper directly with the new 64 bit engine... you can't change between a wrapper that use a 32 bit engine and then change his engine with a 64bit one

#17 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 25 February 2017 - 09:43 AM

View PostNRG, on 25 February 2017 - 08:17 AM, said:

you need to create a new Wineskin wrapper directly with the new 64 bit engine... you can't change between a wrapper that use a 32 bit engine and then change his engine with a 64bit one
I can confirm this. I can't reproduce your problem either.

#18 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 25 February 2017 - 10:17 AM

In other news, all 2.2 engines have been added.

#19 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 184 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 25 February 2017 - 10:21 AM

View PostNRG, on 25 February 2017 - 08:17 AM, said:

you need to create a new Wineskin wrapper directly with the new 64 bit engine... you can't change between a wrapper that use a 32 bit engine and then change his engine with a 64bit one

@doh123 is working on this.
http://wineskin.urge...topics_offset=1

Maybe we can help with beta testing?

#20 Incredible Hulk

Incredible Hulk

    Professional Member

  • Members
  • PipPipPipPip
  • 184 posts
  • Graphics Card:6750M, OSX 10.12.2
  • Operating System:Other OS/Not specified
  • I like to play:PES, COD, Grid, FNV, RO

Posted 25 February 2017 - 10:29 AM

Also there is now a Wineskin Xcode project on Github

https://github.com/s...ineskin?files=1

Don't know who is the maintainer and if this is legit?


#21 --------

--------

    Professional Member

  • Members
  • PipPipPipPip
  • 162 posts
  • LocationIstanbul
  • Graphics Card:MSI Z97 MPOWER - GTX 980 - View Sonic VP2780-4K - 16GB Ram - macOS High Sierra
  • Operating System:Other OS/Not specified
  • I like to play:Most of games :-)
Author

Posted 25 February 2017 - 11:43 PM

View PostIncredible Hulk, on 25 February 2017 - 10:29 AM, said:

Also there is now a Wineskin Xcode project on Github

https://github.com/s...ineskin?files=1

Don't know who is the maintainer and if this is legit?

Your monitoring skills are impressive :D :D

#22 gbsaab

gbsaab

    Novice Member

  • Members
  • 8 posts
  • Graphics Card:ATI Radeon HD 4850 512 MB graphics
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 26 February 2017 - 03:18 AM

View PostNRG, on 25 February 2017 - 08:17 AM, said:

you need to create a new Wineskin wrapper directly with the new 64 bit engine... you can't change between a wrapper that use a 32 bit engine and then change his engine with a 64bit one

Many thanks for this.  I created a vanilla wrapper with the WS9Wine64bit2.2 engine.  To run my 64-bit software, I need .NET 4.5.  I first installed msxml3.dll using WineTricks (that has solved lots of problems in the past).  I then tried to install .NET 4.5 using WineTricks.  The install failed because .NET 2.0 can't be installed in a 64-bit prefix.  I'm stumped again.  How does anyone get .NET going in 64-bit prefixes ?  I've seen lots of reports on this but the only solution I can find is to create a 32-bit prefix which means I can't run 64-bit software !

I've asked for help here: http://portingteam.c...-64-bit-prefix/

Many thanks

Garry

#23 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 27 February 2017 - 02:51 AM

View PostIncredible Hulk, on 25 February 2017 - 10:29 AM, said:

Also there is now a Wineskin Xcode project on Github

https://github.com/s...ineskin?files=1

Don't know who is the maintainer and if this is legit?

its not "Legit" as in officially anything to do with Wineskin.  I assume someone has made a fork... maybe they want to work on it some.  Hopefully if they improve anything they'll submit the changes to me.

#24 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 10 March 2017 - 11:33 PM

All of the 2.3 engines have been added, sorry for the delay (again).

I hope someone has a use for these :)

#25 delta1262

delta1262

    Regular Member

  • Members
  • Pip
  • 17 posts
  • Graphics Card:Intel Iris (1536 MB)
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:Mount and Blade: Warband

Posted 11 March 2017 - 03:12 PM

View PostScoPezz, on 10 March 2017 - 11:33 PM, said:

All of the 2.3 engines have been added, sorry for the delay (again).

I hope someone has a use for these :)

Fastest engine I've used yet

#26 halfmetalalchemist

halfmetalalchemist

    Lurker

  • Members
  • 1 posts
  • LocationSeattle, WA USA
  • Graphics Card:NVIDIA GeForce 9400 256 MB
  • Operating System:OS X 10.11 (El Capitan)
  • I like to play:Skyrim... mostly.

Posted 19 March 2017 - 02:09 PM

As Delta suggested, I'm seeing a speed-bump with 2.3 (still not as fast as 1.9.8 Sherry, tho, I don't think)... but is anyone else experiencing more CTDs with 2.3? For example, I could play Skyrim for hours prior to this build. Now, I'm bombing out within 30 minutes every... single... time. Weird. Trying to track down why.

#27 delta1262

delta1262

    Regular Member

  • Members
  • Pip
  • 17 posts
  • Graphics Card:Intel Iris (1536 MB)
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:Mount and Blade: Warband

Posted 19 March 2017 - 05:12 PM

View Posthalfmetalalchemist, on 19 March 2017 - 02:09 PM, said:

As Delta suggested, I'm seeing a speed-bump with 2.3 (still not as fast as 1.9.8 Sherry, tho, I don't think)... but is anyone else experiencing more CTDs with 2.3? For example, I could play Skyrim for hours prior to this build. Now, I'm bombing out within 30 minutes every... single... time. Weird. Trying to track down why.

Can confirm, it just freezes New Vegas every 30 minutes or so.

#28 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 26 March 2017 - 10:04 PM

Added all the 2.4 engines.

#29 rampancy

rampancy

    Experienced Member

  • Members
  • PipPip
  • 47 posts
  • LocationDenial.
  • Graphics Card:Intel GMA 950 (MacBook), Nvidia GeForce 320M (MacBook Air)
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:FPS, RPGs, TBS, RTS, Adventure Games, Classic and Indie/Retro Games

Posted 04 April 2017 - 03:18 PM

Thank you again so much for your work!

Is there any chance you can make an updated version of your Wine 2.2 custom engine with the No Flicker patches for the latest version of Wine? I've found that that engine actually works really well for games like Army Man 2/Toys in Space, and the Delta Force games recently released on GOG.

#30 Brainzyy

Brainzyy

    Professional Member

  • Members
  • PipPipPipPip
  • 167 posts
  • LocationBelgium
  • Graphics Card:AMD Radeon R9 M370X (2GB) / Intel Iris Pro 5200
  • Operating System:macOS 10.12 (Sierra)

Posted 04 April 2017 - 04:35 PM

View Postrampancy, on 04 April 2017 - 03:18 PM, said:

Thank you again so much for your work!

Is there any chance you can make an updated version of your Wine 2.2 custom engine with the No Flicker patches for the latest version of Wine? I've found that that engine actually works really well for games like Army Man 2/Toys in Space, and the Delta Force games recently released on GOG.
Ah, yes, I seem to have forgotten about those. The problem is that I only have a terrible Macbook4.1 to compile on these days, so it takes a while :P
But I'll update all my custom engines (no flicker, noflicker +ddraw hack, orgin engines, etc).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users