Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Trouble with Wineskin Screen Options on macOS Sierra


  • Please log in to reply
4 replies to this topic

#1 pfftStupidScholar

pfftStupidScholar

    Lurker

  • Members
  • 2 posts
  • Graphics Card:NVIDIA GeForce GT650M
  • Operating System:OS X 10.9 (Mavericks)

Posted 04 January 2017 - 08:44 PM

Hi,

I'm attempting to run The Elder Scrolls V: Skyrim on macOS Sierra. I've successfully created a skin using Engine WS9Wine1.9.24 and Wrapper Version Wineskin-2.6.2. Everything works as it should in this regard, and the game is able to run.

My problem is regarding the Screen Options. I'm currently experiencing two problems, and solving either would be fine.

1) When using the Mac Driver instead of the X11 Driver, any combination of Screen Options settings I choose (automatic, override, rootless, fullscreen, virtual, decorated, etc.) results in a windowed version of the application running that is too large for the screen. I'll post a link to a screenshot below.

Screenshot

2) When using the X11 Driver instead of the Mac Driver, I can choose between rootless or fullscreen and see an apparent change (for example, the screen momentarily goes dark, save for the mouse cursor, for fullscreen), but the application consistently crashes after a few seconds of attempting to run. Yes, the latest XQuartz is installed.

Again, solving either of these problems would make the application operate "acceptably," but I will say that I'd prefer to run on the Mac Driver as Wine supposedly has full support for it now and the performance is noticeably better (faster, better Retina display support).

Thanks!

My Mac OS X Version:
macOS Sierra 10.12

My Mac Model, GPU & CPU:
MacBook Pro (Retina, 15-inch, Early 2013)
2.4 GHz Intel Core i7
Intel HD Graphics 4000 1536 MB
NVIDIA GeForce GT 650M 1024 MB

Error Log(s):
Logs after Mac Driver run: LastRunX11.log LastRunWine.log
Logs after X11 Driver run: LastRunX11.log LastRunWine.log

#2 pfftStupidScholar

pfftStupidScholar

    Lurker

  • Members
  • 2 posts
  • Graphics Card:NVIDIA GeForce GT650M
  • Operating System:OS X 10.9 (Mavericks)

Posted 04 January 2017 - 09:28 PM

Solved this problem myself after a bit more fiddling around. I couldn't find a setting to delete my post, so I'll just post my solution here for posterity's sake.

Remember that Skyrim has it's own internal settings regarding fullscreen, screen resolution, etc.

Find Documents/My Games/SkyrimPrefs.ini, set "bFull Screen" to 1, and set "iSize H" and "iSize W" to the height and width of your screen resolution respectively.

Then set your wineskin to automatic settings. Use the Mac driver. As for other settings, I personally set to decorate windows, auto detect GPU info, and use Direct3D Boost.

#3 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 05 January 2017 - 03:21 AM

Just as an addition... all of the automatic/override, fullscreen, rootless, etc.. all the options do not work at all when the Mac Driver is in use.  Auto Detect GPU info and Direct3D Boost options should be the only things that work.

#4 WhistlingFawn97

WhistlingFawn97

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Intel HD Graphics 5000 1536 MB
  • Operating System:macOS 10.12 (Sierra)

Posted 13 August 2017 - 02:16 PM

Hello guys. I've got a problem to install a game on my mac mini. Its version is Sierra 10.12.3 and I tried to install splinter cell blacklist. I've created the iso through the wrapper but when I try to install the game with Wineskin, this programs gives me an error saying:

"OOPS! no new executables found! Maybe the installer failed...? If you tried to install somewhere other than C: drive (drive_c in the wrapper) then you will get this message too. All software must be installed in C:drive"

The C:drive should be the hard disk but I have no devices on my mac except the hard disk of the mac itself.

Someone can helps me to figure the problem out?? thanks :)

#5 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3011 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 13 August 2017 - 03:13 PM

The C: drive is located inside of the wrapper. When you install the game it should automatically detect the C: drive and try to install the game into c_drive/Program Files. If not then click on the browse window and double click on My Computer in the drop down box and then install it into C://Program Files.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users