Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Unofficial Wineskin Project


  • Please log in to reply
234 replies to this topic

#91 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 03:16 AM

View PostGcenx, on 16 July 2018 - 03:03 AM, said:

Ugh, it worked on my end before I uploaded it.....

Let me just replace the one on MEGA with the current version

EDIT;
I replaced the version in MEGA with Winery 1.8 instead, so no "update", I will figure out the update issue later down the line if anything.

Thanks. Now I can provide some more useful feedback. So I've created a wrapper but it "hangs" and only shows a dialog box with the text clipped when trying to install a game from GOG. Here are some details:

Posted Image

Unofficial Wineskin Winery 1.8
Wrapper version 2.8.1
WS9Wine3.12 engine
macOS 10.13.6
Game: setup_fallout_2.1.0.18.exe (Fallout 1 Windows installer from GOG)

When copying the installer file to the bundle and then running setup_fallout_2.1.0.18.exe through "Test Run" the logs show:

LastRunWine.log
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
0009:fixme:process:SetProcessDEPPolicy (1): stub
0009:fixme:thread:GetThreadUILanguage : stub, returning default language.
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32d968, 0x0 0x32d990
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32d968 0x0 0x32d990) returning a dummy value (current locale)
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32d968, 0x57a680 0x32d990
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32d968 0x57a680 0x32d990) returning a dummy value (current locale)
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
0036:fixme:process:SetProcessDEPPolicy (1): stub
0036:fixme:win:DisableProcessWindowsGhosting : stub
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub
0036:fixme:graphics:ShutdownBlockReasonCreate (0x10084, L"Installing"): stub
0036:fixme:rstrtmgr:RmStartSession 0x50d024, 0, 0x50d028 stub!
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub
0036:fixme:graphics:ShutdownBlockReasonCreate (0x10084, L"Installing Fallout."): stub
0036:fixme:msg:ChangeWindowMessageFilterEx 0x10096 c058 1 0x0
0036:fixme:msg:ChangeWindowMessageFilterEx 0x20096 c058 1 0x0
0036:fixme:msg:ChangeWindowMessageFilterEx 0x1009e c058 1 0x0
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub

Note: This runs fine with doh's current 2.6.2 wrapper. Anything I try to run or install with yours results in this error.

#92 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 03:25 AM

View Postbrymaster, on 16 July 2018 - 03:16 AM, said:

Thanks. Now I can provide some more useful feedback. So I've created a wrapper but it "hangs" and only shows a dialog box with the text clipped when trying to install a game from GOG. Here are some details:

Posted Image

Unofficial Wineskin Winery 1.8
Wrapper version 2.8.1
WS9Wine3.12 engine
macOS 10.13.6
Game: setup_fallout_2.1.0.18.exe (Fallout 1 Windows installer from GOG)

When copying the installer file to the bundle and then running setup_fallout_2.1.0.18.exe through "Test Run" the logs show:

LastRunWine.log
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
0009:fixme:process:SetProcessDEPPolicy (1): stub
0009:fixme:thread:GetThreadUILanguage : stub, returning default language.
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32d968, 0x0 0x32d990
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32d968 0x0 0x32d990) returning a dummy value (current locale)
0009:fixme:nls:GetThreadPreferredUILanguages 00000038, 0x32d968, 0x57a680 0x32d990
0009:fixme:nls:get_dummy_preferred_ui_language (0x38 0x32d968 0x57a680 0x32d990) returning a dummy value (current locale)
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 2
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
000d:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng15.15.dylib
000d:err:menubuilder:convert_to_native_icon error 0x80004005 getting frame 0
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
0036:fixme:process:SetProcessDEPPolicy (1): stub
0036:fixme:win:DisableProcessWindowsGhosting : stub
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub
0036:fixme:graphics:ShutdownBlockReasonCreate (0x10084, L"Installing"): stub
0036:fixme:rstrtmgr:RmStartSession 0x50d024, 0, 0x50d028 stub!
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub
0036:fixme:graphics:ShutdownBlockReasonCreate (0x10084, L"Installing Fallout."): stub
0036:fixme:msg:ChangeWindowMessageFilterEx 0x10096 c058 1 0x0
0036:fixme:msg:ChangeWindowMessageFilterEx 0x20096 c058 1 0x0
0036:fixme:msg:ChangeWindowMessageFilterEx 0x1009e c058 1 0x0
0036:fixme:graphics:ShutdownBlockReasonDestroy (0x10084): stub

Note: This runs fine with doh's current 2.6.2 wrapper. Anything I try to run or install with yours results in this error.

That's really weird let me look into that, since those files are within the wrapper......
Do you by chance use Homebrew/Macports?
Or do you have XQuartz installed?

#93 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 03:32 AM

View PostGcenx, on 16 July 2018 - 03:25 AM, said:

That's really weird let me look into that, since those files are within the wrapper......
Do you by chance use Homebrew/Macports?
Or do you have XQuartz installed?

I use Homebrew. So I noticed that I have icoutils installed which also installs libpng (/usr/local/Cellar/libpng/1.6.34) and freetype as a dependency (in /usr/local/Cellar/freetype/2.9.1) which dylibs then get symlinked to /usr/local/lib.

#94 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 03:39 AM

View Postbrymaster, on 16 July 2018 - 03:32 AM, said:

I use Homebrew. So I noticed that I have icoutils installed which also installs libpng (/usr/local/Cellar/libpng/1.6.34) and freetype as a dependency (in /usr/local/Cellar/freetype/2.9.1) which dylibs then get symlinked to /usr/local/lib.

That might be the issue right there, the dylibs installed by homebrew are just 64bit not mixed 32/64bit versions.

#95 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 04:00 AM

View PostGcenx, on 16 July 2018 - 03:39 AM, said:

That might be the issue right there, the dylibs installed by homebrew are just 64bit not mixed 32/64bit versions.

Hrm...I don't understand how. If your dylibs are packaged properly and linked to the binary in your bundle, there should be no conflicts. Otherwise it would seem something is wrong because that is not how packaging libraries is supposed to work.

#96 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 04:10 AM

View Postbrymaster, on 16 July 2018 - 04:00 AM, said:

Hrm...I don't understand how. If your dylibs are packaged properly and linked to the binary in your bundle, there should be no conflicts. Otherwise it would seem something is wrong because that is not how packaging libraries is supposed to work.

You need to remember Wine likes to use system installed dylibs and if those are a higher version then it will use those instead

#97 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 04:10 AM

<snip>

#98 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 04:12 AM

View PostGcenx, on 16 July 2018 - 04:10 AM, said:

You need to remember Wine likes to use system installed dylibs and if those are a higher version then it will use those instead

Nope...I've uninstalled icoutils/libpng/freetype and this is still happening, so that was not the problem. What are you using to package the dylibs? In the past I've used macpack because macdylibbundler was buggy and unmaintained.

#99 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 04:16 AM

View Postbrymaster, on 16 July 2018 - 04:12 AM, said:

Nope...I've uninstalled icoutils/libpng/freetype and this is still happening, so that was not the problem. What are you using to package the dylibs? In the past I've used macpack because macdylibbundler was buggy and unmaintained.

I did not patch them since I took them from a pack that Slice uploaded a while back, on my end I have no issues with or without XQuartz.
But I will rebuild them when I have time and use macpakc as you suggested.

#100 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 04:25 AM

View PostGcenx, on 16 July 2018 - 04:16 AM, said:

I did not patch them since I took them from a pack that Slice uploaded a while back, on my end I have no issues with or without XQuartz.
But I will rebuild them when I have time and use macpakc as you suggested.

Okay, heh. I figured it was something like that. I think I noticed this stopping working after the recent macOS 10.13.6 update and for the record I could never get any 64-bit engines to work with this unofficial wrapper either. Best not to rely on dylibs from a third party then. They need to be properly linked against the binary with otool. Macpack is good for that.

Thanks for your efforts!

Unrelated, but I also noticed your Engines have some includes removed, comparing one I compressed myself on the left vs yours on the right:

Posted Image

#101 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 06:16 AM

Alright, so it does appear to be an issue with the dylibs you are bundling with the wrapper (using Macpack should be irrelevant at this point I think). To partly fix it I copied libfreetype.6.dylib from the old 2.6.2 wrapper and overwrote the one in Frameworks in wrapper 2.8.1. Now the installer displays the window but there is no progress bar or additional game images displayed during installation (probably because of the libpng dylib problem):

Posted Image

I don't know which version of freetype you are using in the new wrapper but it appears that Wine definitely does not like it, as it cannot even tell its installed. I'll play around with it further and copy libpng15.15.dylib over and see how that goes.

Edit: No, cannot get libpng15.15 to work. Wine still complains that it cannot see it in the logs.

#102 ovvldc

ovvldc

    Master Member

  • Members
  • 1256 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 16 July 2018 - 07:16 AM

View PostGcenx, on 15 July 2018 - 03:25 AM, said:

Once Wine 3.13 is out if it does include MoltenVK support I will update the Master Wrapper to include what is needed to make that work.

Thanks!

#103 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 11:20 AM

View Postbrymaster, on 16 July 2018 - 06:16 AM, said:

Alright, so it does appear to be an issue with the dylibs you are bundling with the wrapper (using Macpack should be irrelevant at this point I think). To partly fix it I copied libfreetype.6.dylib from the old 2.6.2 wrapper and overwrote the one in Frameworks in wrapper 2.8.1. Now the installer displays the window but there is no progress bar or additional game images displayed during installation (probably because of the libpng dylib problem):

Posted Image

I don't know which version of freetype you are using in the new wrapper but it appears that Wine definitely does not like it, as it cannot even tell its installed. I'll play around with it further and copy libpng15.15.dylib over and see how that goes.

Edit: No, cannot get libpng15.15 to work. Wine still complains that it cannot see it in the logs.

I think I know what happened with the dylib's.
Yeah libpng15.15 is annoying to get working it wants a very specific version and the one included with Wineskin-2.6.2 was slightly older. I believe one it likes was included with the latest version of XQuartz 2.7.11 try patching the libpng15.15 form that.

I might not get chance to properly look into fixing this until after Wednesday, but if I do get time I will upload a slightly changed WineskinLuncher version that should mitigate the issue as I forgot this version does not read dylibs from XQuartz (/opt/X11 /usr/X11)


Also the Wineskin-2.6.6 does read from all locations like stock Wineskin for dylibs, might want to try that one and see if it works.


EDIT;
I can use this on my external Mojave install also without issue, I download the winery.app and let it download the engines and master wrapper no problem, only thing I can think of is that I do have SIP disabled on my MacBook Pro. And also I know someone else who got it working also had SIP disabled.

My only guess is having that disabled meant macOS did not enforce the expected dylib path?

#104 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 06:17 PM

View PostGcenx, on 16 July 2018 - 11:20 AM, said:

I can use this on my external Mojave install also without issue, I download the winery.app and let it download the engines and master wrapper no problem

Sorry, but that cannot be true, because I just downloaded the Unofficial Winery from Mega on another machine that has never had Winery installed before and it does not download the wrapper. There's another bug and here's what seems to be going on and how to replicate:

1) If exists, delete or rename the folder ~/Library/Application Support/Wineskin

2) Download Unofficial Wineskin Winery from Mega and run it.

3) Click "Update" as it says "No Wrapper Installed" and allow 2.8.1 to download

4) After it downloads, it's not actually downloaded at all. The UI hasn't update and the wrapper doesn't exist anywhere in ~/Library/Application Support/Wineskin

5) Go to ~/Library/Application Support/Wineskin and create the folder "Wrapper"

6) Go back to Unofficial Wineskin Winery and try to download 2.8.1 wrapper yet again.

7) This time notice that it has actually been downloaded to ~/Library/Application Support/Wineskin/Wrapper

8) Go back to Unofficial Wineskin Winery and notice that 2.8.1 is *still* not recoginized as installed.

9) Go to ~/Library/Application Support/Wineskin and copy 2.8.1 from the Wrapper folder to the "Unofficial_Wrapper" folder

10) Now relaunch Unofficial Wineskin Winery and finally see that wrapper 2.8.1 is finally recognized as installed.

Edit: Furthermore, it will not download any of the Engines until the 2.8.1 wrapper is properly installed and recognized.

#105 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 06:34 PM

View Postbrymaster, on 16 July 2018 - 06:17 PM, said:



Sorry, but that cannot be true, because I just downloaded the Unofficial Winery from Mega on another machine that has never had Winery installed before and it does not download the wrapper. There's another bug and here's what seems to be going on and how to replicate:

Sounds like I did not upload the fixed version to the mega link posted in the thread. Yeah I used a different Link thinking I had them both synced.....
I will need to correct that once I get home tonight.

Thank you for saying that or I would have not realized it was still a broken version posted to this thread.

Edited by Gcenx, 16 July 2018 - 06:42 PM.


#106 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 07:56 PM

<snip>

#107 brymaster

brymaster

    Regular Member

  • Members
  • Pip
  • 15 posts

Posted 16 July 2018 - 08:54 PM

So some further testing, I have a test environment with 3 Macs:

1) MacBook Air
macOS 10.13.6, No XQuartz, No Homebrew packages, Gatekeeper set to defaults

2) MacBook Pro 15''
macOS 10.13.6, No XQuartz, No Homebrew packages, Gatekeeper set to defaults

3) MacBook Pro 13''
OS X 10.11.6, No XQuartz, Yes Homebrew packages, Gatekeeper = off (sudo spctl --master-disable)

Not any 3 of these machines can run a Wine Engine built using your 2.8.1 Wrapper. They all result in missing dylib errors for both freetype and libpng. A closer inspection of the dylibs reveals:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libfreetype.6.dylib
/Users/clobber/Library/Application Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libfreetype.6.dylib:
/opt/local/lib/libfreetype.6.dylib (compatibility version 18.0.0, current version 18.4.0)
/opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.8)
/opt/local/lib/libbz2.1.0.dylib (compatibility version 1.0.0, current version 1.0.6)
/opt/local/lib/libpng16.16.dylib (compatibility version 33.0.0, current version 33.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)

As you can see, the freetype dylib in your wrapper is referencing /opt/local/lib/libfreetype.6.dylib and other shared libraries, which of course, do not exist.

Same deal with libpng:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libpng15.15.dylib
/Users/clobber/Library/Application Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libpng15.15.dylib:
/opt/X11/lib/libpng15.15.dylib (compatibility version 34.0.0, current version 34.0.0)
/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)

This time even worse, referencing /opt/X11/lib (which seems to assume XQuartz is installed). I can manually create that path and then copy libpng15.15.dylib from the Frameworks folder to there and then of course it will work, but that is not the right solution here.

No stock Mac install is going to have these libraries in /opt. They need to be properly bundled inside the Frameworks folder so that the dylibs are redistributable and not referencing non-existent dylibs and paths on the user's machine. For example, if we check doh123's dylibs in the old 2.6.2 wrapper we see:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Wrapper/Wineskin-2.6.2.app/Contents/Frameworks/libfreetype.6.dylib
/Users/clobber/Library/Application Support/Wineskin/Wrapper/Wineskin-2.6.2.app/Contents/Frameworks/libfreetype.6.dylib:
@executable_path/../Frameworks/libfreetype.6.dylib (compatibility version 16.0.0, current version 16.0.0)
@executable_path/../Frameworks/libz.1.dylib (compatibility version 1.0.0, current version 1.2.7)
@executable_path/../Frameworks/libbz2.1.0.dylib (compatibility version 1.0.0, current version 1.0.6)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

doh123's freetype dylib in Frameworks correctly self references with a relative path:
@executable_path/../Frameworks/

So as it stands now, there is no way anyone else with a stock install of macOS can create a working Wineskin bundle using your wrapper. You or somebody else might have got it working if they had XQuartz installed or stuffed some other dylibs in /opt (which you don't need because of the macdriver). In order to properly test this, you are going to want a stock install of the latest stable macOS 10.13.6 (not Mojave with XQuartz/X11 or other dylib stuff installed in /opt).

dylib's must be relative paths, created using install_name_tool (https://stackoverflo...e-path-to-dylib). It is not possible to use dylib's from Slice or elsewhere as they reference local shared libraries. Furthermore, you have to check how pre-compiled Wine from WineHQ was built and make sure all shared libraries it linked against are actually included. I'm guessing libjpeg, among others, is also needed. Hope this all helps.

#108 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 16 July 2018 - 09:17 PM

View Postbrymaster, on 16 July 2018 - 08:54 PM, said:

So some further testing, I have a test environment with 3 Macs:

1) MacBook Air
    macOS 10.13.6, No XQuartz, No Homebrew packages, Gatekeeper set to defaults

2) MacBook Pro 15''
    macOS 10.13.6, No XQuartz, No Homebrew packages, Gatekeeper set to defaults

3) MacBook Pro 13''
    OS X 10.11.6, No XQuartz, Yes Homebrew packages, Gatekeeper = off (sudo spctl --master-disable)

Not any 3 of these machines can run a Wine Engine built using your 2.8.1 Wrapper. They all result in missing dylib errors for both freetype and libpng. A closer inspection of the dylibs reveals:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libfreetype.6.dylib
/Users/clobber/Library/Application Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libfreetype.6.dylib:
/opt/local/lib/libfreetype.6.dylib (compatibility version 18.0.0, current version 18.4.0)
/opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.8)
/opt/local/lib/libbz2.1.0.dylib (compatibility version 1.0.0, current version 1.0.6)
/opt/local/lib/libpng16.16.dylib (compatibility version 33.0.0, current version 33.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)

As you can see, the freetype dylib in your wrapper is referencing /opt/local/lib/libfreetype.6.dylib and other shared libraries, which of course, do not exist.

Same deal with libpng:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libpng15.15.dylib
/Users/clobber/Library/Application Support/Wineskin/Unofficial_Wrapper/Wineskin-2.8.1.app/Contents/Frameworks/libpng15.15.dylib:
/opt/X11/lib/libpng15.15.dylib (compatibility version 34.0.0, current version 34.0.0)
/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)

This time even worse, referencing /opt/X11/lib (which seems to assume XQuartz is installed). I can manually create that path and then copy libpng15.15.dylib from the Frameworks folder to there and then of course it will work, but that is not the right solution here.

No stock Mac install is going to have these libraries in /opt. They need to be properly bundled inside the Frameworks folder so that the dylibs are redistributable and not referencing non-existent dylibs and paths on the user's machine. For example, if we check doh123's dylibs in the old 2.6.2 wrapper we see:

$ otool -L /Users/clobber/Library/Application\ Support/Wineskin/Wrapper/Wineskin-2.6.2.app/Contents/Frameworks/libfreetype.6.dylib
/Users/clobber/Library/Application Support/Wineskin/Wrapper/Wineskin-2.6.2.app/Contents/Frameworks/libfreetype.6.dylib:
@executable_path/../Frameworks/libfreetype.6.dylib (compatibility version 16.0.0, current version 16.0.0)
@executable_path/../Frameworks/libz.1.dylib (compatibility version 1.0.0, current version 1.2.7)
@executable_path/../Frameworks/libbz2.1.0.dylib (compatibility version 1.0.0, current version 1.0.6)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)

We see that doh123's dylibs in Frameworks self reference themselves as they should: @executable_path/../Frameworks/

So as it stands now, there is no way anyone else with a stock install of macOS can create a working Wineskin bundle using your wrapper. You or somebody else might have got it working if they had XQuartz installed or stuffed some other dylibs in /opt (which you don't need because of the macdriver). In order to properly test this, you are going to want a stock install of the latest stable macOS 10.13.6 (not Mojave with XQuartz/X11 or other dylib stuff installed in /opt). Furthermore, you have to check how pre-compiled Wine from WineHQ was built and make sure all shared libraries it linked against are actually included. I'm guessing libjpeg, among others, is also needed. Hope this all helps.

More then helpful, thank you for all the information.

I will just wipe out my system after backing it up and enable SIP again and go from there with a clean installation.


EDIT;
After getting home and enabling SIP my previously working wrappers stopped working, read a little on what SIP does (Apple here so not much information on how it works) it seems SIP strips env veriables if an application is launched from another application...

So I rolled back a change I made and then it worked again, brymasyer also tested the new build and it finally worked on there end also even without fixing the dylibs. This was very strange persistent problem that I never encounter due to keeping off SIP along with some testers (only noticed after reading the logs over again) and one who is running a version that does not include SIP so also did not encounter the problem.

Edited by Gcenx, 18 July 2018 - 01:12 PM.


#109 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 18 July 2018 - 02:12 AM

Ok for anyone reading and having issues with this version I will be uploading a fix once I get time thanks to @brymaster, it seems some of the changes I recently made only worked for users with SIP Disabled (I needed an old Xbox Controller Driver version and I'm running High Sierra....)

I will update the link and first post when I have the corrected version built and uploaded since I have to fix my offline branch I can't just merge my fix from upstream without breaking something else.

#110 ovvldc

ovvldc

    Master Member

  • Members
  • 1256 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 18 July 2018 - 08:16 PM

I am very uncomfortable with having to disable SIP for Wine to work. So please do whatever is needed to not require that...

#111 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 18 July 2018 - 08:35 PM

View Postovvldc, on 18 July 2018 - 08:16 PM, said:

I am very uncomfortable with having to disable SIP for Wine to work. So please do whatever is needed to not require that...

Don’t worry I already have it fixed upstream, I just need time to apply my unofficial changes and then replace the download links. But I really won’t have time until  the weekend.

Also for anyone else reading, so you guys want to keep this on its own folder or just replace the stock Wineskin wrapper?
The next build will be based directly on upstream just the links will be changed.


EDIT;
Replaced with a working version, the updated Winery.app will not update correctly.
Wineskin-2.8.2 is instead using the same wrapper folder as official Winery.app
If you have XQuartz installed you can now use it.

If anyone gets any dylib messages about missing dylibs please post back so I can add them to my list

Edited by Gcenx, 19 July 2018 - 01:47 AM.


#112 Edi316

Edi316

    Lurker

  • Members
  • 2 posts
  • Graphics Card:Radeon Pro 580 8 GB
  • Operating System:macOS 10.12 (Sierra)

Posted 20 August 2018 - 10:55 AM

Wrapper Version: 2.8.5
Engine: WS9Wine 3.13
OS: macOS 10.13.6

When installing Net 4.0 (dotnet40) with Winetricks I get: "Error while reading file: The file "Winetricks.log" couldn't be opened using text encoding Unicode (UTF-8)"

Although this error appears, Net 4.0 installs correct.

Posted Image

#113 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 20 August 2018 - 07:19 PM

View PostEdi316, on 20 August 2018 - 10:55 AM, said:

Wrapper Version: 2.8.5
Engine: WS9Wine 3.13
OS: macOS 10.13.6

When installing Net 4.0 (dotnet40) with Winetricks I get: "Error while reading file: The file "Winetricks.log" couldn't be opened using text encoding Unicode (UTF-8)"

Although this error appears, Net 4.0 installs correct.

Posted Image

Hum that’s rather strange, does this not happen when using winetricks to install dotnet40 or does t also happen for other winetricks?

#114 Edi316

Edi316

    Lurker

  • Members
  • 2 posts
  • Graphics Card:Radeon Pro 580 8 GB
  • Operating System:macOS 10.12 (Sierra)

Posted 20 August 2018 - 08:15 PM

View PostGcenx, on 20 August 2018 - 07:19 PM, said:

Hum that’s rather strange, does this not happen when using winetricks to install dotnet40 or does t also happen for other winetricks?

I tried a few other Winetricks. It seems that the error message only appears when installing a dotnet version (tried 30, 40, und 45). The installation of dotnet works correct, so the error is just "cosmetic". Other Winetricks don't give me the error message.

#115 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 20 August 2018 - 08:24 PM

View PostEdi316, on 20 August 2018 - 08:15 PM, said:



I tried a few other Winetricks. It seems that the error message only appears when installing a dotnet version (tried 30, 40, und 45). The installation of dotnet works correct, so the error is just "cosmetic". Other Winetricks don't give me the error message.

Hum might be a winetricks issue then?, when I get chance I will see if I get the same problem. I normally install winetricks with logs disabled and silent mode. But I did install VulkanSDK a few times last night without that issue

#116 1Mac

1Mac

    Advanced Member

  • Members
  • PipPipPip
  • 53 posts
  • Graphics Card:Radeon Pro 555 2048 MB
  • Operating System:macOS 10.12 (Sierra)

Posted 28 September 2018 - 11:20 PM

A little bug in the current version of Winery: When you first open it you are greeted with a dialog saying that an update for Wineskin is available, would you like to download it? Say okay, and it says what to download: it just says "Wineskin Winery App" or something like that, not the actual newest version. Click okay again and it spins its wheels for a bit before returning to the first dialog.

If you break the cycle and click cancel, it gives you a warning then sends you to the main Winery window. If you then click "check for updates," it sends you to the first dialog, only this time everything works properly, the version you are downloading is actually displayed, and the update works just fine. So the workaround is easy but not obvious. I thought you'd like to know.

#117 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 29 September 2018 - 12:04 AM

View Post1Mac, on 28 September 2018 - 11:20 PM, said:

A little bug in the current version of Winery: When you first open it you are greeted with a dialog saying that an update for Wineskin is available, would you like to download it? Say okay, and it says what to download: it just says "Wineskin Winery App" or something like that, not the actual newest version. Click okay again and it spins its wheels for a bit before returning to the first dialog.

If you break the cycle and click cancel, it gives you a warning then sends you to the main Winery window. If you then click "check for updates," it sends you to the first dialog, only this time everything works properly, the version you are downloading is actually displayed, and the update works just fine. So the workaround is easy but not obvious. I thought you'd like to know.

Hum you right I never noticed since I just swap my local copy over each time let me see about fixing that but in the mean time if it still keeps asking you can download the current version directly Winery.app just don't unpack with Keka as I think it might still have the signature bug.

I used the original update code from doh123 I never changed it, later it might get changed to use Sparkle for updating but that might not be for a good while.

Edit;
Ok I tried again but I moved the download outside of "~/Downloads" and now it updated just fine, but inside "~/Downloads" I have the same issue you described.

#118 1Mac

1Mac

    Advanced Member

  • Members
  • PipPipPip
  • 53 posts
  • Graphics Card:Radeon Pro 555 2048 MB
  • Operating System:macOS 10.12 (Sierra)

Posted 29 September 2018 - 12:39 AM

I was indeed trying to open it in my Downloads folder, fwiw.

#119 Zakk

Zakk

    Regular Member

  • Members
  • Pip
  • 13 posts
  • Graphics Card:Nvidia 650M
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 30 September 2018 - 02:34 AM

Btw, the issue in ~/Downloads is likely due to macOS security features. If you download an application and then run it without copying it, the app is 'translocated' into a read-only jail. You normally wouldn't notice this, but some writes will fail, especially if it tries to modify itself/anything in the app bundle.

Basically after you download something, use finder to move it to another directory and it should be ok. Alternately you can clear the com.apple.quarantine extended attribute on the app bundle. Translocation only happens on quarantined applications. Note the ~/Downloads directory is not 'special'. You can just move the app somewhere and then move it back to ~/Downloads and it will be fine. The important thing is that you move it at least once.

The recommended way to distribute apps to users is to provide the app in a DMG and have them copy it out of the DMG to wherever they want.

#120 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 378 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 06 October 2018 - 06:03 PM

I pushed yet another update aimed at Mojave related issue.
I no longer have CPU spikes from tccd anymore from any part of WineskinLauncher/Wineskin/Winery.

The only "high" CPU load now is engine compression but thats a small price for direct downloads from Winehq


Some under the hood improvements and newer ObjectC_Extensions from VitorMM are included.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users