Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

CrossOver Engine 18.1.0 (WS9WineCX18.1.0) - Wineskin-2.6.2 Version


  • Please log in to reply
8 replies to this topic

#1 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 15 December 2018 - 05:44 PM

18.1.0 CrossOver - December 22nd, 2018
  • macOS:
    • Fixed a bug that prevented Quicken from launching for some users.
    • Fixed a bug that caused the latest Quicken 2016 Mondo Patch to fail during installation.
    • Fixed a bug that prevented game downloads and the Steam Store page from working on the latest Steam release.
    • Restored controller support for Steam.

Download


Requires a minimum of macOS 10.9 (10.8 won't have working Gnutls)
This was built to be used with Wineskin-2.6.2 (I bundled libpng16.16/libjpg9/libgnutls/libgsm inside the engine)
To ensure Steam does not have issues you need to set "gameoverlayrenderer" to disabled in winecfg.
Controller support is included like with Winehq builds.
Use with macdriver, I'm not sure if WineskinX11 will work as it's not functional on macOS Mojave.


Please Note;
If your an Unofficial Wineskin user download the version available from "Unofficial Wineskin Winery" that was built to take advantage of the additional dylibs that are part of Unofficial and some games will work out of box were the above version will need some winetricks to be used as with other "Official Wineskin Engines"
Also if you encounter an SSL error it’s due to the version provided by your version of OSX/macOS




Why do I need 10.9?
The reason is 10.8 only support TLS1.0 where as 10.9 support TLS1.1/1.2 and we need these newer versions to support https sites other secure connection type aka Steam Store/Downloading/Friends List etc

#2 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 20 December 2018 - 05:07 PM

If someone has an issue with this let me know, it seems my copy of XCode Command Line Tools 9.4.1 was upgraded to XCode Command Line Tools 10
That would cause wine to not function on some systems due to how Apple Clang handle linking

#3 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 21 December 2018 - 11:43 AM

the only error I had with all your compiled engines (both: WS10 and this WS9) is a program error with rundll32.exe each time I switch a wrapper from another engine to one of yours compiled engines...

more details of the error here:

https://pastebin.com/U5xJmLck

#4 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 21 December 2018 - 08:34 PM

View PostNRG, on 21 December 2018 - 11:43 AM, said:

the only error I had with all your compiled engines (both: WS10 and this WS9) is a program error with rundll32.exe each time I switch a wrapper from another engine to one of yours compiled engines...

more details of the error here:

https://pastebin.com/U5xJmLck

Do you also get the error if you built the wrapper using this engine directly or only when you swap to it from another?


Edit;
What version of macOS are you running again?
I want to setup a VM so I can recreate the issues your having, I already have one for OS X 10.8 to full bug test this thing

#5 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 22 December 2018 - 12:47 AM

View PostGcenx, on 21 December 2018 - 08:34 PM, said:

Do you also get the error if you built the wrapper using this engine directly or only when you swap to it from another?


What version of macOS are you running again?
I want to setup a VM so I can recreate the issues your having, I already have one for OS X 10.8 to full bug test this thing

I get the error only when I swap the engines

my os x is yosemite 10.10.5

#6 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 22 December 2018 - 01:09 AM

View PostNRG, on 22 December 2018 - 12:47 AM, said:

I get the error only when I swap the engines

my os x is yosemite 10.10.5

Ok thanks.
I think if you made a clean wrapper using WS9WineCX18.1.0 it also does not even make the prefix fully?

I'm asking as I'm currently bug fixing "Unofficial Wineskin"
I disabled a function to get WineskinLauncher working again on the 10.8 VM, I tried running but WS9WineCX18.1.0 didn't make the prefix correctly, yet an official winehq build did function correctly, maybe that's the reason your always getting the issue with my builds? (Ugh Apple Clang)

So if I'm able to build a working Prefix on this 10.8 VM it should also function normally for you.

#7 NRG

NRG

    Champion Member

  • Members
  • 679 posts
  • Graphics Card:Nvidia 9800m GTS
  • Operating System:OS X 10.10 (Yosemite)

Posted 22 December 2018 - 08:07 AM

View PostGcenx, on 22 December 2018 - 01:09 AM, said:

Ok thanks.
I think if you made a clean wrapper using WS9WineCX18.1.0 it also does not even make the prefix fully?


It's seems that

Infact also winecfg utility doesn't works


0009:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0010:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0010:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0010:err:ole:get_local_server_stream Failed: 80004002
0009:err:module:LdrInitializeThunk "winspool.drv" failed to initialize, aborting
0009:err:module:LdrInitializeThunk Initializing dlls for L"C:\\windows\\system32\\winecfg.exe" failed, status c0000005

#8 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 22 December 2018 - 12:19 PM

View PostNRG, on 22 December 2018 - 08:07 AM, said:

It's seems that

Infact also winecfg utility doesn't works


0009:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0010:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0010:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0010:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0010:err:ole:get_local_server_stream Failed: 80004002
0009:err:module:LdrInitializeThunk "winspool.drv" failed to initialize, aborting
0009:err:module:LdrInitializeThunk Initializing dlls for L"C:\\windows\\system32\\winecfg.exe" failed, status c0000005

Strange I have it working when I tested it on OSX 10.8 when I used Official and the fixed unofficial?!.... weird.

But the prefix did not get fully created on OS X 10.8 yet it works just fine on Mojave.....


Let me see what I can figure out over the weekend.

Well the good news is I have “Unofficial Wineskin Winery” and Wineskin-2.8.8Beta6 working normally with the OS X 10.8 VM I have setup. Including engine repacking from winehq.


EDIT;
I do have made progress I managed to build wine and have it build a working wrapper in 10.8, so I'm building WineCX18.1.0 over and if it also builds correctly then I will rebuild WS9WineCX18.1.0 and replace the current download for a useful version

EDIT;
Well I rebuilt WS10WineCX18.1.0 and it built a working wrapper for me on 10.8, now to rebuild WS9WineCX18.1.0 and test using "Wineskin-2.6.2"
And done I replaced WS9WineCX18.1.0 with one that worked on 10.8, however I couldn't load Steam Store page. Seems 10.8 is using an older version of SSL and Steam needs needs a newer version.

Edited by Gcenx, 22 December 2018 - 05:44 PM.


#9 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 373 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 22 December 2018 - 11:38 PM

This was rebuilt and tested, it does run on OSX10.8.


However OSX10.8 is unable to use Gnutls as it now require TLS1.1/1.2 these were added to OSX10.9 this is due to https and other secure connection protocols (https) are now using TLS1.2.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users