Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Ion Fury - black screen at launch and mouse problem


  • Please log in to reply
5 replies to this topic

#1 vanhouten

vanhouten

    Experienced Member

  • Members
  • PipPip
  • 22 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:Other OS/Not specified

Posted 01 September 2019 - 01:25 PM

Welcome back, forum ;)

After the video selection window, the game starts with a black screen (and sound working). But I can blindly start a new game and when the first level start, I have the image back and everything works fine. I can go back to the start menu (and see it…), and I finished the game. So I guess there is some kind of initialization issue.

In software mode I don't have this problem (but the game is better with opengl).

Another thing : I must launch the game using the "Test Run" button, otherwise the mouse goes crazy (turning violently).

My config : macOS 10.14.6 , wineskin 2.9.0.4 and wine64 4.13

#2 vanhouten

vanhouten

    Experienced Member

  • Members
  • PipPip
  • 22 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:Other OS/Not specified

Posted 01 September 2019 - 01:32 PM

By the way, here is my log :

Quote

Ion Fury r8018
Built Aug 15 2019 01:54:02, GCC 9.2.0, 64-bit
Using C:/Program Files/ionfyr/ for game data
Using C:/users/merlin/Application Data/Ion Fury/ for game data
Running on Wine 4.13, identifying as Windows 7 Service Pack 1 (build 6.1.7601)
Initializing SDL 2.0.10
Searching for game data...
Using "fury.grp" as main game data file.
Compiling: scripts/main.con (50245 bytes)
Including: scripts/tokens.con (27554 bytes)
Including: scripts/names.con (59980 bytes)
Including: scripts/sounds.con (191808 bytes)
Including: scripts/music.con (3666 bytes)
Including: scripts/text.con (12575 bytes)
Including: scripts/levels.con (7633 bytes)
Including: scripts/customize.con (6567 bytes)
Including: scripts/subroutines.con (16878 bytes)
Including: scripts/surfaces.con (110651 bytes)
Including: scripts/draw.con (24750 bytes)
Including: scripts/sectors.con (374828 bytes)
Including: scripts/weapons.con (403793 bytes)
Including: scripts/pickups.con (74629 bytes)
Including: scripts/switches.con (152869 bytes)
Including: scripts/props.con (293032 bytes)
Including: scripts/dialog.con (40999 bytes)
Including: scripts/player.con (340291 bytes)
Including: scripts/screens.con (42167 bytes)
Including: scripts/menu.con (40291 bytes)
Including: scripts/inventory.con (1355 bytes)
Including: scripts/particles.con (292072 bytes)
Including: scripts/enemies.con (598362 bytes)
Compiled 1991640 bytes in 1037ms
Initialized 256.0M cache
0009:fixme:win:RegisterDeviceNotificationW (hwnd=0x1006e, filter=0x33f9b0,flags=0x00000004) returns a fake device notification handle!
002d:fixme:win:RegisterDeviceNotificationW (hwnd=0x60070, filter=0x1d16fc40,flags=0x00000000) returns a fake device notification handle!
0009:fixme:xinput:XInputGetBatteryInformation (index 0, type 0, battery 000000000033F8EA) Stub!
0009:fixme:win:RegisterTouchWindow (0x2004a 00000003): stub
0009:fixme:wgl:macdrv_wglChoosePixelFormatARB unused pfAttribFList
0009:fixme:win:RegisterTouchWindow (0x3004a 00000003): stub
0009:fixme:wgl:macdrv_wglChoosePixelFormatARB unused pfAttribFList
/Volumes/Grotte/jeux/WINE/Ion Fury.app/Contents/Frameworks/wswine.bundle/lib64/../bin/wine64-preloader: line 2:  5194 Terminated: 15   DYLD_FALLBACK_LIBRARY_PATH="${WINESKIN_LIB_PATH_FOR_FALLBACK}" "$(dirname "$0")/Ion Fury962314423Wine64-preloader" "$@"
wine: Unhandled page fault on read access to 0x00000040 at address 0x7fff4a2e2fc9 (thread 001c), starting debugger...
001c:err:seh:start_debugger Couldn't start debugger ("false") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
001c:err:seh:setup_exception stack overflow 1712 bytes in thread 001c eip 000000007bc31eb7 esp 0000000000790f60 stack 0x790000-0x791000-0x990000



#3 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3011 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 02 September 2019 - 11:17 AM

do you have d3dx9 installed? You could also try changing the Windows OS that the wrapper uses. You can do that in WineCFG.

#4 vanhouten

vanhouten

    Experienced Member

  • Members
  • PipPip
  • 22 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:Other OS/Not specified

Posted 02 September 2019 - 09:54 PM

I've installed d3dx9 and tried to change to windows 10 but it's still the same.

#5 Gcenx

Gcenx

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 362 posts
  • Graphics Card:Intel Iris
  • Operating System:macOS 10.12 (Sierra)

Posted 02 September 2019 - 10:12 PM

It lightly still needs some native dll files, change the 'Wine Debug" field to the following
err+all,fixme+all,fixme-esync,+loaddll
Or to only show what dll files are being loaded set
+loaddll

The mouse only working properly when using"Test Run" is due to how WineskinLauncher is loaded via Wineskin.app as compared to a standard launch, wine needs to be launched as a subprocess and honestly that would take a lot of changes within WineskinLauncher. I was thinking of using a workaround to avoid this but I won't get around to implementing that and pushing a newer wrapper update for a while.

#6 vanhouten

vanhouten

    Experienced Member

  • Members
  • PipPip
  • 22 posts
  • Graphics Card:AMD Radeon RX 580
  • Operating System:Other OS/Not specified

Posted 03 September 2019 - 12:34 PM

Thanks for the info, I was wondering what was the difference.

I just found out that I could use Eduke32 to launch the game natively… and I've got the same issue. So I suppose it has nothing to do with WINE, probably more with my graphic card. I'll try with another mac later.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users