Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

[FILLED] Crysis


  • This topic is locked This topic is locked
59 replies to this topic

#31 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 22 July 2010 - 02:30 AM

I have made some progress on Darkuser's port thanks to Drakulix.

It still isnt usable as i need to fix a bug where the game crashes after the first chapter video.

But the mouse in-menu works fine, no exceptions (it runs faster than some other ports i have with the mouse in-game *cough cough oblivion cough cough*

Also, differ from Darkuser's port, the sound in the start up videos work fine. No problems there until you start the new game :(

Loading from a previous save game seems to work, but freezes the game about 30mins in. Which sucks.

But im not going to upload it until the new game bug is fixed :(

I may upload a updated video though.
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#32 apolloa

apolloa

    Regular Member

  • Members
  • Pip
  • 10 posts

Posted 26 July 2010 - 02:03 PM

Hey, I got into a game using a saved game. This was using beta Crossover Games 9.1 which has Win 1.2. The trouble is that the game sprite is not drawn, kind of get thick black lines, same for the arms. And I have limited mouse movement?? Anyone got any ideas?

#33 apolloa

apolloa

    Regular Member

  • Members
  • Pip
  • 10 posts

Posted 28 July 2010 - 08:06 PM

Well I got the gun sprites to draw correctly with help from the crossover team, I used the registry entry UseGLSL enabled. So I was able to get into a saved game but the mouse would leave the screen and the game crashes. I set up a registry key for the mousewarpoverride command but then when you press the spacebar to start the game I get a black screen with the health bar at the top of the screen. I also now always get this same thing, even after deleting the mousewarpoverride registry key's??

#34 playn

playn

    Just Playin'

  • Donators
  • 1966 posts
  • LocationAustralia
  • Graphics Card:NVIDIA GeForce GT 330M
  • Operating System:Mac OS X 10.7 (Lion)

Posted 29 July 2010 - 06:39 AM

i think your getting graphic problems because you have low shader settings on or something like that. reverse the changes you made and try that

Posted Image

'Do you want to spend the rest of your life selling sugared water or do you want a chance to change the world?'

– Steve Jobs


#35 apolloa

apolloa

    Regular Member

  • Members
  • Pip
  • 10 posts

Posted 29 July 2010 - 09:10 AM

playn said:

i think your getting graphic problems because you have low shader settings on or something like that. reverse the changes you made and try that

Thanks. I'll try that. I uninstalled Crossover Games beta and installe and installed the release. So re-installed Crysis but I can't even load a game up now????? Very confusing. I stopped being able to load a game up with the beta version just before I removed it.

#36 blargman

blargman

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationyou would want to know
  • Graphics Card:ATI Radeon HD 2600 Pro
  • Operating System:Other OS/Not specified

Posted 02 August 2010 - 02:53 AM

do u guys own an actual copy of the game
!!!

#37 nintendotoad

nintendotoad

    Champion Member

  • Members
  • 793 posts
  • Location/tmp
  • Graphics Card:NVIDIA 580 GTX
  • Operating System:Mac OS X 10.7 (Lion)

Posted 02 August 2010 - 04:22 AM

That's irrelevant. Usually. The crack, unless it was made using .NET Framework 3.5 or something like that (RELOADED), should run at equal speed.
P.S.: http://appdb.winehq....objectManager.p ... &iId=20835
HOW THE HELL DID HE DO THAT!?!?!?!?
PortingNetwork now lurks in the shadows... among us.

#38 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 02 August 2010 - 07:40 AM

nintendotoad said:

That's irrelevant. Usually. The crack, unless it was made using .NET Framework 3.5 or something like that (RELOADED), should run at equal speed.
P.S.: http://portingteam.c...edirect.php?htt ... &iId=20835
HOW THE HELL DID HE DO THAT!?!?!?!?

The One on OS X, Ive asked to downgrade it (it was by me) It was supposed to be rated silver.

But the one on 1.3.0, It isnt that good, maybe it is jsut becuase of my 9400M and emulating it. But It runs alot better in Wine 1.3.0 (im reupload it now to the section, nintendotoad, Ill PM you when the updated wrapper is up, if you like)

But it would still be rated gold, if you can get passed the graphics bugs (on low) and the speed issues on medium-ultra high graphics.
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#39 playn

playn

    Just Playin'

  • Donators
  • 1966 posts
  • LocationAustralia
  • Graphics Card:NVIDIA GeForce GT 330M
  • Operating System:Mac OS X 10.7 (Lion)

Posted 02 August 2010 - 10:01 AM

BoomBoxCreations said:

nintendotoad said:

That's irrelevant. Usually. The crack, unless it was made using .NET Framework 3.5 or something like that (RELOADED), should run at equal speed.
P.S.: http://portingteam.c...edirect.php?htt ... &iId=20835
HOW THE HELL DID HE DO THAT!?!?!?!?

The One on OS X, Ive asked to downgrade it (it was by me) It was supposed to be rated silver.

But the one on 1.3.0, It isnt that good, maybe it is jsut becuase of my 9400M and emulating it. But It runs alot better in Wine 1.3.0 (im reupload it now to the section, nintendotoad, Ill PM you when the updated wrapper is up, if you like)

But it would still be rated gold, if you can get passed the graphics bugs (on low) and the speed issues on medium-ultra high graphics.
how much longer till its uploaded! :p i cant wait to play

Posted Image

'Do you want to spend the rest of your life selling sugared water or do you want a chance to change the world?'

– Steve Jobs


#40 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 02 August 2010 - 10:06 AM

playn said:

BoomBoxCreations said:

nintendotoad said:

That's irrelevant. Usually. The crack, unless it was made using .NET Framework 3.5 or something like that (RELOADED), should run at equal speed.
P.S.: http://portingteam.c...edirect.php?htt ... &iId=20835
HOW THE HELL DID HE DO THAT!?!?!?!?

The One on OS X, Ive asked to downgrade it (it was by me) It was supposed to be rated silver.

But the one on 1.3.0, It isnt that good, maybe it is jsut becuase of my 9400M and emulating it. But It runs alot better in Wine 1.3.0 (im reupload it now to the section, nintendotoad, Ill PM you when the updated wrapper is up, if you like)

But it would still be rated gold, if you can get passed the graphics bugs (on low) and the speed issues on medium-ultra high graphics.
how much longer till its uploaded! :p i cant wait to play

Im currently working on it (hopefully, should be up by the end of the week) Because my internet is shit. My internet switches over on Sunday next week, So it will definitely be up before then. (by when that happens, I will post it from my jailbroken and unlocked iPhone 4)
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#41 blargman

blargman

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationyou would want to know
  • Graphics Card:ATI Radeon HD 2600 Pro
  • Operating System:Other OS/Not specified

Posted 02 August 2010 - 10:39 PM

I can't wait... ive waited so long for this day to come...
!!!

#42 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 20 August 2010 - 12:07 AM

@BoomBoxCreations I too have the same problem the sound you hear on every video the mouse works perfectly on the menù but when I try to start a new game freezes on a black screen! =( i create a wrapper whit 1.2 version of wine!
Gameintosh

#43 Crimsonskies

Crimsonskies

    Advanced Member

  • Members
  • PipPipPip
  • 77 posts
  • Operating System:Other OS/Not specified

Posted 20 August 2010 - 02:15 AM

Bert93 said:

@BoomBoxCreations I too have the same problem the sound you hear on every video the mouse works perfectly on the menù but when I try to start a new game freezes on a black screen! =( i create a wrapper whit 1.2 version of wine!
It works better with 1.3 wine.

#44 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 20 August 2010 - 08:08 AM

Everything works with Wine 1.3.0 (although multiplayer isnt tested)

But there are still some bugs with it, which is crap, should be easier to fix now, the majority of the game works!


P.S. Still uploading
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#45 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 22 August 2010 - 04:55 PM

ok test the 1.3 version but there is a wrapper that is based on this version??
Gameintosh

#46 Drakulix

Drakulix

    Old nearly vanished Member

  • Members
  • 1903 posts
  • LocationGermany
  • Graphics Card:nVidia GeForce 650M 1GB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:FPS, Action, Minecraft, Skyrim, Strategy, rare Racing

Posted 22 August 2010 - 05:04 PM

yeah, boombox has updated his members project section.
The new 1.1 Wrapper is using 1.3
Posted Image

#47 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 27 August 2010 - 11:04 PM

Thanks @Drakulix nice photo!!!  :)
Gameintosh

#48 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 28 August 2010 - 12:24 PM

I might get the wrapper @ BoomBoxCreations is just to see if it works on my computer! and if it works on Ati Radeon!
Gameintosh

#49 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 28 August 2010 - 12:29 PM

Bert93 said:

I might get the wrapper @ BoomBoxCreations is just to see if it works on my computer! and if it works on Ati Radeon!

Ill PM you with the link, But you get 50 posts and you can see the section for the wrapper anyway :)

I dont think it works too well on ATI though, but the more testers the better.
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#50 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 28 August 2010 - 12:44 PM

use a translator but I did not understand very well! you should show me the link to 15:00!  :oops:  :unknown:
Gameintosh

#51 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 28 August 2010 - 12:56 PM

For you:

Io messaggio personale voi con il percorso di download, ma si ottiene 50 posti e si può vedere la sezione per l'involucro comunque.

Non credo che funziona troppo bene su ATI, però, ma i tester più sono e meglio.


(to the mods, its just an italian translation of my above post, nothing different)
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#52 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 28 August 2010 - 01:23 PM

ok grazie mille!!
Gameintosh

#53 bismarrck

bismarrck

    Rookie Porter

  • Members
  • PipPipPip
  • 75 posts
  • LocationBeijing

Posted 30 August 2010 - 12:30 AM

Oh, My God! Crysis!

I have never expected it before.

#54 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 30 August 2010 - 10:43 AM

Ok  @BoomBoxCreations ho testato il Wrapper ma su Ati non funziona bene!! mancano le texture sulle armi e non si riescono a vedere i nemici!! ma le texture della vegetazione sembrano buone!!! c'è ancora da aspettare!! ma per ora è già un passo avanti!! e funziona quando si avvia un nuovo gioco! Grazie ancora per avermi fatto testare il Wrapper!
Gameintosh

#55 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 30 August 2010 - 11:10 AM

Italiano / Italian

Nessun problema @ Bert93

Come ho detto, ci sono alcuni problemi nell'uso di schede grafiche ATI. Mi metterò li fisso, si spera. Ill PM la prossima release, se non hai 50 i messaggi di allora.


(To The Mods) English

No problems @Bert93

As I said, there are some problems using ATI graphics cards. I will get them fixed, hopefully. Ill PM you the next release if you do not have 50 posts by then.

#56 theShadow

theShadow

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts
  • Graphics Card:nvidia geforce 330m
  • Operating System:Mac OS X 10.7 (Lion)

Posted 31 August 2010 - 02:08 PM

is this uploaded on this site, or at wineHQ?

I would like to help test it. :)

#57 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 01 September 2010 - 01:51 AM

theShadow said:

is this uploaded on this site, or at wineHQ?

I would like to help test it. :)

when you get 40 posts, Ill PM you :) When you get 50 posts, check the members section :)
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]

#58 Bert93

Bert93

    Professional Member

  • Members
  • PipPipPipPip
  • 178 posts
  • LocationVenice, Italy

Posted 04 September 2010 - 12:16 PM

@BoomBoxCreations thanks again for all your help and support!
Gameintosh

#59 dku707

dku707

    Rookie Porter

  • Members
  • PipPip
  • 49 posts

Posted 06 September 2010 - 07:40 PM

it's exciting to see the progress made on this game. it has been said in the past that it is impossible, and here we go almost achieving the impossible.
The Game Porting Team: Fueling the Mac Revolution

#60 BoomBox

BoomBox

    Champion Member

  • Members
  • 936 posts
  • Graphics Card:2x GTX 780 Ti
  • Operating System:Windows
  • I like to play:anything

Posted 06 September 2010 - 10:59 PM

We have achieved the impossible :P splits going to do is get better and better :D
If my ports links are dead, Email me.   [ BoomBoxCreations (at) gmail . com ]




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users