Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

[Help] Test Drive Unlimited


  • Please log in to reply
8 replies to this topic

#1 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 30 May 2009 - 07:13 PM

I ported TDU and it works on my Macbook (GMA950). I uploaded it and people on C4M were reporting that it doesn't open for them. They're getting this error:

2009-05-30 16:11:22.114 cider[3608] regapi failed: 2
err:reg:Nt_openConfigW could not retrieve the module file name (reason: 'bad module')
err:reg:Nt_openConfigW could not retrieve the module file name (reason: 'bad module')
Warning: Language 'en_DE' was not found, retrying without country name...
For language 'en' several language ids were found:
en_US - 0409; en_GB - 0809; en_AU - 0C09; en_CA - 1009; en_NZ - 1409; en_IE - 1809; en_ZA - 1C09; en_JM - 2009; en_ - 2409; en_BZ - 2809; en_TT - 2C09; 
Instead of using first in the list, suggest to define
your LANG environment variable like this: LANG=en_US
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
wine: Unhandled exception, starting debugger...

It's using Cider 2432.

Any help or a pointer would be VERY appreciated!


When I'm playing the game I get this....
/cider 
2009-05-30 20:16:46.560 cider[1012] regapi failed: 2
err:reg:Nt_openConfigW could not retrieve the module file name (reason: 'bad module')
err:reg:Nt_openConfigW could not retrieve the module file name (reason: 'bad module')
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
But it launches and plays... strange...
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#2 devilhunter

devilhunter

    just dancing to the beat

  • Administrators
  • 3051 posts
  • LocationSpace/Virgo Supercluster/Milky Way/Orion Arm/Earth
  • Graphics Card:NVIDIA 9800 GTX+
  • Operating System:Mac OS X 10.6 (Snow Leopard)
Author

Posted 30 May 2009 - 09:05 PM

i had the exact same problem when i tried to port TDU.
It worked on my mac at work which had a geforce 7300GT, and when i brought it home for testing (i have a 9800GTX), it wouldn't launch anymore.
Weird.
Cider doesn't treat all Video Cards equally, so this would be a good example for that.
Hello. Sadly, I am not active here on the Porting Team anymore, and therefore I cannot give support or answer questions to any of my posted Ports or posted topics.

- zero

#3 Guest_rlogin_*

Guest_rlogin_*
  • Guests

Posted 30 May 2009 - 09:17 PM

hi jimjimjimbob :-)

i test this afternoon with various CIDER RELEASES and have same problem with ALL... i'm used:

1.- VMWARE to install the "original pc windows game"
2.- fixed/patched it
3.- load in cider R2432 and 2098 with same error (as i say in the other forum)

err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
err:module:BUILTIN_LoadModule loaded .so but dll joystick.drv still not found
wine: Unhandled exception, starting debugger...

i try to "activate" the joystick library adding ""joystick.drv" = "builtin, native"" at config file...    i try to deactivate the joystick library... via cmd line .... and i delete it... and i have same error.

#4 thedoc

thedoc

    Administration Team

  • Administrators
  • 1311 posts
  • Graphics Card:nVidia GeForce 9600M GT - 512 MB RAM
  • Operating System:Mac OS X 10.5 (Leopard)
  • I like to play:FPS, RPG, Racing

Posted 31 May 2009 - 11:20 AM

The game launches for me - but when I enter the serial code i can't click on the OK button - the mouse works but the clicks are not recognized unfortunately.

so I'm stuck on the serial screen.

any suggestions?
Posted Image

Check out my Porting Blog @ Doc's Office


#5 devilhunter

devilhunter

    just dancing to the beat

  • Administrators
  • 3051 posts
  • LocationSpace/Virgo Supercluster/Milky Way/Orion Arm/Earth
  • Graphics Card:NVIDIA 9800 GTX+
  • Operating System:Mac OS X 10.6 (Snow Leopard)
Author

Posted 02 June 2009 - 04:54 PM

thedoctor45 said:

The game launches for me - but when I enter the serial code i can't click on the OK button - the mouse works but the clicks are not recognized unfortunately.

so I'm stuck on the serial screen.

any suggestions?

Had the same problem.
And since it didn't even launch on another mac i didn't bother anymore with the Game.
But i have to admit, i like this game more than the NFS Series.

You can run this game with some effort in the normal Crossover, but the Graphics are mostly messed up.
Hello. Sadly, I am not active here on the Porting Team anymore, and therefore I cannot give support or answer questions to any of my posted Ports or posted topics.

- zero

#6 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 09 June 2009 - 08:47 PM

I got the game working to the point where we've put the serial number and and we've got the menus up and running. When we come to load a save game or start a new one it crashes with this error - kinda reminds me of Driv3r.

Here's the output:

CrossOver Chromium[2749] The primary OEM task just exited.  Time to close down.
CrossOver Chromium[2749] Shutting down all bottles.
PseudoramiX screen 0 added: 1280x779 @ (0,21).
PseudoramiX screen 0 placed at X11 coordinate (0,0).
Screen 0 placed at X11 coordinate (0,0).
Quitting XDarwin...
CrossOver Chromium[2749] X client process terminated with status 1.

Where would the default location of saved games be on windows, maybe a hunt around there could help.

Has anyone else found a fix for games with problems like this?
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#7 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 09 June 2009 - 08:49 PM

Forgot to mention - the way I fixed it was updating the game to 1.66 (using dopeman's patch from mininova with no install needed) and this took away mouse control but allowed the serial to be entered. I know there're loads of people wanting to play this game so I'd hate do disappoint
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#8 devilhunter

devilhunter

    just dancing to the beat

  • Administrators
  • 3051 posts
  • LocationSpace/Virgo Supercluster/Milky Way/Orion Arm/Earth
  • Graphics Card:NVIDIA 9800 GTX+
  • Operating System:Mac OS X 10.6 (Snow Leopard)
Author

Posted 09 June 2009 - 09:32 PM

I see, didn't think of a patch.
Well good luck for some progress.

But there is still the question on why it doesn't launch for some users. (See the posts above)
Hello. Sadly, I am not active here on the Porting Team anymore, and therefore I cannot give support or answer questions to any of my posted Ports or posted topics.

- zero

#9 blueman56

blueman56

    Veteran Member

  • Donators
  • 342 posts
  • Graphics Card:A Portable One!
  • Operating System:OS X 10.9 (Mavericks)

Posted 16 June 2009 - 02:11 PM

The game saves/loads fine and the menus are fine, its just wen the movie and game actually starts the graphics are all messed up!!

Any ideas? Would this game work better in the lastest build of Cider instead of the CX wrapper or has that already been tested?

I'll do some testing on it when i get home from work, but if anybody else has had a go before then culd you share your results?

Thanks!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users