Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

[REQ] Anarchy Online


  • Please log in to reply
6 replies to this topic

#1 MindBrain

MindBrain

    Rookie Porter

  • Members
  • PipPipPip
  • 51 posts

Posted 31 October 2010 - 10:24 PM

How about a wineskin for Anarchy Online? Free sci-fi MMO  can't go wrong with that!

#2 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 31 October 2010 - 10:53 PM

I used to play that a looong time ago... didn;t know it still existed.

#3 MindBrain

MindBrain

    Rookie Porter

  • Members
  • PipPipPip
  • 51 posts

Posted 01 November 2010 - 01:07 AM

Check it out they have free option. I'm trying to make a wrapper, but I ran into trouble with the Anarchy Online patcher, when it goes to patch I get an error saying something about an unsupported operation. It's a bug documented here: http://portingteam.c...edirect.php?htt ... i?id=11486  so uh I'd like to get it to work, if anyone knows about i please share THANKS

edit: There might be a way to make it work using "winetricks" but i'm not sure if it only applies to linux, anyone know how to install winetricks ie6

#4 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 01 November 2010 - 01:23 AM

MindBrain said:

Check it out they have free option. I'm trying to make a wrapper, but I ran into trouble with the Anarchy Online patcher, when it goes to patch I get an error saying something about an unsupported operation. It's a bug documented here: http://portingteam.c...edirect.php?htt ... i?id=11486  so uh I'd like to get it to work, if anyone knows about i please share THANKS

edit: There might be a way to make it work using "winetricks" but i'm not sure if it only applies to linux, anyone know how to install winetricks ie6

In Wineskin 1.x you run WineskinSettings.app in the wrapper... click Advanced and Tools and the Winetricks button... select IE6 and run it.

Wineskin 2.0 beta is similar but the app inside the wrapper is just called Wineskin.app, and the Tools are on a tab, not a button with a different menu.

CXZ/CXS has a CXWinetricks.app that can be used too for those.

#5 MindBrain

MindBrain

    Rookie Porter

  • Members
  • PipPipPip
  • 51 posts

Posted 01 November 2010 - 02:14 AM

I've tried this but I still get the error. Should I wipe out the install and start over first installing ie6? I'll try it thanks...

edit: I'm trying again, started over, installed winetricks ie6 first, using engine 1.2.1, redownloading game, anything else i might be missing from winetricks?

#6 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 01 November 2010 - 04:01 AM

MindBrain said:

I've tried this but I still get the error. Should I wipe out the install and start over first installing ie6? I'll try it thanks...

edit: I'm trying again, started over, installed winetricks ie6 first, using engine 1.2.1, re-downloading game, anything else i might be missing from winetricks?

if its using mshtml (from IE) for log in and patching... it might be bugged from having it disabled earlier... it sometimes doesn't re-enable correctly.  Go into winecfg into the libraries tab, and make sure mshtml is set to native then built in... not disabled... look for multiple entires for it.

#7 MindBrain

MindBrain

    Rookie Porter

  • Members
  • PipPipPip
  • 51 posts

Posted 01 November 2010 - 06:42 AM

doh123 said:

MindBrain said:

I've tried this but I still get the error. Should I wipe out the install and start over first installing ie6? I'll try it thanks...

edit: I'm trying again, started over, installed winetricks ie6 first, using engine 1.2.1, re-downloading game, anything else i might be missing from winetricks?

if its using mshtml (from IE) for log in and patching... it might be bugged from having it disabled earlier... it sometimes doesn't re-enable correctly.  Go into winecfg into the libraries tab, and make sure mshtml is set to native then built in... not disabled... look for multiple entires for it.

Ok well i found 2 entries of it, the 2nd was disabled and I enabled it like you said but I get the same error. I have even installed mfc42.dll  from winetricks as I think was suggested at http://bugs.winehq.o...ug.cgi?id=11486  

someone also mentions doing ".wine-ao install" but I don't know what that is...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users