Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

My Modded GTA San Andreas


  • Please log in to reply
40 replies to this topic

#1 RazorPro

RazorPro

    Chief Designer

  • Members
  • PipPipPipPipPip
  • 274 posts
  • LocationSan Andreas
  • Graphics Card:nvidia 9400m
  • Operating System:Other OS/Not specified

Posted 28 November 2010 - 03:33 AM

Hello everybody,

I just wanted to share some screenshots of my modded GTA San Andreas.  Keep in mind, that this is on my mac, so it wasn't easy to do.

Image Image Image Image Image Image

So, you can see that a lot of the ideas for these came from GTA IV, like the menu, vehicles, hud (first on bottom row), and weapon aim camera (3rd one across on top row).

This wouldn't have been passible without dafootballer's cider 4300 wrapper (because all the vehicles would have been silver :D) and without ferdyfist's modding tools, so thank you guys.

Feel free to post any screenshots of your modded GTA San Andreas below (I'm hoping to see some of yours ferdyfist).

Enjoy,
Razor Pro

Posted ImagePosted Image[ "Experience is the teacher of all things."  -Julius Caesar ]


#2 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 28 November 2010 - 02:41 PM

Still nothing about ENB?

#3 RazorPro

RazorPro

    Chief Designer

  • Members
  • PipPipPipPipPip
  • 274 posts
  • LocationSan Andreas
  • Graphics Card:nvidia 9400m
  • Operating System:Other OS/Not specified

Posted 28 November 2010 - 02:52 PM

No, we'd need an advanced porter to get that working I think.  But, I got everything else working Jawacom.

If any advanced porters don't have anything to do, you should try getting GTA SA working with an ENB mod.

Posted ImagePosted Image[ "Experience is the teacher of all things."  -Julius Caesar ]


#4 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 28 November 2010 - 05:54 PM

Ah, alright, could have investigated ENB further, but I don't really have the time for the moment.

By the way, exactly what mods have you used?  :good:

#5 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 04:04 PM

Awesome! But.. How can i install the Cider 4300 wrapper? Because all my modded cars are chrome now..

#6 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 04:23 PM

I don't think it is 4300, it is 4003...

You download the wrapper viewtopic.php?f=109&t=4893 and then you put the game files in it and type in the executable path in the info.plist inside the wrapper.

You should be able to find some guide around here... ask me or someone else otherwise.

#7 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 05:09 PM

Jowacom said:

I don't think it is 4300, it is 4003...

You download the wrapper viewtopic.php?f=109&t=4893 and then you put the game files in it and type in the executable path in the info.plist inside the wrapper.

You should be able to find some guide around here... ask me or someone else otherwise.

Thank you! :good:

#8 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 05:12 PM

You are welcome!

Have fun.

#9 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 05:15 PM

Well, I downloaded the file, it's named Cider4003.7z, but when I unzip it with Springy, the only file in it is ToyStory3.app... Do I have to drag that into my GTA SA map? Sorry, lol, but I thought normal files would be in it.. :)

Nevermind, I got it! Lol :"":

#10 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 05:20 PM

Right click - Show package contents - Navigate to the folder called transgaming. In there there is drive_c and stuff. Put your San Andreas files in there.

Oh, wait... download this wrapper instead... http://portingteam.c...edirect.php?htt ... 0d24c61bd0

Do the same steps. Put your San Andreas content in there. You can find them somewhere inside your San Andreas wrapper, in transgaming/c_drive/Program
Files/

Sorry if it is unclear.

#11 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 05:23 PM

The site says the download isn't compatible with my computer configuration? lol

#12 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 05:37 PM

Oh, and when I change the executable path's name to where my gta_sa.exe is, the ToyStory3 icon pops up, jumps and asks Do you want to debug.......? And when I choose yes, it just goes away. Nothing more..?

#13 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 06:56 PM

Have you changed both paths? One should be the directory where the .exe is.

#14 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 07:12 PM

There isn't one there.. Should I copy the other one? Will that work?

#15 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 07:22 PM

Posted Image

That's how it should look, at least the paths.

#16 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 07:26 PM

Uhm.. How do I open a log like that? (Sorry, i SUCK at changing things)

#17 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 07:29 PM

Oh, that's the plist editor I have. You don't have one, so, you'll have to open the info.plist in some text editor or something.

Here, download the wrapper. (4003 with the paths in it)



#18 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 07:40 PM

Okay, I downloaded it and dragged everything that was in my GTA San Andreas folder in there, in the map GTA San Andreas. Now do I have to change the Info.plist, or not? And how can i open the game? Lol, i totally suck. :P

#19 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 07:47 PM

You do not change the info.plist if you downloaded the wrapper i just posted. You right click the application you just downloaded and choose show package contents. Navigate to Contents/Resources/transgaming/c_drive/Program Files. Drop your Rockstar folder in there. Or, you drop the GTA San Andreas Folder inside the Rockstar folder... In both cases, overwrite what's already there.

Double click the application. The game starts.

:)

#20 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 07:58 PM

Well, the San Andreas icon pops up, but then it doesn't start.. It goes away again..

#21 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 08:02 PM

Can you upload some pictures of how it looks inside your wrapper or something?

#22 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 08:08 PM

I can always try :)
Posted Image
Posted Image

#23 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 07 January 2011 - 08:09 PM

The GTA San Andreas.app keeps staying like in the second picture..

#24 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 07 January 2011 - 08:12 PM

Do you have any mods installed? They can be the problem... Some mod maybe breaks everything.

All, right, gotta go now, I'll be back in like 12 hours, but perhaps someone else can help you?  :D

#25 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 08 January 2011 - 09:20 AM

I do have a lot of mods installed, yes.. Should I remove all of them?

#26 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 08 January 2011 - 10:01 AM

You may have a mod that breaks everything... What mods are installed? I don't think you'll have to remove all of them.

What does that "Errordump" say by the way?

#27 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 08 January 2011 - 10:36 AM

Well, I had the knight rider mod v0.2A, New great Effects 1.5, and a lot of vehicle mods  (boats, planes, cars).. But I downloaded the game freshly again, it's finished now, so i'll try it again now

#28 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 08 January 2011 - 10:37 AM

All right then... tell me if you run into more problems. :)

#29 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 08 January 2011 - 10:38 AM

I'll be sure to, haha! :)

#30 DutchAppleFan

DutchAppleFan

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • LocationHolland
  • Graphics Card:ATI Radeon HD 4670
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:GTA San Andreas

Posted 08 January 2011 - 11:05 AM

Well, first of all.. Thank you! The game works:) But, it's very very laggy.. How can I fix that? :P




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users