Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Champions Online FFA


  • Please log in to reply
16 replies to this topic

#1 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 28 January 2011 - 07:19 AM

Ladies and gentlemen, I took the liberty to download Champions Online - Free For All, the moment I found out they went free to play, and tried to port it.

IT WORKS.

TO A POINT.

That point being trying to connect to the account Server, which is where I'm totally in the dark. How am I supposed to connect the game to the internet? Winetricks, regedit tips, what have you, would be all nice in this endeavor!


Edit: I figure I can elaborate on the 'How To' of getting this far.

Step 1: Download Champions Online - Free For All. I got mine from a torrent, much easier than trying to use the downloader, which caused more problems than solved.
Step 2: Stick it all in a Wine Wrapper.
Step 3: I'm using Wine Engine 1.3.12, which seems to be working fine with it thus far.
Step 4: Make sure the Execute File is set to GameClient.exe,  using the main file doesn't work for some reason (will double check this.)
Step 5: When you run the file, it'll pop up a graphics card functions thing (I assume, it did for me). Pick Default or  Low Quality, if you're unsure.
Step 6: After some loading, you'll fined yourself in the main menu! Hooray!
Step 7: ??? (Connect to the internet)
Step 8: Profit!

If someone could figure out Step 7, I'd be in great debt.

Edit 2: Going to try to install DirectPlay as a Winetrick. Trying anyways, it's taking it's frigging time.

Edit 3: Turns I had been using 1.3.8 the whole time, but I'm not entirely sure switching it to 1.3.12 will make a huge amount of difference.

On that note, I'll give the STO wrapper a shot.

#2 Jowacom

Jowacom

    Champion Member

  • Donators
  • 811 posts
  • LocationSweden
  • Graphics Card:ATI Radeon 2600 HD
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Most genres

Posted 28 January 2011 - 07:23 AM

Sounds like Need for Speed World... it couldn't patch the game, because it couldn't connect to the Internet. It would be great if we sorted that problem out.

#3 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 28 January 2011 - 03:46 PM

So far no luck with the Winetricks. If anyone else can put in input, I'd appreciate it.

#4 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 28 January 2011 - 03:50 PM

download my Star Trek Online wrapper... it runs CO including the free version as well.

use Wine version 1.3.5.. it runs the best.. there are some html and encryption issues after that that causes very slow loading of the log in pages.

#5 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 28 January 2011 - 03:55 PM

I had tried before, but it didn't seem to be working properly for me. Will try again, but yeah here's hoping.

#6 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 28 January 2011 - 04:10 PM

I concede to the STO Wrapper.

Consider my efforts forfeit.

#7 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 28 January 2011 - 04:39 PM

1.2 wrapper and 1.3 betas had problems...

yesterday I put out STO UMV wrapper 1.3.0 and it works much better (as long as you have only 1 display)


You can take it and clean it up changing Icon and exe and stuff and make it for CO

#8 Ygor

Ygor

    Experienced Member

  • Members
  • PipPip
  • 21 posts
  • Graphics Card:Nvidia GM 9400
  • Operating System:Other OS/Not specified

Posted 29 January 2011 - 12:03 PM

doh123 said:

1.2 wrapper and 1.3 betas had problems...

yesterday I put out STO UMV wrapper 1.3.0 and it works much better (as long as you have only 1 display)


You can take it and clean it up changing Icon and exe and stuff and make it for CO
Hello,
I tried to port it with the Star Trek Online wrapper- and it works for me! :)
Thank you wery much for the wrapper :)

And here is an icon for CO that I made, feel free to use it- till somebody makes a better one :D

http://img152.images...mpslogofin.png/

#9 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 29 January 2011 - 09:51 PM

There is still the small matter of the game crashing every couple of hours, especially when you change instances. It works quite nicely otherwise.

#10 Ygor

Ygor

    Experienced Member

  • Members
  • PipPip
  • 21 posts
  • Graphics Card:Nvidia GM 9400
  • Operating System:Other OS/Not specified

Posted 30 January 2011 - 08:13 AM

Yarrik said:

There is still the small matter of the game crashing every couple of hours, especially when you change instances. It works quite nicely otherwise.

Is it not a problem with snow leopard?

Cause I can run it on 10.5.  without problems.

#11 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 30 January 2011 - 10:34 AM

Ygor said:

Yarrik said:

There is still the small matter of the game crashing every couple of hours, especially when you change instances. It works quite nicely otherwise.

Is it not a problem with snow leopard?

Cause I can run it on 10.5.  without problems.

Why would it be a problem with snow leopard? :Search:

#12 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 01 February 2011 - 10:52 AM

So is the patching process going to function normally with it ported?

#13 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 01 February 2011 - 02:24 PM

I've downloaded the game... going to try it out a bit sometime soon.  Might throw together a wrapper download for it for everyone if I get it working all right.  Probably won't take much work since I already did most of it for STO.

#14 Yarrik

Yarrik

    Regular Member

  • Members
  • Pip
  • 13 posts
  • LocationJordan, for now.

Posted 01 February 2011 - 05:42 PM

If at all possible, could you find a way to deal with the semi-frequent crashing on Snow Leopard?

#15 Pumpqueen

Pumpqueen

    Lurker

  • Members
  • 2 posts
  • Graphics Card:GeForce 8600M GT
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Skyrim - Lotro - Fallout New Vegas - Champions Online - RPG & MMORPG

Posted 01 March 2012 - 10:33 AM

Hello,

I installed Champions online using the STO wrapper, it works until the loading screen. When loading screen appears the screen begins to flicker, then parasit squares appear and then it turns plain blue... Any advice to get it working? CO is really a great game (STO too).

MacBook Pro 15" - OSX 10.6.8 - Nvidia 8600m GT

#16 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 01 March 2012 - 12:43 PM

STO still works fine... i haven't tried CO in over a year, so no idea if its broken.

#17 Pumpqueen

Pumpqueen

    Lurker

  • Members
  • 2 posts
  • Graphics Card:GeForce 8600M GT
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Skyrim - Lotro - Fallout New Vegas - Champions Online - RPG & MMORPG

Posted 11 March 2012 - 12:26 AM

Me again.

STO wrapper WORKS to install and play Champions Online, BUT you must be very patient on first launch and ignore any strange things happening on your screen. After about 5-10 minutes (yes, it's a loooong wait) you finally enter the character creation window and the game will start much faster next time. You might have to re-enter your login and/or password, as the long waiting time sometimes logs you off the server.

Just wanted to point this out for people wishing to play this very good game.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users