Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Blank window on wrapper launch


  • This topic is locked This topic is locked
8 replies to this topic

#1 LameSaint

LameSaint

    Experienced Member

  • Members
  • PipPip
  • 28 posts
  • LocationLas Vegas

Posted 16 July 2011 - 06:27 AM

Okay, so I'm brand new to porting games, and I decided i would give it a shot and learn through trial and error.  I downloaded CXEx central and installed the Carbon wrapper, and am using it to install Rise of Immortal beta using the RoIBootInstaller.exe from their website.  When i install the software inside the wrapper, everything works fine and the install window pops up and installs the game.  However, when i save everything, exit, and launch the wrapper, all that opens up is a blank white rectangular window that is movable but otherwise unresponsive.  Leaving the window alone for a while doesn't do anything, and using another wrapper doesn't work either.  Any idea what might be wrong?
Posted Image

#2 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 16 July 2011 - 01:19 PM

I'm assuming this is a online game.  The blank white is probably trying to use mshtml to do some web rendering for a log in/patcher page.  You probably need to try installing Gecko or IE6/7 into the wrapper.  I don't really use CXEx so I couldn't tell you the specifics on how to do that, but it should be possible using Winetricks.

#3 LameSaint

LameSaint

    Experienced Member

  • Members
  • PipPip
  • 28 posts
  • LocationLas Vegas

Posted 16 July 2011 - 04:35 PM

You're right in assuming that it is an online game, and probably right in assuming that it is a log in/patcher page.  The game is extremely similar to league of legends in most aspects, so I think it is safe to assume it has the same type of log in/patcher page as LoL.  I tried installing gecko using winetricks, but it didn't change anything.  However, when i got the report after installing gecko, there were two lines at the top that both said "Fontconfig error: Cannot load default config file".  Could that error have caused gecko to not work properly?
Posted Image

#4 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 16 July 2011 - 05:30 PM

Most MMOGs login/patchers that need mshtml do not work right with Gecko, which is why I mentioned IE as well.  I know in Star Trek Online and Champions Online I have to use IE7 to get the login/patcher to work.

#5 LameSaint

LameSaint

    Experienced Member

  • Members
  • PipPip
  • 28 posts
  • LocationLas Vegas

Posted 16 July 2011 - 08:30 PM

Ah, thank you for the help doh, your suggestion worked perfectly!  I had to downgrade the engine from Carbon to Ebony in order to install ie6 through winetricks because Carbon was telling me the server was busy or i had no internet connection, but Ebony worked fine.  The white square in now the launcher/patcher window and is actually patching.  Again, thanks for the help!
Posted Image

#6 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 16 July 2011 - 09:39 PM

Trial and error is the best way to learn.
I found a few games that was already ported and tried porting them on my own first.
Also appDB on wineHQ is a great source which has much user feedback to help you on the way.

Until you master a few of the tricks you'll have much coffee and hair pulling, but once you get a hang of it you can port pretty much anything.

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#7 LameSaint

LameSaint

    Experienced Member

  • Members
  • PipPip
  • 28 posts
  • LocationLas Vegas

Posted 16 July 2011 - 10:01 PM

Lol, I understand the coffee and hair pulling part!  I currently have the launcher and patching process working right now, but when i launch the game, it hangs at the "Rise of Immortals" title page, then crashes.  I'm going through all the log files right now to see what's causing the crash, but haven;t had any luck at the moment.  Either way, I'm having a ton of fun trying to port this game!
Posted Image

#8 banditmill

banditmill

    Lurker

  • Members
  • 3 posts

Posted 22 August 2011 - 03:36 AM

I seem to be getting similar problems all the time.

#9 LameSaint

LameSaint

    Experienced Member

  • Members
  • PipPip
  • 28 posts
  • LocationLas Vegas

Posted 23 August 2011 - 07:25 PM

According to Petroglyph support, the game won't run properly because I have an integrated graphics card.  Which sounds like bull to me, because I have no trouble playing other games, and I'm sure that if I installed a copy of windows with boot camp, I could probably play the game.  But I've given up on trying to port Rise of Immortals now.
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users