Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

OS X 10.8 Mountain Lion


  • Please log in to reply
20 replies to this topic

#1 mwine

mwine

    Experienced Member

  • Members
  • PipPip
  • 46 posts

Posted 17 February 2012 - 07:26 PM

Just read that X11 is not included by default (but you can install it) - I wonder if there are any under the hood changes that might effect our wrappers?? I know a few wrapper did break with Lion but I'm sure I got them all working again one way or another.

#2 HiPhish

HiPhish

    Champion Member

  • Members
  • 697 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:Mac OS X 10.7 (Lion)
Author

Posted 17 February 2012 - 07:35 PM

Lion broke only CXEx wrappers, however, whose are made from hacked Crossover components, so that's no big surprise.
Games I own that still need porting:
Dark Messiah of Might & Magic, Descent 3, Fallout, Space Rangers 2

#3 Maverick32

Maverick32

    Regular Member

  • Members
  • Pip
  • 16 posts
  • Graphics Card:Intel HD 3000
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:action-adventure, shooter, open world

Posted 18 February 2012 - 01:27 AM

Hopefully  ports and wrappers still work

#4 wMin17

wMin17

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 400 posts
  • Operating System:Other OS/Not specified

Posted 18 February 2012 - 04:27 AM

Apple is just trying to create new operating systems for some filler....  I mean seriously, the only differences are that its like an ipad.  But what's the point?  You could just buy a freakin ipad!  Weren't ipads there to replace computers?

#5 nintendotoad

nintendotoad

    Champion Member

  • Members
  • 793 posts
  • Location/tmp
  • Graphics Card:NVIDIA 580 GTX
  • Operating System:Mac OS X 10.7 (Lion)

Posted 18 February 2012 - 05:23 AM

In case anyone is worried, both Cider build 2097 and Wineskin 2.5.4 work in the current developer build of Mountain Lion.
PortingNetwork now lurks in the shadows... among us.

#6 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 18 February 2012 - 09:58 AM

View Postnintendotoad, on 18 February 2012 - 05:23 AM, said:

In case anyone is worried, both Cider build 2097 and Wineskin 2.5.4 work in the current developer build of Mountain Lion.
thanks for checking!

#7 fyrabanks

fyrabanks

    Lurker

  • Members
  • 1 posts
  • Graphics Card:NVIDIA GeForce GT 120 512 MB (Apple)
  • Operating System:Mac OS X 10.7 (Lion)

Posted 19 March 2012 - 10:52 PM

Sorry to bump a month old thread, but wrapped applications that previously worked in Mountain Lion DP1 now crash in Mountain Lion DP2. I doubt much relevant has changed between the two versions, and I'm speculating that my applications ran in DP1 because of some system leftovers from the upgrade install from 10.7 (I did a clean install of DP2).

I'm trying to reinstall one of the apps with Wineskin 2.5.4, but the Windows installer crashes immediately and Wineskin gives the "Maybe the installer failed...?" error. Will experiment with some other applications when I'm not busy at work.

Example crash here: http://pastebin.com/6kX04sex
Let me know if there's some place more relevant I should take this--like a bugtracker.

#8 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 21 March 2012 - 10:16 AM

View Postfyrabanks, on 19 March 2012 - 10:52 PM, said:

Sorry to bump a month old thread, but wrapped applications that previously worked in Mountain Lion DP1 now crash in Mountain Lion DP2. I doubt much relevant has changed between the two versions, and I'm speculating that my applications ran in DP1 because of some system leftovers from the upgrade install from 10.7 (I did a clean install of DP2).

I'm trying to reinstall one of the apps with Wineskin 2.5.4, but the Windows installer crashes immediately and Wineskin gives the "Maybe the installer failed...?" error. Will experiment with some other applications when I'm not busy at work.

Example crash here: http://pastebin.com/6kX04sex
Let me know if there's some place more relevant I should take this--like a bugtracker.

Thats from WineBottler and its associated Wine.app, not Wineskin.

#9 reece394

reece394

    Experienced Member

  • Members
  • PipPip
  • 24 posts
  • Graphics Card:NVIDIA GeForce GT 330M 256 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:Red Faction
    Command & Conquer
    Minecraft
    Grand Theft Auto
    Portal 1 & 2

Posted 22 April 2012 - 12:28 PM

I can confirm all wineskin wrappers work with mountain lion dp3 as long as you install xquartz for mountain lion that work with lion

Edit: That are already compatible with lion although I didn't check earlier wrappers to be sure of it

#10 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 22 April 2012 - 04:01 PM

what are the problems if XQuartz isn't installed?  if theres some library thats missing now in 10.8 that used to be around... that XQuartz install adds in, I'd like to knwo what it is cuz I may be able to just put it in the next wrapper update.

#11 reece394

reece394

    Experienced Member

  • Members
  • PipPip
  • 24 posts
  • Graphics Card:NVIDIA GeForce GT 330M 256 MB
  • Operating System:OS X 10.9 (Mavericks)
  • I like to play:Red Faction
    Command & Conquer
    Minecraft
    Grand Theft Auto
    Portal 1 & 2

Posted 12 May 2012 - 12:40 PM

Sorry for the late reply but without x quartz installed some wrappers don't run they bounce up and down and then just quit. I think they are old wineskin wrappers but cannot be certain. Maybe some of them are dependent on x11 or Xquartz and can't function otherwise

#12 wMin17

wMin17

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 400 posts
  • Operating System:Other OS/Not specified

Posted 12 May 2012 - 03:13 PM

I am going to get screwed when WS10 comes out.  I still have 10.6.8!

#13 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 12 May 2012 - 03:49 PM

View PostwMin17, on 12 May 2012 - 03:13 PM, said:

I am going to get screwed when WS10 comes out.  I still have 10.6.8!
I have no idea when WS10 is out, but doh123 just recently did drop the 10.5 support.
I guess doh123 can answer this a lot better than me (because I'm just guessing), but I do believe that 10.6 support is something that still is very important.

According to steam, 35% of the users still use 10.6.8 (there is a "other category" where I guess there are some more 10.6.x users are too).
This might change when 10.8 comes around, but I do prefer 10.6 over 10.7..

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#14 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 12 May 2012 - 10:30 PM

I doubt I'll be needing to drop 10.6 support anytime soon... maybe a few years from now.

#15 hmtinc

hmtinc

    Someone

  • Members
  • 1315 posts
  • LocationCanada
  • Graphics Card:Nvidia GTX 760 (2048mb)
    Intel HD 4000 (512mb)
    Nvidia geforce 9400 (264mb)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:Games
Author

Posted 13 May 2012 - 12:37 AM

Apple is slowly approaching 10.8 soon then in the next 1 -2 years or so it will be 10.9
after 10.9 they will have to end the OSX era ( cause X in osX stands for 10) . Then what will they call MAC OS . Will it be called OSXI   :D

Don't end 10.6 support anytime soon .. Then how will i run wine on my old pc :D
--
HM

#16 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 13 May 2012 - 01:00 AM

after 10.9 would be 10.10 and 10.11 and 10.12 .... but even if they went to "11.0" I don't think they'd stop using OS X.  They already dropped the Mac part off so the OS is just called "OS X" and its not really about X = 10 anymore.

#17 zoroaster

zoroaster

    Professional Member

  • Members
  • PipPipPipPip
  • 143 posts

Posted 15 May 2012 - 05:00 PM

View Postmwine, on 17 February 2012 - 07:26 PM, said:

Just read that X11 is not included by default (but you can install it) ...

This is no big problem as long as Apple continues to contribute to standards like X11. At least for the next release Xquartz development still goes on.

View PostwMin17, on 18 February 2012 - 04:27 AM, said:

Apple is just trying to create new operating systems for some filler....

View Posthmtinc, on 13 May 2012 - 12:37 AM, said:

...Then what will they call MAC OS .

View Postdoh123, on 13 May 2012 - 01:00 AM, said:

... They already dropped the Mac part off so the OS is just called "OS X" and its not really about X = 10 anymore.

No, maybe not: in about three years from now it could be called iOS 7 and then X11 support is the least problem ... :wacko:

View Postcluthz, on 12 May 2012 - 03:49 PM, said:

... This might change when 10.8 comes around, but I do prefer 10.6 over 10.7..

10.7 is the first step toward iOS. Maybe this is good maybe it is bad but overall it is more stable and faster then its predecessor. 10.8 will be even more like iOS so everybody has to accept this or use another OS in the near future. We will see but for now there is no need for panic.

#18 HiPhish

HiPhish

    Champion Member

  • Members
  • 697 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:Mac OS X 10.7 (Lion)
Author

Posted 15 May 2012 - 06:45 PM

As long as they just take the usability of iOS and don't remove functionality I don't see why people get so upset over this. I mean, has anyone's workflow changed because of Launchpad and multitouch gestures?
Games I own that still need porting:
Dark Messiah of Might & Magic, Descent 3, Fallout, Space Rangers 2

#19 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 15 May 2012 - 07:01 PM

The main idea people don't like... Isn't the interface as much as the functionality. Objc cocoa for everything only... iOS is a very limited system in many ways, not only that.

#20 agentgfunk

agentgfunk

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Intel HD Graphics 4000 384 MB
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 18 March 2013 - 02:24 PM

I can't get this one Rise of Nations Gold Program to work in Mountain Lion!!! It's really pissing me off I don't know what to do. It actually miraculously worked a couple times when I first got it I don't even know how it's possible for it to not work now. It says it's running off Wineskin 2.5.4 and then nothing starts!!! Someone please help me!!!

#21 ovvldc

ovvldc

    Master Member

  • Members
  • 1250 posts
  • LocationEurope
  • Graphics Card:Intel Iris Plus
  • Operating System:Other OS/Not specified
  • I like to play:stories

Posted 18 March 2013 - 05:23 PM

Update the wrapper. And make a new topic in the appropriate forum if you do not want to be viewed as a spambot.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users