Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

[REQ] ArmA II


  • Please log in to reply
48 replies to this topic

#31 moussaillon

moussaillon

    Professional Member

  • Members
  • PipPipPipPip
  • 171 posts

Posted 30 April 2012 - 11:10 PM

Btw Arma 3 should be released later this year. May the wrapper work for both :P

#32 fin109

fin109

    Regular Member

  • Members
  • Pip
  • 12 posts
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Many games.

Posted 30 April 2012 - 11:47 PM

Im honestly fine with a few bugs...

#33 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 01 May 2012 - 12:27 AM

Bugs: Crashes in about 5 minutes, lags like crazy, and textures are missing. Sounds like a fun time.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#34 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 01 May 2012 - 12:29 AM

Are there possible fixes for all of it?

#35 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 01 May 2012 - 02:43 AM

I've tried most of the appdb fixes with no real end of the tunnel for a fully working port.

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#36 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 01 May 2012 - 03:24 AM

hm, thats too bad. Oh well, there are lots of good fps games worth playing other than this one.

#37 GameGuy

GameGuy

    Legendary Member

  • Members
  • 2,127 posts
  • LocationCanada...Eh
  • Graphics Card:nVidia 9400m 256mb
    ATI Radeon HD 6950 2GB
    MSI N670GTX PW/OCE 2GB SLI
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:RPG, Racing, and of course FPS

Posted 01 May 2012 - 03:25 AM

Its a sim not an fps

Posted Image
Macbook Pro: Intel C2D 2.53ghz, 4GB Ram, Nvidia 9400m 256MB

Hackintosh: Intel i5-3570k, 16GB Ram, Asus Z77 Sabertooth, MSI GTX 670 Power Edition SLI
If my post helped you hit the like button :)


#38 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 01 May 2012 - 03:28 AM

oh, well excuse me. =P

#39 fin109

fin109

    Regular Member

  • Members
  • Pip
  • 12 posts
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Many games.

Posted 01 May 2012 - 11:50 AM

Oh well

#40 MaskedTurk

MaskedTurk

    Experienced Member

  • Members
  • PipPip
  • 30 posts
  • LocationEngland, UK
  • Graphics Card:[MBP]
    NVIDIA GeForce 9400M (256 MB)
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Strategy, Simulation, FPS... yeah, anything >_>

Posted 05 May 2012 - 03:03 PM

My only problem running this from Wineskin (2.5.5 1.5.3) is the mouse issue. Anyone know how to get around that one issue?

#41 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 05 May 2012 - 06:44 PM

when you say mouse issue, does that mean you could get into the game from the menu or not?

#42 fin109

fin109

    Regular Member

  • Members
  • Pip
  • 12 posts
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Many games.

Posted 06 May 2012 - 07:26 PM

It means when he clicks on something it does nothing.

#43 MaskedTurk

MaskedTurk

    Experienced Member

  • Members
  • PipPip
  • 30 posts
  • LocationEngland, UK
  • Graphics Card:[MBP]
    NVIDIA GeForce 9400M (256 MB)
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Strategy, Simulation, FPS... yeah, anything >_>

Posted 06 May 2012 - 09:28 PM

^ exactly that. Not sure how to get the wine patch to work via Wineskin either :/

#44 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 07 May 2012 - 10:37 PM

ah, well that was the exact problem I had.

#45 MaskedTurk

MaskedTurk

    Experienced Member

  • Members
  • PipPip
  • 30 posts
  • LocationEngland, UK
  • Graphics Card:[MBP]
    NVIDIA GeForce 9400M (256 MB)
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Strategy, Simulation, FPS... yeah, anything >_>

Posted 21 May 2012 - 07:44 PM

Ok so, I managed to build a Wine-1.5.1-rawinput engine. But then the game crashes straight after the loading bar; I don't even get to see the splash screen

This is what I seem to be getting when I run it from a wineprefix (not wineskin) using 1.5.1 with rawinput patch
Fontconfig error: "~/.fonts.conf", line 1: no element found
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Fontconfig error: "~/.fonts.conf", line 1: no element found
Fontconfig error: "~/.fonts.conf", line 1: no element found
Fontconfig error: "~/.fonts.conf", line 1: no element found
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16fee94, uiNumDevices=1, cbSize=12) stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16ff0f4, uiNumDevices=1, cbSize=12) stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x16ff4dc,0x00000000), stub!
fixme:ddraw:DirectDrawEnumerateExA flags 0x00000007 not handled
fixme:win:EnumDisplayDevicesW ((null),0,0x16fefbc,0x00000000), stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16fe9f0, uiNumDevices=1, cbSize=12) stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16fe9f4, uiNumDevices=1, cbSize=12) stub!
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x89ff68c, uiNumDevices=1, cbSize=12) stub!
fixme:coreaudio:get_channel_mask Unknown speaker configuration: 16
fixme:coreaudio:get_channel_mask Unknown speaker configuration: 16
fixme:coreaudio:AudioSessionControl_RegisterAudioSessionNotification (0x18e6d0)->(0x8a0bb7c) - stub
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0x9b0f5dc): stub
fixme:avrt:AvSetMmThreadPriority (0x12345678)->(1) stub
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16fe8c8, uiNumDevices=1, cbSize=12) stub!
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table
fixme:d3d9:surface_init Multisample quality set to 1, substituting 0.
fixme:d3d9:surface_init Multisample quality set to 1, substituting 0.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x28.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:query_init Unhandled query type 0x5.
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x16fe2a8, uiNumDevices=1, cbSize=12) stub!
[76158] <Error>: kCGErrorIllegalArgument: CGSGetWindowBounds
[76158] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
[76158] <Error>: kCGErrorIllegalArgument: CGSGetSurfaceBounds
[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
[76158] <Error>: kCGErrorIllegalArgument: CGSGetWindowBounds
[76158] <Error>: kCGErrorIllegalArgument: CGSGetSurfaceBounds
wine[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
wine[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
wine[76158] <Error>: kCGErrorIllegalArgument: CGSBindSurface: Invalid window 0x4b14
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNDEFINED (0x8219)
err:d3d:context_check_fbo_status FBO 0 is incomplete, driver bug?
err:d3d_draw:drawStridedFast >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glDrawArrays @ drawprim.c / 58
wine[76158] <Error>: kCGErrorIllegalArgument: CGSSetWindowSendExposed: Invalid window 0x4b14
error: xp_attach_gl_context returned: 2
X Error of failed request:  GLXBadCurrentWindow
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  11 (X_GLXSwapBuffers)
  Serial number of failed request:  1730
  Current serial number in output stream:  1730

Can anyone build/source a Wine 1.3.36/1.5.1 rawinput engine for us to use?

Or better yet, help make a custom engine that defo works? :(

#46 MaskedTurk

MaskedTurk

    Experienced Member

  • Members
  • PipPip
  • 30 posts
  • LocationEngland, UK
  • Graphics Card:[MBP]
    NVIDIA GeForce 9400M (256 MB)
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:Strategy, Simulation, FPS... yeah, anything >_>

Posted 22 May 2012 - 02:39 AM

Ok, huh. I tried building again and it worked this time round.

Pick up the Wine-1.5.1-rawinput engine here, and use it in a new wineskin wrapper.

# Install ArmA 2
# Do winetricks win7 strictdrawordering=enabled

Run arma2.exe (or arma2OA.exe etc.) with the EXE flags: -nosplash -cfg=config.cfg

Make sure you're running the most up-to-date version of the game you can. ArmA2 is 1.11, ArmA2:OpArrow is 1.60

--
Minor issue: when in game, the pan mouse seems to get stuck at the edges of the screen, meaning you can't look 360 degrees. Anyone know a fix for that?

#47 bloodfang42

bloodfang42

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • Locationin limbo
  • Graphics Card:NVIDIA GeForce 320M 256 MB graphics
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:almost anything.....except for puzzle games

Posted 23 May 2012 - 03:16 AM

great job for getting it to work. Could you explain how to use the rawinput engine?

EDIT: nevermind, figured it out. But whenever I test run the game, It doesn't do anything then the logs come up. They say something about a file called x3d audio 1_6 that the game requires to run. Any ideas on what to do?

EDITEDIT: alright, fixed that by reinstalling directx9 through winetricks. But now, the game crashes when I try to run it. The 1.5.4 engine works, but the mouse issue isn't fixed so I can't get past the main menu.

#48 hixhax67

hixhax67

    Lurker

  • Members
  • 4 posts
  • Graphics Card:ATI Radeon 2600 Pro
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:EVERYTHING!!!

Posted 17 June 2012 - 02:39 PM

hey, now that we've got it working, can we figure out how to get DayZ working on it?

#49 hixhax67

hixhax67

    Lurker

  • Members
  • 4 posts
  • Graphics Card:ATI Radeon 2600 Pro
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:EVERYTHING!!!

Posted 17 June 2012 - 05:18 PM

actually I got it working on winetricks steam, but its stuck at initial launch




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users