Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Richard Burns Rally - Freak Graphics Glitch!


  • Please log in to reply
15 replies to this topic

#1 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 06 May 2012 - 10:22 PM

I'm guessing most of you haven't heard of this game, but it's easily the best rally sim out there. It came out in 2004, but the community has continued to produce mods that bring the visuals up to todays standards. If you're a fan of realistic driving games, you need to play this game! It's pretty hard to play with just the keyboard, it's really designed to be played with a wheel!

The game works really well, however, about 2 minutes into a race, the game stops drawing major scenery objects such as trees and buildings.

This is evidently a common problem with running RBR in Wine, some of the test results on AppDB report this same problem. For some people, setting "UseGLSL" to "disabled" is the registry editor fixes this problem, but for others (me included) it doesn't.

Strangely, if I set "VertexShaderMode" to "none" in the RegEdit, the graphics for the skybox and the car are messed up (black or invisible), yet the original graphical problem with the scenery disappearing doesn't occur.

I've tested the game in Wineskin (with all engines 1.1.5 through 1.5.3), Crossover and CXEx, and the same bug occurs in each. I'm running OS X 10.6.8 and I have a Nvidia GeForce 320M graphics card.

I'm only running the demo at the moment, for testing purposes, I will buy the full game at some point, even if I can't get this problem sorted. The demo can be grabbed HERE

Some screens of the bug occurin'

The start of the race looks just fine:
Posted Image

Yes, I do suck at this game!
Posted Image

The scenery just disappears! Notice the lack of trees. You can still crash into them, they're just invisible!
Posted Image
Apart from that, the only other issue is that replay mode freezes the game after about 5 seconds.

A video of this game running on a PC with the latest graphics mod. This is a proper rally game!


I can easily post the Wineskin error log if it's needed, I wasn't sure wether it would help, as this isn't a problem with the game freezing or crashing.

#2 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 06 May 2012 - 10:25 PM

I'll take a look at it.
Got nvidia and 10.6.8 here too to test on, so if it works here I guess that it will work for you too

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#3 thedoc

thedoc

    Administration Team

  • Administrators
  • 1311 posts
  • Graphics Card:nVidia GeForce 9600M GT - 512 MB RAM
  • Operating System:Mac OS X 10.5 (Leopard)
  • I like to play:FPS, RPG, Racing

Posted 06 May 2012 - 10:28 PM

sadly this bug is driver related and seems to affect nVidia users mostly (where the GLSL trick doesn't seem to work) - graphics driver issues are pretty much impossible to fix since they work on MacOS level.
Posted Image

Check out my Porting Blog @ Doc's Office


#4 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 06 May 2012 - 10:40 PM

View Postcluthz, on 06 May 2012 - 10:25 PM, said:

I'll take a look at it.
Got nvidia and 10.6.8 here too to test on, so if it works here I guess that it will work for you too

Cheers man, that would be great.

View Postthedoctor45, on 06 May 2012 - 10:28 PM, said:

sadly this bug is driver related and seems to affect nVidia users mostly (where the GLSL trick doesn't seem to work) - graphics driver issues are pretty much impossible to fix since they work on MacOS level.

I was hoping this wouldn't be the case...

#5 Blinx 007

Blinx 007

    Master Member

  • Members
  • 1351 posts
  • Graphics Card:Nivida
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:FPS RPG 3rd Person & Horror Games

Posted 06 May 2012 - 11:06 PM

i heard of this game its fun i use to play it when i was 6 this was the game!

#6 Blinx 007

Blinx 007

    Master Member

  • Members
  • 1351 posts
  • Graphics Card:Nivida
  • Operating System:Mac OS X 10.7 (Lion)
  • I like to play:FPS RPG 3rd Person & Horror Games

Posted 06 May 2012 - 11:07 PM

Try installing dx9 ddl in wine tricks looks like a graphical shader issue

#7 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 06 May 2012 - 11:13 PM

Ok, I did get the game to run in cider, but same issues.
Disabling GLSL doesn't work, different FBO settings and pixels/vertex shaders doesn't work either.
(did try a few different engines too)
I read thru the wineHQ bug, and seems it affect all nvidia cards, on all wine versions too, I was just hoping cider would work..

After a quick google search people did also have this issue on windows.

I think thedoc is spot on (he usually is), and we cannot fix this :(

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#8 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 06 May 2012 - 11:51 PM

Darn.

Is this something that could be potentially fixed in a future Wine version, or do you think the drivers are simply incompatible?

Also, is it possible that the RSRBR mod would fix this? It seems to be a major overhaul of the game's graphics and content, and presumably such a large-scale mod would address bugs experienced by Windows users, especially as it's as widespread as everyone with an Nvidia card!

View Postblinxfrost, on 06 May 2012 - 11:07 PM, said:

Try installing dx9 ddl in wine tricks looks like a graphical shader issue

By the way Blinx, it's DLL, not DDL. I noticed you always spell it wrong, just sayin'! :P It stands for dynamic link library.

#9 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 07 May 2012 - 12:13 AM

As the issue is also happening in Cider, (tried 4 different engines, from the 1k, 2k, 4, and 5k series all same results)
i doubt it will be fixed.

The issue is not with wine as it works on AMD/ATI, but only on nvidia.

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#10 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 08 May 2012 - 08:38 PM

Excuse my ignorance as to how these things work...

Would it be possible to apply vertex shader support to certain objects within the game, and disable it for others? When I change Vertex Shader Support from 'hardware' to 'none' in Winecfg, the car turns invisible, the skybox disappears, and the road is the wrong colour, however, the problem with the trees disappearing goes away! That made me think, if there was a way of disabling vertex shader support for just the trees,buildings and spectators, but enable it for the cars, the trees and the skybox, the bug would be fixed!

This is just a dumb theory, but could it be possible?

This is how the game looks with vertex shader support turned off. Note the trees and other objects that were disappearing look fine.
Posted Image

#11 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 08 May 2012 - 09:47 PM

That would not be possible.

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG


#12 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 08 May 2012 - 10:38 PM

Confound these games! They drive me to PCs!

#13 emash

emash

    Novice Member

  • Members
  • 6 posts

Posted 10 November 2012 - 03:08 PM

i have the same problem using "universal wrapper", is it possible to develop another wrapper, just to test the game in different versions of cider and wine, maybe a properly working configuration can be found.

#14 swipe_

swipe_

    Lurker

  • Members
  • 1 posts
  • Graphics Card:NVIDIA 9400M 256MB w/ NVIDIA 9600M GT 512MB (Discrete)
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 15 January 2013 - 11:38 PM

anyone got this working with nvidia cards? or tried to see if applying mods helped at all. such as RSRBR 09-13

#15 nismology

nismology

    Advanced Member

  • Members
  • PipPipPip
  • 94 posts
  • LocationUK
  • Graphics Card:NVIDIA GeForce 320M
  • Operating System:Mac OS X 10.6 (Snow Leopard)
  • I like to play:Racing games, first person shooters, platformers, old/retro games.

Posted 17 October 2014 - 11:49 PM

Just an update...

I upgraded to OS X 10.10 Yosemite today, and tried playing RBR...

The problem has vanished! The game now works perfectly!

#16 cluthz

cluthz

    Senior Hall monitor!

  • Super Forum Moderators
  • 2836 posts
  • LocationNorway
  • Graphics Card:Nvidia GTX780 GHz Edition
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 19 October 2014 - 09:52 PM

View Postnismology, on 17 October 2014 - 11:49 PM, said:

Just an update...

I upgraded to OS X 10.10 Yosemite today, and tried playing RBR...

The problem has vanished! The game now works perfectly!

Great news!

[HackPro i7-4790K, 3x SSD + 5TB HDD • 16GB RAM • NVidia GTX 780 GHz Edition • OSX 10.10] . [MacBookAir 13 1.7GHz • Intel HD 3000 • OSX 10.9.5]


How to port Steam games .... My Youtube Porting videos ... Play my RPG





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users