Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Anno 1404


  • Please log in to reply
23 replies to this topic

#1 Guest_moncul111_*

Guest_moncul111_*
  • Guests

Posted 25 July 2009 - 11:04 AM

hey guy's ,i will try porting Anno 1404 .....

any advices would be great

thanks ....

#2 MWest

MWest

    Rookie Porter

  • Members
  • PipPip
  • 46 posts
  • LocationSouth Coast England

Posted 25 July 2009 - 11:09 AM

I had a go at this. couldn't get it to port properly.

I have it running under wine 1.1.26 but it's a little choppy.

Good luck with it though.
West

#3 Guest_termsandconditions_*

Guest_termsandconditions_*
  • Guests

Posted 25 November 2009 - 12:16 PM

performance is really bad in my vm..looking forward to the port

#4 Taeki

Taeki

    Currently on vacation

  • Members
  • 568 posts
  • LocationGermany
  • Graphics Card:ATi 4850 (512MB)
  • Operating System:Mac OS X 10.6 (Snow Leopard)

Posted 25 November 2009 - 12:35 PM

termsandconditions said:

performance is really bad in my vm..looking forward to the port

Anno 1404 is already ported  :twisted:

#5 Guest_arvean_*

Guest_arvean_*
  • Guests

Posted 13 December 2009 - 12:49 AM

it is??? where?

#6 Taeki

Taeki

    Currently on vacation

  • Members
  • 568 posts
  • LocationGermany
  • Graphics Card:ATi 4850 (512MB)
  • Operating System:Mac OS X 10.6 (Snow Leopard)

Posted 13 December 2009 - 12:56 AM

arvean said:

it is??? where?
viewtopic.php?f=47&t=1404  :wink:

#7 Guest_websee_*

Guest_websee_*
  • Guests

Posted 06 February 2010 - 11:06 PM

hmm, it crashes for me every time i try to build a warehouse in continous mode

ah, im using the dvd version, patch 1.1
with the cider wrapper from freaky creatures

#8 Guest_vantiago_*

Guest_vantiago_*
  • Guests

Posted 14 February 2010 - 11:16 PM

has this been fixed or still a problem?

#9 noname

noname

    Regular Member

  • Members
  • Pip
  • 10 posts
  • LocationCroatia

Posted 24 February 2010 - 11:11 AM

I cant wait for this to come out from Blue Byte, they wrote somewhere they'll make a Mac version

#10 Guest_TheProtagonist_*

Guest_TheProtagonist_*
  • Guests

Posted 30 March 2010 - 01:53 PM

Anno runs at my Mac, it doesn't crashes
but the framerate is low, but it's playable.

#11 dramaties

dramaties

    Experienced Member

  • Members
  • PipPip
  • 20 posts

Posted 01 April 2010 - 01:02 PM

It's really slow for me too, but i like the game too much to just quit the game... It's a lotta fun! I don't have those crashes either, what mac do you have?

#12 Guest_deanoncens_*

Guest_deanoncens_*
  • Guests

Posted 17 August 2010 - 11:23 AM

Anno runs here too, it's a bit slow but playable

#13 hotsix

hotsix

    Regular Member

  • Members
  • Pip
  • 19 posts

Posted 27 October 2011 - 10:34 PM

I've created a new wrapper based on a modified 5413 Cider-Engine (mixed with 66xx & 71xx):

- Lion 10.7.2 compatible
- now full DirectX 10 support
- perfect 3.0 shader support
- great performance increase over previous ports (graphics, loading time, overall)
- individual icon and splash screen
- updater disabled

Runs perfectly well on my MacPro Radeon HD 6870 with highest settings, 4xAA, 8xAF and all shaders enabled.

I'll upload it on request.

#14 leamree

leamree

    Novice Member

  • Members
  • 5 posts

Posted 29 October 2011 - 01:05 AM

This is the best game ever

#15 TheTuKays

TheTuKays

    Professional Member

  • Members
  • PipPipPipPip
  • 112 posts
  • Graphics Card:ati
  • Operating System:Other OS/Not specified

Posted 30 October 2011 - 09:29 AM

hotsix said:

I've created a new wrapper based on a modified 5413 Cider-Engine (mixed with 66xx & 71xx):

- Lion 10.7.2 compatible
- now full DirectX 10 support
- perfect 3.0 shader support
- great performance increase over previous ports (graphics, loading time, overall)
- individual icon and splash screen
- updater disabled

Runs perfectly well on my MacPro Radeon HD 6870 with highest settings, 4xAA, 8xAF and all shaders enabled.

I'll upload it on request.
now that'd be totally awesome... please share!

#16 hotsix

hotsix

    Regular Member

  • Members
  • Pip
  • 19 posts

Posted 02 November 2011 - 07:55 AM

Meanwhile I've created a new wrapper - this one is based on Cider Engine 6357 7081 with some mods. The game works 100% with all graphic features available, full shader support, Lion 10.7.x compatible and runs VERY fast (approx. 2x faster than with 6357) ^^

Added a nice splash screen, icon and a short read me file.

Get the updated (V2 = SDL fix & size optimized) wrappers here:

Megaupload: Anno 1404 (7081) Wrapperv2.zip (~17MB)

RapidShare: Anno 1404 (7081) Wrapperv2.zip (~17MB)

Have fun ^^

#17 emash

emash

    Novice Member

  • Members
  • 6 posts

Posted 12 November 2011 - 03:55 PM

Thanks a lot, keep up the good work!

#18 grampman

grampman

    Lurker

  • Members
  • 1 posts

Posted 14 November 2011 - 09:03 PM

Hi there.
First I would like to thank you for your effort. Unfortunately the wrapper quits right after activation of the App. I copied a working Parallels installation into the wrapper but as mentioned it jumps in the dock 2 times then quits.

I'm using a MBPro, 10.7.2.

Any suggestions what to do now?  :Search:

Sorry for my english I'm from germany.  :Rose:

#19 hotsix

hotsix

    Regular Member

  • Members
  • Pip
  • 19 posts

Posted 25 November 2011 - 11:06 AM

grampman said:

Hi there.
First I would like to thank you for your effort. Unfortunately the wrapper quits right after activation of the App. I copied a working Parallels installation into the wrapper but as mentioned it jumps in the dock 2 times then quits.

I'm using a MBPro, 10.7.2.

Any suggestions what to do now?  :Search:

Sorry for my english I'm from germany.  :Rose:

Did you copy it to the right path?

Must be: c_drive/Program Files/ANNO 1404

Some installations have a different path.

#20 lixxbox

lixxbox

    Lurker

  • Members
  • 3 posts
  • Graphics Card:NVIDIA
  • Operating System:Other OS/Not specified

Posted 11 December 2011 - 12:34 PM

Same problem like grampman.

Anno icon pops up and closes immediately.

Console tells me:
11.12.11 13:27:54,229 cider: TransformProcessType failed! Err: -50
11.12.11 13:27:54,787 com.apple.launchd.peruser.501: ([0x0-0x1e41e4].com.transgaming.anno1404[4746]) Exited with code: 14

The files are in the right folder, which is named "ANNO 1404".

The game works great with the port mentioned in the other thread. I would prefer your port, because of performance increases (MB Air user) ;-)

Edit: I'm also on OSX Lion 10.7.2

#21 Frantz08

Frantz08

    Lurker

  • Members
  • 4 posts

Posted 14 December 2011 - 01:12 PM

I've the same problem, the game start up and it closes immediately.
If i try with the older wrapper appear a window about a patching of freaky creatures (i never heard about it) and appears a black window with a blue flashing cursor until i force-shut down the mac.
I've a macbook pro 15" mid 2010 with Lion 10.7.2

#22 petermaffai

petermaffai

    Lurker

  • Members
  • 1 posts
  • Graphics Card:Intel HD Graphics 3000 384 MB
  • Operating System:Mac OS X 10.7 (Lion)

Posted 02 January 2012 - 04:33 PM

any new results?

#23 dornbrooknd

dornbrooknd

    Lurker

  • Members
  • 1 posts
  • Graphics Card:NVidea GeForce 8800
  • Operating System:Mac OS X 10.7 (Lion)

Posted 10 August 2012 - 10:24 AM

Hey, guys.

I've got 7081 downloaded and am working on the plist.info file to make the changes to get Anno1404.exe working with 7081.

What, in general, needs to be done?

I've modified CedegaGameDir and CedegaGameName. This is obviously not enough.

All of the general tutorials for creating wrappers seem to have been taken down or disappeared, and if anyone has one that would be helpful.

#24 Argon

Argon

    Lurker

  • Members
  • 3 posts

Posted 18 June 2014 - 03:38 PM

Is there a chance for a reupload? I've got a wrapper myself but it flickers :/
Unfortunately there's no other Anno port in the database.

edit// ok it seems it runs basically oob with the current wineskin wrapper.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users