Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Wineskin 2.5.6 – Cannot Disable CPU Cores within Wine (On Mac)


  • Please log in to reply
2 replies to this topic

#1 SAHunterMech

SAHunterMech

    Experienced Member

  • Members
  • PipPip
  • 24 posts
  • Graphics Card:AMD Radeon HD
  • Operating System:Other OS/Not specified
  • I like to play:Thief, Dark Forces 1/2, Mirror's Edge, Riven, Total Annihilation, Mega Man Legends

Posted 17 September 2012 - 09:03 PM

Recently, I made wrappers for Thief 1 and 2, some very old and buggy PC games from 1999/2000. During the building of these wrappers, I noticed a problem in Wine.

Both of these games run on the 'Dark Engine', and this game engine has a glitch where if you're playing a game with more than one CPU Core enabled, the game will freeze after 1-5 minutes of gameplay. As you know, Wine has a setting, 'Disable all CPU Cores except for 1'. However, with this setting enabled, the freezing glitch still happened with my wrappers.

(The only way I was able to successfully disable cores is with an XCode tool, 'CPUPalette.app'. After turning off all cores but one in that app, the freezing stopped.)

Still being relatively new here, I am unsure if this bug in Wine has already been adressed (I searched up and down before posting)...

#2 doh123

doh123

    Wineskin Developer

  • Members
  • 4279 posts
  • LocationOver here
  • Graphics Card:Geforce GT 650M, Intel HD 4000, Radeon 6750, Intel HD 3000, Geforce 320m (in 3 machines)
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:RPG and Strategy

Posted 17 September 2012 - 09:38 PM

yeah, the option doesn't work on your machine unless you have the hwprefs command line utility available... so by default it doesn't work on most machines.

#3 julus

julus

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 261 posts
  • LocationSlovakia
  • Graphics Card:AMD Radeon 6750M
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:MMORPG, Adventure, RPG, Strategy
Author

Posted 20 September 2012 - 06:51 PM

View PostSAHunterMech, on 17 September 2012 - 09:03 PM, said:

Recently, I made wrappers for Thief 1 and 2, some very old and buggy PC games from 1999/2000. During the building of these wrappers, I noticed a problem in Wine.

Both of these games run on the 'Dark Engine', and this game engine has a glitch where if you're playing a game with more than one CPU Core enabled, the game will freeze after 1-5 minutes of gameplay. As you know, Wine has a setting, 'Disable all CPU Cores except for 1'. However, with this setting enabled, the freezing glitch still happened with my wrappers.

(The only way I was able to successfully disable cores is with an XCode tool, 'CPUPalette.app'. After turning off all cores but one in that app, the freezing stopped.)

Still being relatively new here, I am unsure if this bug in Wine has already been adressed (I searched up and down before posting)...

There is a workaround, in Instruments in Xcode package, you can set the number of used CPU beforehand, but it does not really help. Titan Quest has this problem also - if running on multicore, it will freeze in 30 minutes... Setting to 1 CPU via instruments didn't helped the game, and only 1 cpu was detected (so the instruments set it correctly)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users