Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

CrossOver (CX) Ports and Snow Leopard


  • Please log in to reply
61 replies to this topic

#31 versilia

versilia

    Lurker

  • Members
  • 4 posts

Posted 23 December 2009 - 07:21 PM

CSI-Hard Evidence wrapped with CrossOver Games 8.1.0 runs splendidly on my iMac 24" 2.93 Ghz graphic card ATI Radeon HD 4850 with snow leopard (10.6.2). I hadn't the least problem from the beginning to the end.

#32 Coogie7

Coogie7

    Professional Member

  • Members
  • PipPipPipPip
  • 133 posts
  • LocationNeverland
  • Graphics Card:NVIDIA 9400m
    2.4 GHz Intel Core 2 Duo
    8 GB 1067 MHz DDR3
  • Operating System:OS X 10.8 (Mountain Lion)
  • I like to play:Everything, but especially FPS, ie. COD MW3.

Posted 28 December 2009 - 04:35 AM

versilia said:

CSI-Hard Evidence wrapped with CrossOver Games 8.1.0 runs splendidly on my iMac 24" 2.93 Ghz graphic card ATI Radeon HD 4850 with snow leopard (10.6.2). I hadn't the least problem from the beginning to the end.

That's because the CSI 4 Hard Evidence wrapper (for snow leopard users) is the CSI 3 Las Vegas wrapper with a small modification to the info.plist. The CSI 3 Las Vegas wrapper is a CXskin, which currently are working with snow leopard.

-nice try, but you haven't found any secret way to solve all of the snow leopard compatibility issues that so many experienced porters haven't been able to fix
Posted Image

Please do not redistribute or mirror my ports/wrappers on other websites without my permission.

#33 Guest_kalidem_*

Guest_kalidem_*
  • Guests

Posted 31 December 2009 - 10:13 AM

good post !!

#34 Guest_zephyroth_*

Guest_zephyroth_*
  • Guests

Posted 31 December 2009 - 12:06 PM

The solution provided here works for Torchlight but not for Call Of Duty Modern Warfare 2.
With or without this fix all I have is a black screen with sound. Blindly navigating into the game only show artifacts, no textures ....
At least it's the beginning of a solution !

#35 Guest_manzaxl_*

Guest_manzaxl_*
  • Guests

Posted 08 January 2010 - 02:46 AM

thx for the info

#36 Guest_rezecib_*

Guest_rezecib_*
  • Guests

Posted 10 January 2010 - 10:42 PM

Hansi, what exactly is this "5 minute" process that you hinted at? If that process is explained in a simple way, perhaps posted at a high level, I'm guessing the wrapper update process could be crowdsourced. I'd be willing to help, as I have several games I never got around to playing that were ported with older CX wrappers left over from the backup of my previous computer (which died).

#37 Guest_sbredflag_*

Guest_sbredflag_*
  • Guests

Posted 12 February 2010 - 05:15 PM

Thanks a lot for the fix, thedoctor45

#38 Guest_sbredflag_*

Guest_sbredflag_*
  • Guests

Posted 12 February 2010 - 05:17 PM

Sorry for the double post, I don't see an edit button, but the link for ScriptEditor is broken, fyi.

#39 Guest_andybrandy_*

Guest_andybrandy_*
  • Guests

Posted 18 February 2010 - 10:11 PM

thanks for all the info - i will try this an a game...

#40 Guest_TehMaster_*

Guest_TehMaster_*
  • Guests

Posted 20 February 2010 - 10:38 PM

Thanks for the info on the temp fix. Any news on the progress being made towards full snow leopard support?

#41 devilhunter

devilhunter

    just dancing to the beat

  • Administrators
  • 3051 posts
  • LocationSpace/Virgo Supercluster/Milky Way/Orion Arm/Earth
  • Graphics Card:NVIDIA 9800 GTX+
  • Operating System:Mac OS X 10.6 (Snow Leopard)
Author

Posted 20 February 2010 - 11:00 PM

TehMaster said:

Thanks for the info on the temp fix. Any news on the progress being made towards full snow leopard support?

Moving every CX Port by hand to CXZ/Wineskin is the only solution.
Hello. Sadly, I am not active here on the Porting Team anymore, and therefore I cannot give support or answer questions to any of my posted Ports or posted topics.

- zero

#42 Guest_MacGamer_*

Guest_MacGamer_*
  • Guests

Posted 25 February 2010 - 04:45 AM

That sounds like it would take awhile.

#43 huloi

huloi

    Lurker

  • Members
  • 3 posts

Posted 03 March 2010 - 06:22 PM

Thanks! This is a great post!

#44 huloi

huloi

    Lurker

  • Members
  • 3 posts

Posted 03 March 2010 - 06:22 PM

Question: Is the new CrossOver 9 resolve the problem?

#45 devilhunter

devilhunter

    just dancing to the beat

  • Administrators
  • 3051 posts
  • LocationSpace/Virgo Supercluster/Milky Way/Orion Arm/Earth
  • Graphics Card:NVIDIA 9800 GTX+
  • Operating System:Mac OS X 10.6 (Snow Leopard)
Author

Posted 03 March 2010 - 06:26 PM

huloi said:

Question: Is the new CrossOver 9 resolve the problem?

Read 3 posts upwards.
Hello. Sadly, I am not active here on the Porting Team anymore, and therefore I cannot give support or answer questions to any of my posted Ports or posted topics.

- zero

#46 gumbyx84

gumbyx84

    Regular Member

  • Members
  • Pip
  • 13 posts

Posted 04 March 2010 - 04:30 PM

devilhunter said:

TehMaster said:

Thanks for the info on the temp fix. Any news on the progress being made towards full snow leopard support?

Moving every CX Port by hand to CXZ/Wineskin is the only solution.

Ew.. That doesn't sound like fun work. Take your time. I found this place randomly and I have to say its a great resource. Here's hoping the release of CX9 will help this along.

#47 Guest_Lvnsuede16_*

Guest_Lvnsuede16_*
  • Guests

Posted 06 March 2010 - 10:18 PM

SL is better and an amazingly cheap upgrade from Tiger

#48 dankoB

dankoB

    Legendary Member

  • Super Moderators
  • 3011 posts
  • LocationNew Brunswick, Canada
  • Graphics Card:MacBook Pro 11,3
    Core i7 16GB
    NVIDIA GeForce GT 750M
    2GB GDDR5 vRAM
  • Operating System:macOS 10.12 (Sierra)
  • I like to play:la rockitar
Author

Posted 11 March 2010 - 02:41 AM

I'm game, I've actually already done Clive Barker's Undying and indeed it did only take 5 minutes, It can be found at BrSt for now, but I'll upload it soon and post here.

#49 Guest_RafaelGPinto_*

Guest_RafaelGPinto_*
  • Guests

Posted 13 March 2010 - 02:15 PM

thanks for the info.

#50 willhopper

willhopper

    Lurker

  • Members
  • 3 posts

Posted 13 March 2010 - 04:37 PM

Thanks for the info.  On the Brightside we can move from CX which i never liked anyway. Too bad about all the effort it takes.

#51 Guest_TrapperJ_*

Guest_TrapperJ_*
  • Guests

Posted 15 March 2010 - 07:39 PM

the link for script editor broke, is there another place I can get it?

#52 MaxMaven

MaxMaven

    Regular Member

  • Members
  • Pip
  • 10 posts

Posted 18 March 2010 - 11:40 PM

Finally! I have been looking a while to find a temp fix for the problem, thank you so much!

Now...whats next on my list of things that 10.6.2 broke? ;)

#53 Guest_skruug_*

Guest_skruug_*
  • Guests

Posted 25 March 2010 - 08:02 PM

thanks, this article helps a lot

#54 Guest_mitchde_*

Guest_mitchde_*
  • Guests

Posted 15 April 2010 - 08:16 AM

Hi, within the time the xforge team developed the Xquartz (X11) further.
Does the lastest 2.5.0 RC2 or 2.5.1 Beta 1 change anything with that SL Problem + CX ?

SL Versions of X11:
http://static.macosf...z/downloads/SL/

#55 wallspaper

wallspaper

    Experienced Member

  • Members
  • PipPip
  • 37 posts
  • Graphics Card:AMD Radeon HD 6750M 512 MB
    Intel HD Graphics 3000
  • Operating System:OS X 10.8 (Mountain Lion)

Posted 04 May 2010 - 04:34 AM

thanks for the tips

#56 Guest_ultimate3_*

Guest_ultimate3_*
  • Guests

Posted 16 May 2010 - 03:42 AM

Hello everyone, I might need a little bit here:
When I Type: sudo mv quartz-wm quartz-wm.bak
Terminal says
mv: quartz-wm: No such file or directory

Any ways to fix this? I m guessing that's because of this that the game PURE won't work on my mac.

#57 Guest_JJJohnson_*

Guest_JJJohnson_*
  • Guests

Posted 16 May 2010 - 04:31 PM

Thanks for the info!

#58 Reboot

Reboot

    I am Darkstar

  • Database Moderators
  • 2381 posts
  • Graphics Card:Nvidia EVGA GTX 980 SC 4GB
  • Operating System:OS X 10.9 (Mavericks)
Author

Posted 10 July 2010 - 04:35 AM

Snow Leopard is faster than Leopard. I already upgraded.

Thank you for info!

Posted Image


~ ~ ~ Hackintosh Spec ~ ~ ~

Intel Core i5-3570K 4.20GHz -- Patriot Viper Xtreme 8GB DDR3 1600MHz -- Nvidia EVGA GTX 980 4GB VRAM GDDR5 SC


#59 bobthedeadly

bobthedeadly

    Rookie Porter

  • Members
  • PipPip
  • 45 posts

Posted 14 July 2010 - 12:31 AM

mknox said:

instead of the applescript mentioned above you could also use the one i posted over at insanlymac:
set desktoppath to "/"
set spotlightquery to "\"kMDItemFSName == 'CX Pro Wrapper 8.0.app\""
set command to "mdfind -onlyin " & desktoppath & " " & spotlightquery
set founditems to paragraphs of (do shell script command)
set the input to the result as Unicode text
set the result to ""
set nextPart to ""
on urlToPOSIXPath(theURL)
	return do shell script "python -c \"import urllib, urlparse, sys; print urllib.unquote(urlparse.urlparse(sys.argv[1])[2])\" " & quoted form of theURL
end urlToPOSIXPath
to searchReplace(thisText, searchTerm, replacement)
	set AppleScript's text item delimiters to searchTerm
	set thisText to thisText's text items
	set AppleScript's text item delimiters to replacement
	set thisText to "" & thisText
	set AppleScript's text item delimiters to {""}
	return thisText
end searchReplace
set the_url to input
set value to searchReplace(urlToPOSIXPath(the_url), "/Macintosh HD", "")
set new_value to searchReplace(value, " ", "\\ ")
set nextPart to the result
do shell script ("VERSIONER_PERL_PREFER_32_BIT=yes " & nextPart & "/Contents/MacOS/CrossOver\\ Chromium") as Unicode text

replacing the "CX Pro Wrapper 8.0.app" bit with the name of your wrapper.

This is better in my opinion because it lets you move the game into a different location without changing the applescript.

I am very new at this. I don't really know what a lot of this stuff does, but I just tried it and nothing happened. I suspect that I am doing it wrong.

I copied that entire script into the AppleScript Editor, changed "CX Pro Wrapper 8.0.app" to "Sniper - Art of Victory.app" (which is the game I am trying to play) and pressed "Run". It said "Running Script" and then "" and nothing is happening. I suspect there are more steps that I am not doing correctly. Could you or someone help please?

#60 Guest_mtx_*

Guest_mtx_*
  • Guests

Posted 16 July 2010 - 02:07 AM

I was wondering why these games weren't working on my new built hackintosh. Thanks for the info!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users