Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

[HELP] DRIV3R cider error


  • Please log in to reply
13 replies to this topic

#1 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 22 April 2009 - 09:35 PM

I've started to port the awesome game DRIV3R - or Driver 3. It loads, I see the first video clips but when in come to load the profile (which you have to do to start the game) it give the following error:
Posted Image

Unhandled page fault on read access to 0x0000005c at address 0x005c8bd3.
Do you wish to debug it?


You guys got any idea what i can do? I'd love to get this game ported! I've used version 2289 and 2079.
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#2 loco

loco

    PortingTeam Founder

  • Administrators
  • 1186 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:macOS 10.12 (Sierra)

Posted 22 April 2009 - 09:53 PM

Moving this to the gaming help section :P You got me worried there, thought you found an error with the site!


Also, did the game even start with cider version 2289? I thought only 2097 and earlier works. Also a pastebin of the terminal output would help us help you.

Follow us on facebook:



#3 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 23 April 2009 - 06:09 AM

Sorry - it wasn't 2289 - It was an older version (near 1200) that i'd accidentally miss-numbered

Same problem with both.

http://pastebin.com/f17499f56
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#4 slacker

slacker

    Veteran Member

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Operating System:Other OS/Not specified

Posted 24 April 2009 - 10:47 AM

what kind of mac are you on
Posted Image

#5 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 26 April 2009 - 12:36 AM

I'm on the old style GMA950 macbook. I'm going to try it on an X3100 and report back.
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#6 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 28 April 2009 - 04:35 AM

I tried it on an X3100 and had the same problems. I can only think it's trying to access some save games that are saved someplace else. Does anyone have any ideas where or what i can try after looking after the report?

Thanks :)
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#7 loco

loco

    PortingTeam Founder

  • Administrators
  • 1186 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:macOS 10.12 (Sierra)

Posted 28 April 2009 - 07:02 AM

The equivalent my documents is at Contents/Resources/Preferences/p_drive/All  Users/Application Data

Follow us on facebook:



#8 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 28 April 2009 - 09:02 AM

Hmm... I must be running off an older version - I have no P Drive!

It sees my saved games that i made on Windows... so it must be saving that someplace... Thanks for the help so far!

I'll have a go with a fresh 2097. Wish me luck ;)
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#9 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 28 April 2009 - 09:33 AM

Tried with 2097 and game launched. Got to same place of loading profile then it asked to debug then died. Here's the terminal print out:


I'd have a go using the crossOver wrapper - but i can't seem to find a tutorial.... any help? (sorry if it's plain and obvious....I have looked)

http://pastebin.com/f162e03a6
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#10 loco

loco

    PortingTeam Founder

  • Administrators
  • 1186 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:macOS 10.12 (Sierra)

Posted 28 April 2009 - 02:03 PM

Tutorial: http://game.ibrain.c... ... r-wrapper/
Wrapper: http://game.ibrain.c... ... s-wrapper/
and a wrapper with video guide: http://game.ibrain.c... ... -tutorial/


Enjoy

Follow us on facebook:



#11 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 01 May 2009 - 03:17 AM

Thanks for that help and the links!

I had a good with the Crossover Wrapper but came up with these errors - less of the game loaded than when I used cider.

http://pastebin.com/d722da0d  Terminal output.


Should i just give up with Driver 3?
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob

#12 applecider

applecider

    Regular Member

  • Members
  • Pip
  • 12 posts

Posted 18 May 2009 - 09:37 PM

Try using cider wrappers 1835 and 1940 to see if it works any better/different.

#13 loco

loco

    PortingTeam Founder

  • Administrators
  • 1186 posts
  • Graphics Card:NVIDIA GeForce 9400M
  • Operating System:macOS 10.12 (Sierra)

Posted 18 May 2009 - 10:26 PM

If nothing else works and you think you've tried everything maybe we just need to say its unportable...

Follow us on facebook:



#14 jimjimjimbob

jimjimjimbob

    Abandoned

  • Members
  • PipPipPipPipPip
  • 424 posts
  • LocationUK
  • Operating System:Other OS/Not specified

Posted 20 June 2009 - 11:14 PM

I tried again one last time and unfortunately I've given up until the version 8 CrossOver comes out.  No point wasting hours and hours on one game that wont work when you could spend that porting 5-6 good games that do work great
Hello. Sadly i'm not active here on the Porting Team anymore, and therefore i cannot give support or answer questions to any of my posted Ports.

- jimjimjimbob




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users