Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Gcenx

Member Since 10 Aug 2014
Offline Last Active Private
*****

Posts I've Made

In Topic: Far cry 3 cracshes on loading screen

18 October 2019 - 02:52 PM

Winehq appdb shows Wine-3.7 as platinum for El Capitan.

You can repackage the Winehq portable release into an Engine or swap to Unofficial Wineskin for the built in Engine repacking feature.

In Topic: Wineskin and MacOS Catalina

17 October 2019 - 05:38 PM

I’ve explained this before in the release thread, Reddit, GitHub and PortingKit blog post via PaulTheTall. I’ve even gone as far as editing Winehq macOS sections and asked a mod to pin an information thread and edit another to indicate 10.8 > 10.14 support only.

Unofficial Wineskin and all of its components are 64Bit bar WSGamma due to the lack of source.

Wineskin Engines are Wine, meaning if Wine doesn’t work on on macOS Catalina, only CrossOver19 when launched will function on macOS Catalina and I don’t plan on building that on day one.


If you require these wrappers you can ether downgrade to macOS Mojave, setting up Bootcamp or purchasing the latest version of Parallels Desktop and setting up a VM of Windows or macOS Mojave.

In Topic: Wineskin on Catalina - Access on the file system

15 October 2019 - 05:48 PM

 antion, on 15 October 2019 - 04:54 PM, said:

It seems that it is a problem of VirtualDub. Opening the notepad.exe is absolutely no problem, I can access all files. That's strange.

I hope there will be a solution soon (I needed Catalina for SwiftUI).

Maybe it’s making 32Bit calls even with the 64Bit built as that’s common on Windows.

That’s weird why would you need to upgrade for SwiftUI? Is it like MoltenVK-3.0 branch?

As I’m running XCode11 on Mojave currently, I don’t use Swift anyway but I know your able to install much newer Swift toolchains that can be used within XCode if needed.

In Topic: Wineskin on Catalina - Access on the file system

15 October 2019 - 01:38 PM

I don’t officially support macOS Catalina.

Now that’s I have that outta the way, launch Wineskin.app then try launching using “Test Run” that will launch the wrapper using NSTask and that should allow permissions prompts if required, launching in that manner on Mojave allowed microphone access etc.

But it could be some other reason the app is crashing, for the foreseeable  
future I won’t be upgrading to Catalina, once CrossOver19 is available I’ll be setting up an external install and see what can be done to get Wineskin to function since CrossOver19 will be the only compatible Engine on Catalina for quite sometime.

In Topic: WineStagingGnutls3.X+ & WineStagingVulkan64Bit3.X+

14 October 2019 - 06:42 PM

Has anyone noticed any issue with the latest runtime version I uploaded? I would like any feedback before I go integrating it into a newer wrapper update I’m currently working on.

One issue I know of is the newer FreeType2 (2.10) won’t be compatible with wine versions below Wine-2.18, I’m sure nobody got the issue due to the way I mapped the runtime in the current release as wstools.bundle includes a compatible version of FreeType2 (from XQuartz 2.7.11)
The updated version of WineskinLauncher now changes dylib mapping depending on Engine version to avoid conflicts with dylib’s provided via homebrew/macports.