Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google      Sign In   
  • Create Account

Rendell001

Member Since 14 Aug 2019
Offline Last Active Oct 21 2019 11:23 AM
-----

Topics I've Started

Forge of Freedom: American Civil War – First port, annoying glitches..

19 October 2019 - 07:47 PM

Hi there, occasional lurker who decided to take the plunge with my first attempt at a game which I love but is not yet part of your database: Forge of Freedom: American Civil War by Matrix Games.

I've owned this and played it for several years on a mid 2011 iMac using Parallels / bootcamp but I really wanted a wrapper version which I could open like any other native app. As an interim step, I'd created a bottle in Crossover 18 and it generally worked but there were a couple of annoying glitches. Firstly, the music files wouldn't work (though the other sound effects and voice samples were unaffected) and secondly, the game would crash when the "Overview" tab was clicked. Aside from these glitches, I noticed that the "End turn" button would flicker slightly during play but otherwise functioned correctly.

https://pasteboard.co/ICJNqde.png

So I then decided to tackle a wrapper via the Porting Kit app. Though I'm clearly a novice, I did manage through trial and error, to replicate the Crossover bottle's performance. The same glitches are still present though in the new wrapper. I don't think this should be too involved a problem, I figure I'm just missing a framework or some other minor tweak and I should be able to get the glitches ironed out.

The game was originally published in 2006 and I've found that windows XP is the best environment for it. It uses a Flash player for some sections and also Indeo codec for some short intro sequences. I know that the music files are in WMA format but I'm wondering why they won't play when the other sounds etc are in the same format - DRM maybe? The "Overview" screen seems to be the most pressing problem - unlike all the other tabs, it's supposed to show a graphical overview of the country with the various governors superimposed on their respective states but instead just white screens or flat out crashes...

Any advice you could give me would be gratefully received!

My Mac OS X Version:
Mac OS 10.13.6 High Sierra>

My Mac Model, GPU & CPU:
iMac (27-inch, Mid 2011), AMD Radeon HD 6970M 2048 MB & 3.4 GHz Intel Core i7.

Error Log(s):